Fresh Leap 15.2 on Dell Precision 5550 - Problems with 27 inch Second screen through HDMI

Hello there

This is a new installation on the laptop model mentioned above with KDE and Full Wayland.

The laptop screen and its definition is very nice, however when I add a second screen I cannot say the same (see below).

Please note I use a Dell docking station that gets the HDMI and connects to the laptop on one of the the USB-C ports.

IIyama 27 inch screen (ProLite B2791HSU model)

I cannot get the same clear definition than on the laptop screen and also the way some items are display do not look right.

The setting I have are: 1920 x 1080 (which is its native resolution) and setting the DPI to 72.

Sometimes clicking on some icons are not fully shown or just the definition that the laptop screen has is a much better quality. Also some times some parts of the screen look darker than others.

Dell 24 inch screen

I also tried on a 7 year old 24 inch screen and with this one I managed to have a better look and feel than with the 27 inch however it is still not good enough and found by testing the same above problems.


  1. The laptop has a graphics card as follows
    nVidia TU117GLM [Quadro T1000 Mobile]
    Intel UHD Graphics
  2. Is there anything I am missing to set up or perhaps drivers I should try?
  3. Is there anyone else with a similar configuration and issues?

Any help will be appreciated :slight_smile: Thank you!

I don’t have dual screens, so I don’t know much about your problem. However, may I suggest you try KDE/Plasma with X11 (i.e. without Wayland).

I’ve been quite happy with Leap 15.2 since I installed it some time ago. However, when I last logged in (Monday), I decided to give Wayland a try. And, quite honestly, it is not ready for prime time. When I next login (probably after updating), I’ll be going back to X11.

72 DPI is an extremely low resolution for a computer screen less than 30 years old. The lower the resolution, the lower the quality. Most PC apps and environments assume a minimum DPI of 96, and many modern screens, particularly laptops, are capable of much more. Modern desktops dissuade or outright deny applying an accurate DPI WRT the physical DPI of a display screen. Matching the logical DPI to the physical DPI takes a heroic effort that is worth it only for a limited set of needs. Web browsers enforce a minimum DPI of 96 within their display ports. DPI is more often used as a scaling device, notably in Gnome. A 27" 1920x1080 screen is most often used optimally at the assumed DPI of 96, even though it’s physical DPI is about 82.

Please check that inxi is installed and install if it isn’t already, then do from Alt-F2 or Konsole:

inxi -Gxx | susepaste -n estebanc00
susepaste -n estebanc00 /var/log/Xorg.0.log

You may get an error message about upload failure, but the results should be found at . If you get an error message about Xorg.0.log not found, then do this:

susepaste -n estebanc00  .local/share/xorg/Xorg.0.log

Too new hardware. Try to use newer kernel from Kernel:stable repo:

Docking station and Full Wayland brings additional headaches.
And you not mentioned Thunderbolt 3.

Thanks for you answer. I have tested KDE/Plasma (without Wayland) and the problem I found is that by default it scales the built-in screen (laptop) and the 27" FullHD monitor to 200%. Then I go to change the scaling for the 27" screen to set it to 100% and it allows me to do it confirming with a message that changes will take effect after logging out and logging in however when I log back in the changes are not applied.

What do you mean by KDE/Plasma with X11? I do not have that option . I have Plasma, Plasma Wayland and Plasma Full Wayland.

Yes you are right, DPI 72 it was very low resolution and it did not make sense. It took me time to answer because I have been trying to test different options before replying, I would briefly describe two of them before providing the outputs that you had asked me. Please bear with me.

The first time I installed 15.2 and once I selected the packages a window popped up showing a warning with something like “Nouveau DRI/3D driver selected. This driver is experimental and not recommended for KDE Desktop or QT based app”. It asks to either agree or disagree.

I chose to agree.

After that installation the output of inxi -Gxx was

inxi -GxxGraphics:  Device-1: Intel UHD Graphics vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:9bc4           Device-2: NVIDIA TU117GLM [Quadro T1000 Mobile] vendor: Dell driver: nouveau v: kernel bus ID: 01:00.0           chip ID: 10de:1fb9e           Device-3: Realtek type: USB driver: uvcvideo bus ID: 1-11:7 chip ID: 0bda:5510           Display: x11 server: X.Org 1.20.3 compositor: kwin_x11 driver: modesetting,nouveau unloaded: fbdev,vesa           alternate: intel,nv,nvidia resolution: 1: 3840x2400~60Hz 2: 1920x1080~60Hz s-dpi: 96           OpenGL: renderer: Mesa DRI Intel UHD Graphics (Comet Lake 3x8 GT2) v: 4.6 Mesa 19.3.4 compat-v: 3.0           direct render: Yes

I will try to upload the file /var/log/Xorg* into susepaste once I finish answering here.

After the above, things did not work very well but the I went for a zypper update and although it is not perfect it worked better than before the update.

I also tried a second installation choosing to disagree to installing the Nouveau DRI/3D drivers, however when I check inxi -Gxx I see exactly the same output as the one above.

After the zypper update I manage to scale the laptop to 200% and the 27" to 100% using KDE/Wayland or FullWayland. It works okayish but some times it hangs or when trying to change display settings it hangs and I have to restart it or just logging in is very slow to a point that it takes 2 to 3 minutes to login.
So still not working well.

I was wondering and wanted to ask:

  1. Are the above shown drivers the one I should have for my hardware?
  2. Shall I try with other drivers or Nouveau is the best I could get? ( I found a driver on the Nvidia website but it does not download: Linux x64 (AMD64/EM64T) Display Driver | 440.100 | Linux 64-bit | NVIDIA)
  3. Shall I install a newer kernel? (It is currently running 5.3.18)?

Any help will be appreciate it.

Hello there

thanks for your answer. Yes I did not mention Thunderbolt 3.

Is this the correct article to switch the kernel ? or do I have to follow different steps and use 5.8 as you pointed out on the link above?

Both i7-10750H and T1000 are only a few months old. I wouldn’t expect full support from 15.2, and possibly not even from TW - yet. To find out about TW you could boot the latest live TW media to test your hardware’s support. If satisfactory, you could first try a 5.8 kernel in 15.2, and if that isn’t enough, upgrade 15.2’s X11 to the latest version from the build service repos.

Even with older (“fully supported”) hardware, a laptop with both Intel and NVidia GPUs (monikered aka Optimus) takes some effort to configure. You’ll almost certainly need Suse Prime installed to achieve success. The wildly different display densities of a laptop screen and a 27" FHD screen present their own problems even without the complication of Optimus.

PS, still waiting to see Xorg.0.log.

Thanks for your answer and yes you are right both are quite new. The Xorg.0.log failed to upload yesterday, sorry about that. Now it is on SUSE Paste

I am going to try the steps as you suggested.

  1. TW latest (check kernel) and test how it goes

  2. 15.2 with newer kernel (same as TW)

  3. If needed upgrade X11 on 15.2 to the latest.


A) To upgrade the kernel on 15.2 shall I use this article?

b) Is it worth once the kernel is upgraded to test other drivers for the NVIDIA card such as the NVIDIA drivers ?

c) Shall I consider checking and perhaps upgrading KDE (plasma or wayland) to a newer version ?

Thank you very much for all your help!

These error messages are indicative of newer Intel and NVidia hardware than the 15.2 software supports:

    19.143] (EE) Unknown chipset: NV167
    19.837] (EE) modeset(G0): glamor initialization failed
    19.949] (EE) modeset(0): [DRI2] No driver mapping found for PCI device 0x8086 / 0x9bc4
    19.949] (EE) modeset(0): Failed to initialize the DRI2 extension.

Thank you, I will start testing with TW.

Looks appropriate for the devel kernel, which is likely overkill. Probably better to apply that process but use Kernel:/stable instead.

b) Is it worth once the kernel is upgraded to test other drivers for the NVIDIA card such as the NVIDIA drivers ?
I have no idea whether you’ll find a proprietary NVidia driver matching Kernel:/HEAD or Kernel:/stable. I suspect not. Newer FOSS drivers would come from enabling X11:/XOrg/openSUSE_Leap_15.2 and using the same procedure to install as for Kernel:/HEAD.

c) Shall I consider checking and perhaps upgrading KDE (plasma or wayland) to a newer version ?
Negative re KDE/Plasma. Given nrickert’s comment about Wayland, I wouldn’t expect material help from enabling and upgrading to X11:/Wayland either, but if you’re ambitious… I’ve yet to attempt to use Wayland, and don’t see it happening in the foreseeable future either.

Note the links I have here provided can be downloaded and copied to /etc/X11/zypp/repos.d/ as a simpler alternative to the zypper ar process commonly described for adding a repo, which creates a new file in that location, subject to typing and consequent errors.