Fresh installed XEN wont boot.

Hi there. Im newbie in linux, so dont punch me if i made something wrong.

I got fresh installed OpenSUSE Leap 42.1 x64 on my server.
Hardware:
Motherboard: S5520UR
CPU: 2 x Xeon (16CPUs)
RAM: 16 GB
HDD: 4 x 1TB Seagate Disks in Raid 5 (true raid, nothing about software)

So, with opensuse all ok, but when i install XEN on open suse i got some problems. Server wont boot OpenSuse with Xen hypervizor. Last message i saw on the screen was something “DOM 0 bla bla bla” and then blank screen. Num lock wont lightup when i press it. I saw some looks like forum threads, where people talk about GPU issue (im using intel built in) with kde plasma, so i decided try to reinstall OpenSUSE with gnome. And nothing happend. Booting stoped at the same place. I tried to install xen from my CD (OpenSUSE ISO) and tried to download fresh vers. from repo. Again nothing happend. XEN just wont work at all. I tried to set up BIOS to default and swithon just one option per loading. And again i got nothing. XEN not load journals so there nothing in /var/log/xen/ and nothing about bootloading in logs and etc stuff. I just dnt know what to do. Can u help me with my problem?

Almost every BIOS (and UEFI) when set to the “default”, disables a setting which is named (sometimes) “Secure Virtual Machine Mode”; another name could be “Intel Virtualization Technology”; bottom line, the name of the BIOS/UEFI setting needed to run Virtual Machines varies from manufacturer to manufacturer.

  • Once you’ve found the BIOS/UEFI setting for Virtual Machine (Virtualisation) support, enable it.

You may also care to take a look here: <https://doc.opensuse.org/documentation/leap/virtualization/html/book.virt/index.html> – the “openSUSE Leap 42.1 Virtualization Guide”; and further here: <https://doc.opensuse.org/documentation/leap/virtualization/html/book.virt/part.virt.xen.html> – “Part IV Managing Virtual Machines with Xen”.

If you still have a problem after setting your BIOS to enable virtualization, pull out a camera (can be a phone), snap a picture of the error displayed on the screen, upload the pic somewhere on the Internet and include a link to the picture in your post.

TSU

BIOS settings (Intel VT and e.t.c) allready enabled. Im checked it twise.

About screenshot(with cellphone camera). I cant take a picture, coz there is no EROR on screen. Last thing show on screen was something like “Dom 0: something here” and after that its BLANK. Just black screen. No cursor. No reaction on NUM LOCK. Journals are clear. Before that, i have SLES 9 on that server and it was works just fine.

BTW: Im using GRUB2. System and varios folders on the partitions about 50GB (Ext4). And 2.6 TB for LVM (im use it for my guest machines).

PS: Sorry fo my Eng.

https://1.downloader.disk.yandex.ru/disk/25d4d5ad80b61d572fdbd1397e7bdb0f0fc3b77a1ef01c70d4521b3af57d6436/5783c00f/WtdK975HvYm0B6xEnUtQu5DK3M9kHfujULzPl91UFUnvzbhRiaBXjQyjlxjA8S-sJQ-Evpmu2m7ZYa-9FI2kpQ%3D%3D?uid=0&filename=kwge3YC2DC0.jpg&disposition=inline&hash=&limit=0&content_type=image%2Fjpeg&fsize=91001&hid=0d9c2b6e57f91cb170a9ba28bc7118f3&media_type=image&tknv=v2&etag=e56e0e19b3f3115b96755489d3329e93

I got this if i load OpenSUSE + Xen with deleted “quiet” param, and added “nomodeset plymouth.enable=0” param.

Im also tryed to load with “noacpi” param, it takes no effect.
Googling that line gives (pci 00:blablabla) gives me no info. IDK what to do, can anyone say what i can to do with that?

Did a Google search of the error in your camera pic “io address conflict with ACPI CPU throttle io”

Skimmed the results,
Suggests that you may need to flip some ACPI setting in your BIOS (no detailed identification what setting).
Recommend you step through your BIOS settings looking for anything related to ACPI and experiment. AFAIK there isn’t any ACPI setting that can’t be tried, AFAIK you should always be able to power down and power back up again and reach your BIOS to change settings again.

And, then you might submit your findings to http://bugzilla.opensuse.org.
There are some search results that suggest that there is an upstream kernel configuration that assumes that a “kernel ring buffer” is larger(more addresses) than what exists on your machine… Which makes sense, your error might be interpreted as “trying to write data to an address that belongs to something else already.”

TSU

Ive played with some options related to ACPI in different variations. Im turned off C3 ACPI table support and turned on Execute Bite (or something looks like that). And now i passed PCI bridge to BUS succesfull (last time i stuck on that point). But there is another error now.
https://3.downloader.disk.yandex.ru/disk/bfa7cdf1193a8aaafdce7de88c653e7118f5ae15aacb7614bd994faf90f8ad47/5784d9b0/WtdK975HvYm0B6xEnUtQu1tQ7pGCr3UUlfzBJoZhuVu0-j4MBwUA0l07q6TS9gX2ExItP6E99ZNxLCGqa-zLHw%3D%3D?uid=0&filename=ynPsF1PlaLk.jpg&disposition=inline&hash=&limit=0&content_type=image%2Fjpeg&fsize=255730&hid=67e354d3378d6365f3e28e28305fe07a&media_type=image&tknv=v2&etag=3827c7f8a6a044c93fadf7da901dc491

DWARF2 unwinder stuck at ret_from_fork+0x4d/0x77

https://4.downloader.disk.yandex.ru/preview/f2d805f07bc9ac97e11e255f9bb4a7bdba89b9460f195eb608edd2b37f15f9cb/inf/WtdK975HvYm0B6xEnUtQu4O8hCZIc8MLTL_wn_Ge_lYwDC5kvZKE5IO_-eggFZ01b0d7QlcrOHSxB3ilv2k9Bw%3D%3D?uid=5995379&filename=ynPsF1PlaLk.jpg&disposition=inline&hash=&limit=0&content_type=image%2Fjpeg&tknv=v2&size=1249x539
Re-upload of image.

The above link leads to a Russian language HTTP Error 403.
Please post your image in something which the rest of the planet Earth may be able to access; such as the openSUSE Paste (HTTP-only): <SUSE Paste;

  • N.B.:
    the default is “code” – you have to select “image” – tabs “top right”.

I found way to fix issue with DWARF2 unwinder stuck at ret_to_folk
In grub2, after module=linux_*-xen resume=/dev/sda2 - i deleted that resume=/dev/sda2

And now loading stops at another error. And i dont even see that error. Screenshot below.

https://3.downloader.disk.yandex.ru/preview/a19b2f8aafacfe77e921b6092b79c7507a3ddf581665d419a5efb6ff67ad8f82/inf/WtdK975HvYm0B6xEnUtQu04jjlvLSCLzYVY2D4pN8mlU9-PmhZ4_kGR-Zwso9yOESKQZeR3ovaDQT9Zp4XB4vg%3D%3D?uid=5995379&filename=n_ng3CXZ4SU.jpg&disposition=inline&hash=&limit=0&content_type=image%2Fjpeg&tknv=v2&size=1249x495
link to pic - https://drive.google.com/file/d/0B1gqabvqdW3aZldLV1dvLVpjUWc/view
megasas: INIT adaper done - and nothing happend. Im trying to find out what happening.
BTW (loading passed to that moment with “nomodeset” param in grub2).

Although I don’t see an error in this pic, the info on the screen relates to recognizing and mounting USB devices, specifically using a USB Hub which may an external device and not necessarily referring to your machine’s internal hardware.

I’ve found BIOS/Hardware or even non-Desktop support for USB problematic over the years, if your boot or OS partitions are not on USB devices, you should physically disconnect all your USB devices when you boot.

TSU

Good morning. Yep, u right heres no error on the screen, but loading stops. If i turnoff nomodeset then i see message " [OK] basic target reached (or something like that). And booting stops on that moment. Ill try to boot without usb devices. Thanks for ur answers.

Im stuck right here. Cant do anything.

I think my hardware too old for that brend new LEAP.
Im downloaded OpenSUSE13.1 (3.6 instead of LEAP 4.1) and wanna try to set it up, maybe that will work (at that server was sles on 2.6 kernel, so idk what i can do else).

When i got any result, i will write here. Maybe something for old hardware missing in LEAP. idk.