Fresh install with dual boot: problem starting Windows 7...


I just installed OpenSuse 11.2 in a desktop PC that already had Windows 7 installed.
When trying the Installation CD, I accidentally pressed the first option (I think its “Install from Hard Disk”)… Then I noticed the system reboot and begun to install and run something from the HD. I decided to shutdown the PC… and I noticed that Windows did not start anymore, but a kind of linux installation process from the HD, again.

Then, I decided to proceed with the installation using th CD. It was completed ok, and I was happy to see that Windows partitions (NTFS) were respected and data kept.
Yet, when rebooting, I’m offered to start openSuse or Windows; when I select Windows, I get this wired linux installation process from HD again… and Windows does not start. Is there something I can do to eliminate that Linux install process on the Windows boot record (I don’t know if that the correct tech term), and restore Windows startup ?

I still have Windows software installed I need to run from time to time, and it’d be a problem not to be able to restart it again. Please help.


This is for a previous version of SUSE but it applies to you. Read it carefully.
You arrived at the same issue in a slightly different way.

Update from Suse 11.0 to 11.1 - Page 2 - openSUSE Forums

Also for win7, you may need this if you don’t have a proper win7 install disk
Download Windows 7 System Recovery Discs — The NeoSmart Files

Unfortunately, didn’t work :frowning:

I got to try even Step 4… didn’t work either.

And unfortunately, when you just come back with ‘it didn’t work’ I’m not sure I can help.

Take it from me this is fixable. But you need to explain what you have done and what happens in the process.

Tell us:

  • Do you have a working openSUSE system?
  • Are windows files/partition still in place?

And unfortunately, when you just come back with ‘it didn’t work’ I’m not sure I can help.

There was not much more to say my friend … :wink: but if you say there is something that can be done, I can tell you the story and answer the specific questions you ask:

1- I executed the Win 7 Repair option from the DVD
2- I selected the “Repair boot” option
3- It said it was fixed
4- I restarted the system
5- It could not startup anything at all; the ROM showed an error message indicating there was no bootable device found :open_mouth:
6- Then I inserted the OpenSuse 11.2 DVD, and selected the option to checkup the system.
7- It found the boot problem, and fixed it. The problem is that the fix was to show up only suse start up, and not Windows any more (on the GRUB menu).
8- I tried Step 4… was even worst: the system didn’t boot either (for both Win and Suse), and the suse dvd could not repair the boot, until a second pass of the system check-up.

One thing I noticed, is that when I exit the suse chek-up software to reboot the system, it showed a blue screen with a menu that said “installation failed”, and then showed menues to restart or turn off; I think these last screens are the remains of the install software that the openSuse DVD copied on the boot sector, when all these problem originated: when I accidentally pressed the option “Install from HarDisk” of the suse DVD.

As for your questions:

Do you have a working openSUSE system?
Yes… suse installed correctly from the DVD and now I’m working with it, accesing the NTFS partitions for read/write.

Are windows files/partition still in place?
Yes, as a matter of fact, when I tried Step 4, I could acces to C: from command line. It is still there.

In the root of windows, called C:
do you see a file bootmgr

Yep, the file is there:

bootmgr, 374,6 kb, Jul-13-09

I extract this quote from the link I posted earlier. Where you read Vista / replace it with WIN7

The problem is that the Vista boot manager’s database now has a boot entry for the openSUSE installation (that is what you are seeing) and it has a higher priority than the Vista entry. Grub successfully calls the Vista boot loader but it is looping through this other entry and never gets to the entry needed to start Vista.

The solution is to remove the added entry and to restore the original Vista entry.

Vista and WIN7 are not quite the same and I think WIN7 has a folder ‘boot’. I suggest you google on restoring the original boot code, M$ should have some info on it.
Or, I suspect, if you used SUSE to delete the bootmgr and in /boot delete the file ‘bcd’. When you then use the auto-repair it should get fixed.
Or manually edit the file with bcdedit using the repair dvd.
Google is your friend, me too…:wink: