Fresh install. Stuck at KDE login


I just finish installing. On KDE login, I am trying to login but it comes back to the same login page again. Please advise me on what to do?

Note: I am moving from fedora 23 to Opensuse 42.1. So, I am total new for this distro. For this, please guide me.

And thank you.

Some things to check:

Can you login to “Icewm”? On the login screen, look where it says “Plasma 5” (or maybe “KDE Plasma desktop”) toward the left. You can select other possible desktops there. And at least “Icewm” should be available.

Can you login to a command line terminal? Use CTRL-ALT-F1 to get a terminal screen. See if you can login there. If you are unfamiliar with using the terminal, just use the “logout” command when done. And then CTRL-ALT-F7 should get you back to the graphic login screen.

The reason for these tests is to try to narrow down what might be causing your problems.

I tried all three GUI’s nothing working. Yes the terminal is working fine. When I returned back to GUI it is stuck with no respond from mouse and keyboard.

I still suspect the graphics driver, I am using Nvidia. If I can add the repos for Nvidia from the command and do the install maybe it will work.

You could login as root. Then run “yast”. It will be an “ncurses” version (all ASCII characters), and perhaps a little awkward to use. But, yes, you could add repos and install software that way.

You might prefer to try adding “nomodeset” to the boot command line.

On the boot screen, hit ‘e’. That allows you to edit the command line.
Scroll down until you find a line that begins “linux” (or maybe “linuxefi”).
Hit the END key to get to the end of that line.
Enter " nomodeset".
Resume booting (there will be a message on the screen telling you the keys to use for that.

For testing, please provide me with the command to add the repo plus the nvidia link.

Then I think you need to run “zypper update” under root which will install the nvidia driver. Right? then restart?

found this link .

No you have to install the driver and it is easiest from command line yast.

All details here

What I did that worked for me.

sudo zypper ar nvidia

zypper update

zypper inr

Note: I did it using ssh from a laptop at home. And of course, it can be done from the machine it self using (CTRL + ALT + F1).

Thanks a lot for the help.