Fresh install. Packman repos installed. Can't switch MM packages to Packman. Yast complains.

Just did a fresh Tumbleweed install with Plasma
Installed smplayer, mplayer, VLC. They all come from openSUSE repos.
Much not even offered from Packman.
Not even video codecs as far as my search has shown.
If I try and change provider to Packman endless unresolved libs and other files it’s just a hell of requires but not provided and so forth. openSUSE files are old versions in many caces.
What has happened? We use to be able to simply installed the package from Packman and it just worked… Now openSUSE has decided it will ship all these players with broken codecs.
I can’t even watch a video. I get audio but no video.
What happened to the codecs from Packman?
How are we supposed to fix this?

The packman repository is a third party provider, you need to followup with them… I would surmise the recent update along with gstreamer (AFAIK bad) breakages mean things need fixing, submitting, review etc before they get updated.

For example;

My wonder is why the packagers have decided to do everything they can to make sure multimedia doesn’t just work anymore? When you try and switch to Packman you get irresolvable packages to here and back. Why did my installation of 5 hours ago just play these files and my new installation just doesn’t? h264 isn’t in the openSUSE VLC so no video. VLC ships with the correct codecs. If you try and switch to Packman VLC a wall of irresolvable packages. Try and play a video in smplayer. No video. Look of h264 in Yast and you won’t find it. What has happened? Is the distro trying to run people who need multimedia off?

Because things a being rebuilt all the time at the moment (which do filter through to packman), some things need a manual trigger to get them going again.

Have you looked at OBS…? Head down to the bottom… it’s very busy at the moment… 80,000 jobs blocked for x86_64…

If you look at VLC, it’s failing to build both on OBS and Packman…

Oh. That’s a lot of packages. How did they manage not breaking existing installs multimedia? There’s been a ongoing forcing of openSUSE packages pushing out Packman packages slowly over time. VLC was just one. You either accept or don’t dup. The security implications of that are not ideal. Oh well can’t be helped. You progress or you don’t but it makes openSUSE less attractive in the meantime. I can’t see shipping a multimedia player like VLC that can’t do h264 which is now not encumbered by any patents. I mean it’s willfully broken and openSUSE decided it was going to push Packman aside.

If VLC is the only thing your wanting then look at switching to VideoLan rather than packman?

VLC is only a last resort.
I’d much prefer MVP / Smplayer was working. with video and subtitle support.
If it won’t play then use VLC.

Well still no H264 decoding. VLC actually says it’s missing the H264 codec.
I’ve got gstreamer-plugins-bad from Packman installed.
What else is missing that’s blocking video playback in mvp or vlc?
I know they some packages are still building but vlc and mvp don’t complain of missing dependencies.
I hear the audio just fine.

Still fixes for VLC in the wind… an update has just been pushed to multimedia:libs…

OK. Still waiting on Packman too then I guess.
Packman has a newer version of vlc than openSUSE Tumbleweed provides.
Sorry I really don’t know where else to ask about this.

OK. I installed from Videolan from one click as suggested. Again unresolvables that would break Tumbleweed if solutions were accepted.
Still no video playback after 9 days even after doing as suggested. Broken/missing codecs.
Who do you need to communicate with to get this fixed?

My old installs still play video my main desktop with a news installation does not.
What actual files are broken or missing? Why can my old install that are up to day play the media that may main desktop can’t?
Is there a pattern I can install that will fix this? I’ve been duping every day to try and get these files that are missing or broken.

With help from the provision of a filelist from a helpful soul in #packman I discovered I was missing vlc-vdapu.
Once this was installed I have video playback in all my players.
Something it pulled in fixed it.
Perhaps the openSUSE multimedia pattern is broken.
This should have been pulled in.
Thanks for the fish.