Fresh install on HP AIO, I messed up partitioning

500GB HDD partitioned 300GB, 100GB, both using ext4 & 10GB swap. I was about 90% process of getting things set up.before that fubar’d partition scheme was wrong.

Problem is I set the 100GB as /home , and the 300GB as /

Is there any way to make the 100 partition as /
and the 300 partition as /home
??

I put gparted in but it doesn’t run for some reason. I tried ‘parted’, but I am not a good enough terminal user, and fear I will mess it up really good if I try that.
I’ve tried the YaST partioner, but can’t find a way to resize partitions, then put the puzzle pieces back the way way they should be.

HELP & Suggestions??

Hi Bill, you cannot manipulate mounted partitions, so you cannot change your layout from the running system but you can do something from a live DVD or another installed system that doesn’t use the partitions you are trying to change.
The options you are asking for depend on the layout of your disk, so please post the output of:

fdisk -l

I am in the process of doing another fresh install, so I can’t give tho output you’ve asked for.
Need the practice i=of installing I guess.

OK, everybody here is used to learning by trial and error lol!

For what its worth This is what it looks like now.

**Disk /dev/sda: 465.76 GiB, 500107862016 bytes, 976773168 sectors**
Disk model: ST500DM009-2F110
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 5D0528B1-47FF-4D09-B04B-E16E05BAFD3E

**Device****    Start****      End****  Sectors**** Size****Type**
/dev/sda1       2048   1026047   1024000  500M Microsoft basic data
/dev/sda2    1026048 210741247 209715200  100G Linux filesystem **<< / >>**
/dev/sda3  210741248 839886847 629145600  300G Linux filesystem **<< /home/bill >>**
/dev/sda4  839886848 860858367  20971520   10G Linux swap
/dev/sda5  860858368 976773119 115914752 55.3G Linux filesystem

For the record, the 100G for the System is huge overkill. Launch GParted and look at how small the percentage of use is. I am running 15.3 with a 25GiB System/root partition and it is not even half full. I have used 25GiB or smaller for several years, never even approached filling it.

# df -h /
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda10       18G   11G  5.9G  65% /

If I didn’t have 9 kernels installed instead of 2, the used and avail would probably more than swap places, <5.9G/35% used, >11G/65% free. 100G for a / would produce a tragic waste of space here.

For the record, what is written above is certainly true for a basic installation on EXT4 but 100 GB may not be such a waste for a BTRFS install with snapshots or for some use profiles that need huge chunks on /var or elsewhere, like KVM virtual machines, mail servers or some databases, just to name a few.
So it really depends on what the user plans to do with that system.

I am willing to reduce the size of /dev/sda2 (/) partition, and increasing size of /dev/sda5.
But the previous fresh install of Leap 15.3, I installed GPARTED, and it ran once, then never again. I looked like it was starting up, but went poof! Top nor ps -ef did not show it was there.

I’ll try to install gparted and run it again(if it will)

Thanks for all the responses and inputs!
Bill_L

GParted works best with Gnome or other GTK based desktops and might have problems when run from KDE; sorry I don’t have Leap 15.3 atm so cannot check it myself.
Anyway you have to run it from another system to be able to change the current root filesystem (maybe there is a spare/rescue system on sda5?).
Another option is to download the live GParted iso here GParted -- Live CD/USB/PXE/HD and burn it to an USB drive; that version might allow more options than the one packaged for openSUSE.

You may also use the YaST partitioner (run from another system, again) to resize a partition:

  • select “All devices”, then select the partition you want to resize,
  • then go to the “Device” menu and choose “Resize…”

Moving back sda3 (and then enlarge it) might be more tricky depending on the tool you use.
YaST partitioner forbids moving a partition with a filesystem already created on it.
GParted might or might not allow moving a filesystem already created, depending on filesystem type, size etc.
Of course you always can backup all your data, then reformat sda3 and restore your data but I would leave that as the last option.

If you want to enlarge sda5, you might shrink sda2, move the swap space in the free space, then delete the existing swap and gain 10 GB to move/enlarge (or reformat) sda5.
Of course, backup all your important data before doing anything of the above (but I guess you are already used to that practice).

Gparted works on all my other Leap 15.3 machines. so I can give it another try on the HP AIO.
I will look at the GParted link you provided to see what it has to offer.

I do have another networked machine the HP AIO can ‘talk’ to and vice versa, if that is an option for using the YaST Partitioner.
OR try to ind my Leap Live USB drive(if I haven’t written over it ( < very possible).

I installed the KDE kdepartitionmanager, but it appears to be pretty much the same as GParted.