Fresh install of openSuse 12.2: network does not work (wired and wireless)

Hi,

I first tested openSuse 12.2 in VirtuabBox within Mint 12, and network worked just fine; Internet was connected

Then, I installed in a HD partition, sharing wth Mint 12. I had some trouble booting Mint 12, so I restored Mint’s Grub2 menu, I executed “update-grub”, and OpenSuse entry was there; there were like 4 repeated entries for openSuse; I checked the grub.cfg in Mint, and it created different boot commands for each of the 4.
Any way, I booted openSuse with the new Mint Grub2 menu, and I found that the fancy boot splash screen was not there for openSuse… When booting from suse’s grub2, the slpash appeared. Now, boot commands are shown. It finally started up…
Then, I noticed that no network icon was in the task bar; Firefox did not work at all. I got into network manager in Yast, and both wired and wireless cards were de-activated and not configured (kind of not normal… as VirtualBox networking was catched automatically well by os 12.2 installed there)
After configuration and activation, network still does not work; internet is not detected… :frowning:

In Mint 12, net configuration is shown like this:

guillermo@guillermo-desktop ~ $ ifconfig
eth0 Link encap:Ethernet HWaddr 00:1c:c0:80:62:19
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:20 Memory:d3200000-d3220000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:52 errors:0 dropped:0 overruns:0 frame:0
TX packets:52 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4080 (4.0 KB) TX bytes:4080 (4.0 KB)

wlan0 Link encap:Ethernet HWaddr 68:7f:74:66:db:0c
inet addr:192.168.0.101 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::6a7f:74ff:fe66:db0c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:9144 errors:0 dropped:0 overruns:0 frame:0
TX packets:9197 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:7378312 (7.3 MB) TX bytes:1632003 (1.6 MB)

I have a cable ISP with a Cisco cablemodem and a wireless router

From a terminal
Post for us

/sbin/lspci -nnk

I had a simalir issue, i had to change the device activation in yast to “At Boot Time” from “On Cable Connection”, little bug I think.

gav616

I had a simalir issue, i had to change the device activation in yast to “At Boot Time” from “On Cable Connection”, little bug I think.

I already have “At boot time”; not working

caf4926](http://forums.opensuse.org/members/caf4926.html)

Here the result of the command:

guillermo@linux-oi8k:~> /sbin/lspci -nnk
**00:00.0 Host bridge [0600]: Intel Corporation 82G35 Express DRAM Controller [8086:2980] (rev 03) **
**Subsystem: Intel Corporation Device [8086:d701] **
**00:01.0 PCI bridge [0604]: Intel Corporation 82G35 Express PCI Express Root Port [8086:2981] (rev 03) **
**Kernel driver in use: pcieport **
**00:19.0 Ethernet controller [0200]: Intel Corporation 82566DC Gigabit Network Connection [8086:104b] (rev 02) **
**Subsystem: Intel Corporation Device [8086:d701] **
**Kernel driver in use: e1000e **
**00:1a.0 USB controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 [8086:2834] (rev 02) **
**Subsystem: Intel Corporation Device [8086:d701] **
**Kernel driver in use: uhci_hcd **
**00:1a.1 USB controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 [8086:2835] (rev 02) **
**Subsystem: Intel Corporation Device [8086:d701] **
**Kernel driver in use: uhci_hcd **
**00:1a.7 USB controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 [8086:283a] (rev 02) **
**Subsystem: Intel Corporation Device [8086:d701] **
**Kernel driver in use: ehci_hcd **
**00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 02) **
**Subsystem: Intel Corporation Device [8086:d701] **
**Kernel driver in use: snd_hda_intel **
**00:1c.0 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 [8086:283f] (rev 02) **
**Kernel driver in use: pcieport **
**00:1c.1 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 [8086:2841] (rev 02) **
**Kernel driver in use: pcieport **
**00:1c.2 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 [8086:2843] (rev 02) **
**Kernel driver in use: pcieport **
**00:1d.0 USB controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 [8086:2830] (rev 02) **
**Subsystem: Intel Corporation Device [8086:d701] **
**Kernel driver in use: uhci_hcd **
**00:1d.1 USB controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 [8086:2831] (rev 02) **
**Subsystem: Intel Corporation Device [8086:d701] **
**Kernel driver in use: uhci_hcd **
**00:1d.2 USB controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 [8086:2832] (rev 02) **
Subsystem: Intel Corporation Device [8086:d701]
Kernel driver in use: uhci_hcd
00:1d.7 USB controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 [8086:2836] (rev 02)
Subsystem: Intel Corporation Device [8086:d701]
Kernel driver in use: ehci_hcd
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev f2)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801HB/HR (ICH8/R) LPC Interface Controller [8086:2810] (rev 02)
Subsystem: Intel Corporation Device [8086:d701]
00:1f.2 IDE interface [0101]: Intel Corporation 82801H (ICH8 Family) 4 port SATA Controller [IDE mode] [8086:2820] (rev 02)
Subsystem: Intel Corporation Device [8086:d701]
Kernel driver in use: ata_piix
00:1f.3 SMBus [0c05]: Intel Corporation 82801H (ICH8 Family) SMBus Controller [8086:283e] (rev 02)
Subsystem: Intel Corporation Device [8086:d701]
Kernel driver in use: i801_smbus
00:1f.5 IDE interface [0101]: Intel Corporation 82801HR/HO/HH (ICH8R/DO/DH) 2 port SATA Controller [IDE mode] [8086:2825] (rev 02)
Subsystem: Intel Corporation Device [8086:d701]
Kernel driver in use: ata_piix
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GT216 [GeForce GT 220] [10de:0a20] (rev a2)
Subsystem: Giga-byte Technology Device [1458:34d6]
Kernel driver in use: nouveau
01:00.1 Audio device [0403]: NVIDIA Corporation High Definition Audio Controller [10de:0be2] (rev a1)
Subsystem: Giga-byte Technology Device [1458:34d6]
Kernel driver in use: snd_hda_intel
04:00.0 IDE interface [0101]: JMicron Technology Corp. JMB368 IDE controller [197b:2368]
Subsystem: JMicron Technology Corp. JMB368 IDE controller [197b:2368]
Kernel driver in use: pata_jmicron
05:03.0 Network controller [0280]: Ralink corp. RT2561/RT61 802.11g PCI [1814:0301]
Subsystem: Linksys WMP54G v4.1 [1737:0055]
Kernel driver in use: rt61pci
05:05.0 FireWire (IEEE 1394) [0c00]: LSI Corporation FW322/323 [TrueFire] 1394a Controller [11c1:5811] (rev 70)
Subsystem: Intel Corporation Device [8086:d701]
Kernel driver in use: firewire_ohci

By the way… when configuring the Wireless network, and press the “refresh” button, it detects the name of my wireless network; I select it, type in the WEB… no message at all, and network seem not to run, as Firefox keeps telling me of page not founds when I try to browse

This is your wired connection:

**05:03.0 Network controller [0280]: Ralink corp. RT2561/RT61 802.11g PCI [1814:0301]**
         **Subsystem: Linksys WMP54G v4.1 [1737:0055]**
         **Kernel driver in use: rt61pci**

Am I to understand your wireless is USB? As it’s not in the PCI output.
Do you mean WEP?

type in the WEB…

Ideally you should use WPA security, it’s safer and causes less complications for users.

FYI: The wired connection looks OK and it’s very unusual that a wired connection doesn’t work. Can you login to your router?

Hello,

I am not sure if it is the right topic, but here is the issue.

I have recently installed OpenSuse 12.2, parallel to the already existing Win Xp system. They both seem to boot ok.
But, the problem is that I cannot access internet in OSuse 12.2.
From the two existing methods of configuration, at first I used ifup. After that I found out that it is possible to start NetworkManager, by chosing it from Network Settings, Yast.
In Win Xp I am using Wired LAN. I have typed the IP settings in NetworkManager IPv4, chosing “manual”.

http://i47.tinypic.com/158qj6.png

I have tried many options, from auto to manual, and others.

http://i49.tinypic.com/2a4r600.png

After looking through the internet related info, I tried to chose “Loop … DHCP …”, so appeared the following error message.

http://i46.tinypic.com/aue70w.png

As the internet connection did not appear I have check out the mentioned option.

I don’t know maybe it can help to solve it, after typing /sbin/lspci -nnk:

vladimir@linux-yqxz:~> /sbin/lspci -nnk
00:00.0 Host bridge [0600]: Silicon Integrated Systems [SiS] 671MX [1039:0671]
Subsystem: Elitegroup Computer Systems Device [1019:0671]
Kernel driver in use: agpgart-sis
00:01.0 PCI bridge [0604]: Silicon Integrated Systems [SiS] AGP Port (virtual PCI-to-PCI bridge) [1039:0003]
00:02.0 ISA bridge [0601]: Silicon Integrated Systems [SiS] SiS968 [MuTIOL Media IO] [1039:0968] (rev 01)
00:02.5 IDE interface [0101]: Silicon Integrated Systems [SiS] 5513 IDE Controller [1039:5513] (rev 01)
Subsystem: Elitegroup Computer Systems Device [1019:5513]
Kernel driver in use: pata_sis
00:03.0 USB controller [0c03]: Silicon Integrated Systems [SiS] USB 1.1 Controller [1039:7001] (rev 0f)
Subsystem: Elitegroup Computer Systems Device [1019:7001]
Kernel driver in use: ohci_hcd
00:03.1 USB controller [0c03]: Silicon Integrated Systems [SiS] USB 1.1 Controller [1039:7001] (rev 0f)
Subsystem: Elitegroup Computer Systems Device [1019:7001]
Kernel driver in use: ohci_hcd
00:03.3 USB controller [0c03]: Silicon Integrated Systems [SiS] USB 2.0 Controller [1039:7002]
Subsystem: Elitegroup Computer Systems Device [1019:7002]
Kernel driver in use: ehci_hcd
00:05.0 IDE interface [0101]: Silicon Integrated Systems [SiS] SATA Controller / IDE mode [1039:1183] (rev 03)
Subsystem: Elitegroup Computer Systems Device [1019:1180]
Kernel driver in use: sata_sis
00:06.0 PCI bridge [0604]: Silicon Integrated Systems [SiS] PCI-to-PCI bridge [1039:000a]
Kernel driver in use: pcieport
00:07.0 PCI bridge [0604]: Silicon Integrated Systems [SiS] PCI-to-PCI bridge [1039:000a]
Kernel driver in use: pcieport
00:0f.0 Audio device [0403]: Silicon Integrated Systems [SiS] Azalia Audio Controller [1039:7502]
Subsystem: Elitegroup Computer Systems Device [1019:1386]
Kernel driver in use: snd_hda_intel
00:1f.0 PCI bridge [0604]: Silicon Integrated Systems [SiS] PCI-to-PCI bridge [1039:0004]
Kernel driver in use: pcieport
01:00.0 VGA compatible controller [0300]: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter [1039:6351] (rev 10)
Subsystem: Elitegroup Computer Systems Device [1019:6351]
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 01)
Subsystem: Elitegroup Computer Systems Device [1019:8136]
Kernel driver in use: r8169

I am a bit new to Linux, so it is a bit difficult for me now to use the Konsole.
It is very possible that maybe I didn’t check the right option, or typed the right data.

Thanks in advance for advice regarding the Internet connection issue. :slight_smile:

Please help me with this topic, if it is not enough information, I can provide more.

Thank you

On 12/04/2012 03:56 PM, koloboc wrote:
>
> Please help me with this topic, if it is not enough information, I can
> provide more.

With manual configuration (ifup) and a static IP, be sure you get the DNS and
default routing correct. With DHCP and NM, those are handled for you.

You should post the output of the following commands:


/sbin/ifconfig
route -n
cat /etc/resolv.conf

Your lspci output does not show any wireless device. If it uses a USB
connection, you should post the output of ‘lsusb’.

I have typed the IP settings in NetworkManager IPv4, chosing “manual”.
Why .

Hello guys,

Thank you a lot for your reply.

lwfinger,
I don’t have a Wireless connection, I am using a wired connection (Wired LAN). And I am not sure I understood right what you typed about DHCP and NM, but here is what appeared after typing in konsole:

vladimir@linux-yqxz:~> cat /etc/resolv.conf

/etc/resolv.conf file autogenerated by netconfig!

Before you change this file manually, consider to define the

static DNS configuration using the following variables in the

/etc/sysconfig/network/config file:

NETCONFIG_DNS_STATIC_SEARCHLIST

NETCONFIG_DNS_STATIC_SERVERS

NETCONFIG_DNS_FORWARDER

or disable DNS configuration updates via netconfig by setting:

NETCONFIG_DNS_POLICY=’’

See also the netconfig(8) manual page and other documentation.

Note: Manual change of this file disables netconfig too, but

may get lost when this file contains comments or empty lines

only, the netconfig settings are same with settings in this

file and in case of a “netconfig update -f” call.

Please remove (at least) this line when you modify the file!

nameserver 87.248.160.5

vladimir@linux-yqxz:~> /sbin/ifconfig
eth0 Link encap:Ethernet HWaddr 00:1E:90:38:0A:8A
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:140 errors:0 dropped:0 overruns:0 frame:0
TX packets:140 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:12017 (11.7 Kb) TX bytes:12017 (11.7 Kb)

caf4926,

Because I have tried other methods as well, at first it was automatic. But Ok, I will put is back auto if it is better.
There is still no connection.

Thank you for your advice :slight_smile:

I have some news.

Following the suggestion, I have chosen the ifup method. I have filled in the fields which I know, plus the “Routing” compartment. Maybe it is not enough, but the there is some progress in this, because when I open the internet browser (Firefox), it types the status “looking up for site…”, so it is not “Server not found” any more. Anyway I cannot access the internet.
I have tried some variants of configurating, typing and checking, but this is the result so far.

Here is the configuration

http://i45.tinypic.com/2rh8pqf.png

http://i48.tinypic.com/vik8kx.png

http://i49.tinypic.com/14dzucp.png

http://i47.tinypic.com/do5tth.png

I tried not to “touch” filed I don’t know, so it is almost like default.
Please, if it is possible and you know maybe I should check some fields or type something, let me know.
Thank you again for information

On 12/05/2012 03:36 PM, koloboc wrote:
>
> [image: http://i49.tinypic.com/14dzucp.png]

on that slide, change
87.248.160.5 to 8.8.8.8
and
217.26.150.4 to 8.8.4.4

and add to the Name Server 3 line:
2001:4860:4860::8888

and, press ok
then in a terminal


su -     (give root password)
/etc/init.d/network restart

and, when the networks is back up, see if you can browse to
www.google.com, give it a try…

if you still can not get to the net: just leave those 8.8.etc numbers in
there (for now–they are what i use, and they work), and see what others
have to say…


dd http://tinyurl.com/DD-Caveat