Fresh install of Leap . . . where is my wifi?? And, Yast how to + "Man who carries Pack"?

Folks:

Just did a fresh install of LEAP 15.3 to my '09 MBP due to problems with ubuntu Hirsute wifi drivers being lost . . . so, I did a basic install and then added the MATE DE, and all of that went well . . . via net installer on ethernet.

Looking in the toolbar there is no “network” applet . . . so I tried a few moves to get wifi scanned . . . I’ve either “forgotten” or never knew how to add wifi network into SUSE?? Could somebody link me to that data???

And, then, went through the problems with Packman repos in my TW distro a little bit ago, and I changed to an ftp location . . . I tried to use Yast Repositories to add Packman, I clicked “community sources”??? and then click “go” . . . and the cig bar starts and then in a couple seconds, “repositories could not be loaded”???

Is Packman the only repository that would be found there? I vaguely recall that should be how to add Packman?? Or, is there a way to add it via zypper??

Right now the most pressing concern would be to get wifi going, then after that, the “Man who Carries Pack” . . . manually searched for and set to an alternative mirror???

Quite a few questions just in one thread!

First of all: openSUSE Leap 15.3 is still Beta so …

You are expecting a “network applet” so i guess you are managing your network with NetworkManager. Which applet you need depends on your DE. However you can always use nmcli (on the command line) or nmtui (started via command line but semi-graphics) to interact with NetworkManager and to setup your network access.

If you are managing your network with wicked then YaST is the tool which will help you to setup your network access.

# zypper addrepo --help

should tell you how to add a repository and here

http://packman.links2linux.de/mirrors

you can find a list of Packman mirrors.

Regards

susejunky

@susejunky:

Thanks, I’ll check through that in a bit . . . thought I saw “wicked” somewhere in the install . . . ??

Yast/wicked doesn’t seem to be showing any wifi options?? Since this is a Mac, would I need to add “broadcom wifi drivers” or something like that to get wifi working?? One of the nicer features to ye olde ubuntu is that they have “Add’l Drivers” app, which searches for wifi drivers and installs them . . . does SUSE have this kind of app??

Or is this where switching from wicked to “network manager” would get that set up and get the right drivers for the wifi card installed??

Please show the result of (must be done as “root”)

#  hwinfo --netcard

Both wicked and NetworkManager should work (NetworkManager will probably offer more comfort if you have to switch between networks frequently).

Regards

susejunky

Jumping out for a bit, but I saw that there are some commands to try on wifi card??

26: PCI 400.0: 0280 Network controller                          
  [Created at pci.386]
  Unique ID: YmUS.jnA1zEZx189
  Parent ID: Rgik.RRGuB29h369
  SysFS ID: /devices/pci0000:00/0000:00:15.0/0000:04:00.0
  SysFS BusID: 0000:04:00.0
  Hardware Class: network
  Model: "Apple AirPort Extreme"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x432b "BCM4322 802.11a/b/g/n Wireless LAN Controller"
  SubVendor: pci 0x106b "Apple Inc."
  SubDevice: pci 0x008d "AirPort Extreme"
  Revision: 0x01
  Driver: "b43-pci-bridge"
  Driver Modules: "ssb"
  Memory Range: 0xd3200000-0xd3203fff (rw,non-prefetchable)
  IRQ: 18 (no events)
  Module Alias: "pci:v000014E4d0000432Bsv0000106Bsd0000008Dbc02sc80i00"
  Driver Info #0:
    Driver Status: ssb is active
    Driver Activation Cmd: "modprobe ssb"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #19 (PCI bridge)

29: PCI 0a.0: 0200 Ethernet controller
  [Created at pci.386]
  Unique ID: rBUF.PWmYQHojxY6
  SysFS ID: /devices/pci0000:00/0000:00:0a.0
  SysFS BusID: 0000:00:0a.0
  Hardware Class: network
  Model: "nVidia Apple iMac 9,1"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x0ab0 "MCP79 Ethernet"
  SubVendor: pci 0x10de "nVidia Corporation"
  SubDevice: pci 0xcb79 "Apple iMac 9,1"
  Revision: 0xb1
  Driver: "forcedeth"
  Driver Modules: "forcedeth"
  Device File: eth0
  Memory Range: 0xd3586000-0xd3586fff (rw,non-prefetchable)
  I/O Ports: 0x21e0-0x21e7 (rw)
  Memory Range: 0xd3589000-0xd35890ff (rw,non-prefetchable)
  Memory Range: 0xd3589300-0xd358930f (rw,non-prefetchable)
  IRQ: 30 (104367 events)
  HW Address: 34:15:9e:1f:59:1c
  Permanent HW Address: 34:15:9e:1f:59:1c
  Link detected: yes
  Module Alias: "pci:v000010DEd00000AB0sv000010DEsd0000CB79bc02sc00i00"
  Driver Info #0:
    Driver Status: forcedeth is active
    Driver Activation Cmd: "modprobe forcedeth"
  Config Status: cfg=no, avail=yes, need=no, active=unknown

So, I tried that “modprobe ssb” and not sure if it did anything, although now there is an “applet” for “network” . . . but it only is using ethernet. I tried to manually add “wifi” but it isn’t able to scan the router which is literally 12" away . . . .

I checked Yast Network . . . and it took a couple of minutes to “config the network” . . . but in the applet still shows “enable networking” as greyed out, it’s checked but grey.

And I checked Yast for “NetworkManager” . . . which shows as installed already, but trying to launch it in the console didn’t open anything, and trying to install it via zypper came back “nothing to do” . . . .

The result of “hwinfo --netcard” which you showed here said

...
Driver Info #0:
    Driver Status: ssb is active
...

so i believe the driver for your WLAN-card is installed and gets correctly loaded (no need to load it manually). Make sure you have selected NetworkManager to handle your network access.

Please show the results of

> systemctl status network

and

> nmcli -p general status

All this can be done as a “normal” user. Then as “root” do

# rfkill

and

# journalctl -b 0 -p 3

and show the results as well.

If the results are comprehensive just load them up to https://paste.opensuse.org and post the link instead.

Regards

susejunky

Make sure you have selected NetworkManager to handle your network access.

@susejunky:

Thanks for the added information . . . I’ll get back over to the MBP in a bit, but my first question is “How am I selecting Networkmanager”?? I tried various options of typing “networkmanager” in the console, but nothing obvious happened in response. I checked Yast and it is installed, but not showing in the menu for launching??

This morning I’m in my Gecko partition, and whatever network applet it has, in the menu there is both “enable networking” && “enable wifi” checked on, but I recall in the Leap install there is only “enable networking”??

I’ll run your suggested commands in a bit and post them here or in the linked pastebin type place.

No place to attach tar.gz files here in the thread???

Open YaST and go to **Network settings.

**In case NetworkManager is already set you will receive a pop-up message saying “Your network is managed by NetworkManager.” (or something alike) right when you enter the page.

On the upper part of that page is a drop-down-selection which allows you to choose between NetworkManager, wicked and no networking (if i recall correctly).

If that selection is not set to NetworkManager then change it to NetworkManager, confirmed your choice and reboot your system. From then on NetworkManager should be started on system startup automatically.

(see also here https://doc.opensuse.org/ for even more detailed information)

Regards

susejunky

@susejunky:

So, seems like the issue is “solved” . . . ran through your commands and on the last one there was an error something like “b43 driver is not installed, please run the following command to install it . . .” . . . so historically that has been the missing piece as far as getting Apple computer wifi set up . . . it’s just been so long that I had to manually do it.

So I added the b43 & b43 legacy drivers, rebooted . . . tried to connect, didn’t work, tried a few connections, nothing worked . . . ??? So I ran a “Zypper ref && dup” on it, not sure what the right commands for Leap are supposed to be . . . but it removed a “yast-trans”?? package and added one back in, I rebooted . . . window tried to load, then system rebooted itself a second time . . . and that time going back wifi connected!!!

So, thanks kindly for walking me through it . . . not sure how I feel about going back to the 5.3 kernel, as I think yesterday TW went to 5.11??? But, for this older computer I didn’t want to have to continually update it.

There are still a couple of errors showing in journalctl -b 0 -p 3

- Logs begin at Wed 2021-03-10 10:44:05 PST, end at Wed 2021-03-10 10:49:06 PST. --
Mar 10 10:44:20 localhost.localdomain systemd-xdg-autostart-generator[2010]: /etc/xdg/autostart/user-dirs-update-mate.desktop:10: Key OnlyShowIn was already defined, i>
Mar 10 10:44:31 localhost.localdomain lightdm[2192]: gkr-pam: unable to locate daemon control file
Mar 10 10:44:31 localhost.localdomain systemd-xdg-autostart-generator[2257]: /etc/xdg/autostart/user-dirs-update-mate.desktop:10: Key OnlyShowIn was already defined, i>
Mar 10 10:44:32 localhost.localdomain mate-session[2264]: GLib-GObject-CRITICAL: object GsmAutostartApp 0x55a0b4349bb0 finalized while still in-construction
Mar 10 10:44:32 localhost.localdomain mate-session[2264]: GLib-GObject-CRITICAL: Custom constructor for class GsmAutostartApp returned NULL (which is invalid). Please >
Mar 10 10:49:06 localhost.localdomain su[3512]: The gnome keyring socket is not owned with the same credentials as the user login: /run/user/1000/keyring/control
Mar 10 10:49:06 localhost.localdomain su[3512]: gkr-pam: couldn't unlock the login keyring.

Seems like in several of those commands it was just 10 lines that repeated for a number of pages???

Good to hear.

Anything in particular that is not working correctly?

Regards

susejunky

Well all I saw is the “keyring errors” . . . if that means anything?

Still have to fiddle with the Packman stuff . . . but main issue was the wifi, which I’ll betesting at work in a few hours to see if it can handle connecting via some log in window system . . . .

We shall see.

So, I’m at work and wifi is working, so I spent a few minutes looking at “zypper addrepo --help” . . . . but it just seems to be giving me terms . . . ?? Is this where I could run “zypper addrepo --packman” and that will add Packman into Yast and then I can “edit” it to one of the other mirrors??

I thought previously I added Packman via Yast Software Repositories and clicking on “add” and then on “Community Repositories”??? and that showed Packman. But that seems to be “nothing to be found” and it errors out?? I think I searched Yast for Packman and it “found nothing”???

Or, is this where I could pick “ftp” in Yast and then paste in one of the other mirrors URLs, and Yast will auto-add that as “Packman Repsoitory”???

Belay that last request, I think I got it by adding the ftp via Yast and the mirror . . . . I’ll try to run a zypper and see how it goes, but we might be “done” on this 15.3 fresh install.

Here is how i changed the Packman repository:

YaST -> Software Repositories -> Add -> choose Specify URL then Next -> set Repository Name to Packman Mirror TH AC and URL to https://ftp.halifax.rwth-aachen.de/packman/suse/openSUSE_Leap_15.3/ then Next -> Done

To get the current package list from that repository i finaly did

# zypper ref

.

Last but not least two hints:

  1. openSUSE Leap 15.3 is still a BETA version. So some areas might not work as expected.
  2. If you need urgent help and do not want to wait for an answer from the forum https://doc.opensuse.org/ is really an excellent source of information. Although much of it is intended for openSUSE 15.2 it might help with openSUSE 15.3 and Tumbleweed as well.

Good luck.

susejunky

@susejunky:

Thanks for the details . . . that is basically what I did, I just named it “Packman” . . . and Yast did the rest.

I’m not “new” to linux world, but I am still a “newbie” as far as the ins and outs of SUSE goes . . . no formal training in computer science since the 70’s with the IBM punch cards . . . so I can do a few basic moves in the console, but don’t know enough to run through setting up wifi as with the commands you provided . . . . And, then Yast is also a “brave new world” as far as learning all of the features that Yast provides, if one knows where to look, etc.

But, as far as “beta” goes, that isn’t a real problem, most of my multi-boot computers are running “testing” or “rolling” distros, so I’m a “jack of all distros . . . rolling stone gathers no moss . . . master of none of them.” For the most part “beta” offerings are pretty well tested and functional . . . I did have some issues with a Sid derivation wrecking havoc across partitions awhile back . . . Sid is well-named.

But, one final question . . . I forget whether Leap uses the same “zypper ref && zypper dup -l” commands that TW uses, or whether they have another command to run for stable updates???

That’s where the openSUSE documentation page (which i mentioned in my last post) can help.

As soon as openSUSE Leap 15.3 is officially released you will have to update it with

# zypper up

(the “refresh” should happen automatically if you have setup your repositories appropriate).

Make sure you have the OSS-update- and Non-OSS-update-repositories setup and enabled.

As long as openSUSE Leap 15.3 is BETA you probably have to update it with

# zypper dup

but i’m not sure about this.

Regards

susejunky

Alrighty, thanks for that zypper data . . . I have been using “dup” and so far that has been working. But over in TW I do the ref && dup -l . . . .

I like to stay in the “testing” zone . . . so I’ll have to see if there is a 15.4 that starts up soon after the 15.3 is released . . . ???

https://en.opensuse.org/openSUSE:Roadmap

Regards

susejunky