Fresh install of 9/16 snapshot . . . too early for Packman repo && question on /fstab???


  1. Been posting here about problems with large package upgrades, so to try to cope with that I did a fresh install of TW using NET installer from 9/16 to install the “/” into an SSD, while keeping the “/home” in its original HDD . . . . And seemingly all went well with the install. I tried to use YaST to add Packman repos, but nothing showed up in the “community” listings?? Is it “too early” for this new install to add Packman?? I had it installed in the previous edition . . . .

  2. One of my other reasons for doing a fresh install was that I was trying to use the new install to freshen grub to help get a ubuntu based distro also on the machine to upgrade to a newer kernel . . . it seemed to be showing a swap partition as what it was going to “resume” from, so I used /etc/fstab to edit the /boot/efi UUID and that “worked” to get that system to revive from suspend, but didn’t upgrade the kernel–after running “grub-mkconfig” in TW a few times . . . .

The issue I’m seeing now in TW is that in the console, instead of just showing the TW user name, it now shows “TW user name @ Lubuntu user name” . . . ??? I used the same /boot/efi UUID for both systems, thinking that that is where TW has the master grub file . . . does that matter???

I believe that ubuntu seems to insist on being in charge of grub, but that makes a problem for TW, which is where I want the control to be happening?? Any way to get TW to be the sole grub handler??

The Community list seems to be broken. Just add a suitable Packman site yourself. E.g.$releasever/

And better make one thread for each problem. IMHO this thread will be a mess before you can say J.R.)

  **Bug 1203213**]( -       List of Community repositories almost empty ... (no "nVidia", etc.)

Originally filed against 15.3 , but see comment #18 in that report.


Ah, OK. I think I might have the chops to do that . . . but do I not want it to be “tumbleweed” specified??$releasever/

Or, that doesn’t matter??

Thanks for the “make another thread” suggestion . . . but, since we know more or less the answer to #1 . . . now we would or could be discussing #2???

Sorry, I missed the Tumbleweed. I assume you should replace $releasever with tumbleweed, not to have both…
You do not have another TW install, or had one where you made documentation of?

Maybe someone else can provide a correct URI for you

The URI is:

TW - no concept of releasever


Thanks kindly for that correction . . . . I do have a Leap 15.4 install running in another old machine, but don’t know too much about “$releasever” . . . . Just figured that Leap wouldn’t be what I’d want in a TW install . . . .

So, I’m under the impression that I added “Packman” to the repos . . . ran a zypper on it . . . but it still says “nothing to do”??? Earlier the video in social media was blocked, assuming it still is??

Is this something where it takes a few zyppers to get Packman to install stuff???

Repository 'Packman Repo' is up to date.                                        
Repository 'Main Repository (NON-OSS)' is up to date.                           
Repository 'Main Repository (OSS)' is up to date.                               
Repository 'Main Update Repository' is up to date.                              
Repository 'openSUSE-20220916-0' is up to date.                                 
All repositories have been refreshed.
Loading repository data...
Reading installed packages...
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Computing distribution upgrade...
Nothing to do.

You need to issue

zypper dup --from packman --allow-vendor-change



This is an old problem with many new posters here. Posting output, but NOT the command. We are not clairvoyant. And saying “ran zypper on it” is saying next to nothing. >:(


Thanks for that data. In my case I had to modify it to the caps for “Packman_Repo” . . . no other combos, like with small p and r . . . would do:

sudo zypper dup --from Packman_Repo --allow-vendor-change
Loading repository data...
Reading installed packages...
Computing distribution upgrade...

The following 9 packages are going to be upgraded:
  gdk-pixbuf-loader-libheif libavcodec58_134 libavformat58_76 libavutil56_70
  libfdk-aac2 libheif1 libquicktime0 libswresample3_9 libswscale5_9

The following 9 packages are going to change vendor:
  gdk-pixbuf-loader-libheif  openSUSE ->
  libavcodec58_134           openSUSE ->
  libavformat58_76           openSUSE ->
  libavutil56_70             openSUSE ->
  libfdk-aac2                openSUSE ->
  libheif1                   openSUSE ->
  libquicktime0              openSUSE ->
  libswresample3_9           openSUSE ->
  libswscale5_9              openSUSE ->

The following 6 NEW packages are going to be installed:
  libde265-0 librtmp1 libvo-amrwbenc0 libx264-161 libx265-199 libxvidcore4

PS: video in social media seems to be operational, Packman must be working hard on it; thanks for the assist on it.

Sure, same as with any other distro. Make TW the only distro with an installed bootloader. If that’s too extreme for you, just don’t include the ESP partitions in the fstabs on distros other than TW, which will prevent them from writing anything to the ESP. Another option is at the conclusion of every non-TW boot that includes messing with boot, before shutdown or reboot, use efibootmgr to ensure the boot priority has TW first in list. If you forget this efibootmgr process, you can perform equivalent maintenance via UEFI BIOS setup.

If you learn to use custom boot configuration that includes symlinks to kernels & initrds, either via /boot/grub2/custom.cfg, and/or the *custom files in /etc/grub.d/, what the Grub configuration scripts do needn’t matter much. Your custom stanza titles can be anything using whatever charset your Grub supports. openSUSE includes the necessary symlinks in /boot/, while Debian and derivatives put them in /. Your custom.cfg’s stanzas can be at the top of every Grub menu, with the auto-generated ones that follow rarely needed, mainly only when you wish to boot an older kernel, or some other advanced option. Think /etc/grub.d/[01-09]_custom, as the auto-generated ones arise from 10_linux. Read /etc/grub.d/README. For more info, read here.


Make TW the only distro with an installed bootloader. If that’s too extreme for you, just don’t include the ESP partitions in the fstabs on distros other than TW, which will prevent them from writing anything to the ESP.

So, that is what I thought I had done . . . removed grub from everybody except TW . . . but it seems like ubuntu/deb have a way to “re-grow” grub?? Checking in Lubuntu’s synaptic it showed grub2 as “available” . . . but right-clicking on the line item it then provided “prepare for complete removal”??? Other items with grub in the list didn’t have that option . . . so I “removed” it, even though it wasn’t “installed”??? The problem right now is that somehow Lubuntu isn’t allowing itself to move up to newer kernels, that are installed . . . but doing the fresh install of TW and making the new grub didn’t seem to bring Lubuntu along . . . .

But, now that I’ve learned about the fstab file . . . the idea of removing the “/boot/efi” line data . . . might be the next step.

Thanks for sharing that link about the custom grub . . . that might be “too radical” for me right now, but only a few weeks ago I didn’t know about /etc/fstab . . . .

Apparently I’m out of “likes” for another few hours . . . .