Fresh Install - No Sound Card to be Found

After I did a fresh install of LEAP 42.3, I realized I did not have functioning audio. I installed PulseAudio Volume Control a couple days ago. I presume the system recognized the sound card back then since I could select the correct Output Device in the Volume Control window, but no sound came out of the speakers or headphones when plugged in.

I googled solutions, followed some forum threads and suggestions from around the web, but to no avail.

Then this morning, I booted put up the computer and the sound was working!

Then a little while later, not sure what happened, I logged back in and the sound was gone. Now, Yast and PulseAudio Volume Control no longer recognize the Hardware Output Device. All I see is the “Dummy Output” and neither seem to recognize the sound card.

I believe it has something to do with ALSA, but I’m not sure. I ran /usr/sbin/

Here is the uploaded output:
Any help is greatly appreciated !

Hi, welcome to these forums,

I sincerely hope this is not what it seems: a broken soundcard/chip. Can you post output of

sudo lspci

between CODE tags, the # in the editor layout ribbon ?

If you performed a kernel update, and did not reboot, it is also possible your sound is not working. Did you try a second reboot ?

Here is the output:

00:00.0 Host bridge: Intel Corporation Device 5910 (rev 05)
00:01.0 PCI bridge: Intel Corporation Skylake PCIe Controller (x16) (rev 05)
00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04)
00:04.0 Signal processing controller: Intel Corporation Skylake Processor Thermal Subsystem (rev 05)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-H Serial IO I2C Controller #0 (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA Controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #1 (rev f1)
00:1c.4 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #5 (rev f1)
00:1c.5 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #6 (rev f1)
00:1c.6 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #7 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
01:00.0 VGA compatible controller: NVIDIA Corporation Device 1c8d (rev a1)
3b:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 16)
3c:00.0 Network controller: Intel Corporation Wireless 7265 (rev 61)
3d:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS522A PCI Express Card Reader (rev 01)

I just reboot it again. No sound card to be found

Speaking of a possible faulty card or chipset… there is one error that appears when booting up the computer. It reads as such:

        3.071217] nouveau 0000:0100.0: unknown chipset (137000a1)

That’s the open source nvidia driver.

Can you also show


, I don’t see an audio device in the lspci output

Here is the output:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 8087:0a2a Intel Corp. 
Bus 001 Device 002: ID 04f2:b5d6 Chicony Electronics Co., Ltd 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Lspci should output for the audio of Intel Skylake :

00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)

Might it be that this is disabled in BIOS/UEFI ?

Indeed … I agree - check to ensure it is not disabled in the BIOS … maybe toggle BIOS setting for audio off, and then back on.

Another possibility is a bad install of the 4.4.126-48-default kernel, and to try a force re-install of that kernel.

I looked through the BIOS pages and didn’t recognize anything for disabling/enabling audio, however I’m not a hardware guy, I’m a software developer, so I’ve attached screenshots of pages that has things that I don’t understand that might be related to audio?](](

I’m setting up the new 18.04 Ubuntu on an USB drive to test it on this problematic machine. If it works (or doesn’t), I’ll update here and let you know.

Thank you, everyone !

I didn’t see a place to edit the post above… so if I’m double-posting / breaking your forum etiquette, my apologies.

I have managed to get my machine to boot off an USB drive of Ubuntu 18.04, and I do hear sound out of the speakers, so that leads me to believe the original installation of openSuse had something go wrong.

So how do I go about reinstalling the kernel on openSuse?

If that doesn’t work, I may try reinstalling openSuse all together…

Is kernel-firmware installed?

A kernel re-install can be forced in YaST > Software > Software Management … and under search type “kernel” and click on the black check mark icons next to ‘Kernel-default’ , and possibly also ‘Kernel-firmare’.

I can’t recall if you simply need ‘update’ or ‘update-unconditionally’ but a bit of trial and error will let you know that. (right clicking will show the options).

Ensure it is an upward green arrow you get.

Make certain it is NOT a red ‘x’ nor a ‘lock’ symbol. <<<< this is important !! You don’t want to uninstall your kernel, nor prevent future kernel updates.

On Fri, 11 May 2018 05:06:03 +0000, mrmazda wrote:

> Is kernel-firmware installed?

I ran into a similar issue with that same intel device on an HP laptop a
week or so back but this was after an update to a working TW system. I
had sound working somewhat (no volume control and only from Firefox, KDE
setup showed no sound device). Problem fixed itself a couple of days
later after another update and plugs right along now so I just figured it
was a temporary glitch in the software/firmware.

Just used the LEAP 42.3 & get the best experience in making my experience best with the audio of different things.
Garry Taylor