Fresh Install - Monitor Resolution Stuck at 640x480

Installed the latest snapshot of openSUSE Tumbleweed (09-09-2016) and my monitor(s) don’t seem to be recognised correctly by oS.

I had to enable “nomodeset” as a boot option when installing Tumbleweed otherwise I got no display output at all (worth noting that this issue did not occur with Leap 42.1). I am running KDE and have an Nvidia GTX 970 - currently using the nouveau rather than proprietary drivers.

I installed Tumbleweed successfully and can boot into it, but my display resolution is stuck at 640x480. The resolution in the GRUB menu is also ridiculously low. See the image below for the Display Configuration:

The output from xrandr is:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected primary 640x480+0+0 0mm x 0mm
   640x480       73.00* 

The contents of 50-monitor.conf in the Xorg conf folder is:

# sure you don't have in use another one laying around e.g. in another
# xorg.conf.d file or even a generic xorg.conf file. More details can
# be found in
#Section "Monitor"
#  Identifier "Default Monitor"
#  ## If your monitor doesn't support DDC you may override the
#  ## defaults here
#  #HorizSync 28-85
#  #VertRefresh 50-100                                                                  
#  ## Add your mode lines here, use e.g the cvt tool                                    

In YaST under Hardware Information the monitor specs are all correct and present (i.e. refresh rates, maximum resolution, etc. are all listed there as well as the brand and model).

My gut feeling is that the xorg configuration just hasn’t taken place correctly, but then I thought that xorg had actually been depreciated so not sure where to go from here.

Appreciate any help yous can give.

Can you boot without nomodeset and get a better Resolution?
Otherwise install the Nvidia Driver the Hard way:

If you added “nomodeset” you are not using nouveau at all, but rather fbdev, which just takes over the boot menu resolution.
You can change it in YaST->System->Boot Loader.

Or try to remove “nomodeset” (in YaST->System->Boot Loader->Kernel Parameter), as Sauerland suggested, to really use nouveau.

If nouveau is giving you problems, you may also try to uninstall it (package xf86-video-nouveau) and using the “modesetting” driver instead, or (as Sauerland already wrote as well) install the nvidia driver.

For some reason, nouveau just doesn’t work full-stop on Tumbleweed for me. After GRUB the display goes blank and that’s it. I have to do a hard restart to get back to GRUB. With LEAP 42.1, nouveau works without any issues. I’m back on LEAP for now until I can do a bit more research into why LEAP would be working but Tumbleweed wouldn’t…:sarcastic: