Fresh install - D-BUS session bus is not available

Hi,
New install of LEAP 42.2 (had 42.1 without issue), when trying to start or check the status of akonadictl get the below message.


D-Bus session bus is not available!

0: akonadictl() [0x40c0d3]
1: akonadictl() [0x40c3c2]
2: /lib64/libc.so.6(+0x34950) [0x7ff3156c5950]
3: /lib64/libc.so.6(gsignal+0x37) [0x7ff3156c58d7]
4: /lib64/libc.so.6(abort+0x13a) [0x7ff3156c6caa]
5: akonadictl() [0x40a9ac]
6: /usr/lib64/libQt5Core.so.5(+0x99a48) [0x7ff31606ca48]
7: /usr/lib64/libQt5Core.so.5(_ZNK14QMessageLogger5fatalEPKcz+0x96) [0x7ff31606e366]
8: akonadictl() [0x409c4b]
9: akonadictl() [0x405e39]
10: /lib64/libc.so.6(__libc_start_main+0xf5) [0x7ff3156b16e5]
11: akonadictl(_start+0x29) [0x407619]
]

Have seen other forum posts request this info, which for me

printenv DBUS_SESSION_BUS_ADDRESS
unix:abstract=/tmp/dbus-BnzJx2SFg8,guid=9be21b273256b0bed79c023e582f2f58

I have also noticed that kmail isn’t functioning correctly (wonder if related), its lost the config I just entered (email addresses).

Any ideas please?

THanks

Can you please post the full output of “akonadictl start”?

It’s unlikely to be a problem with the D-BUS session bus, or you wouldn’t even be able to login (into KDE at least).

Also note that you have to run it as user (not as root, not via sudo) in the user’s session, otherwise the user’s session bus will not be found.

I have also noticed that kmail isn’t functioning correctly (wonder if related), its lost the config I just entered (email addresses).

Yes, kmail requires Akonadi.

Embarrassingly that fixed it - worked from a user prompt. I had been using a root prompt to use systemctl to view the status of services, and used the same to look at akondaictl status and got the error messages. Thank you.

I should add, once I got it working from a user prompt. I then went into Kmail, added the accounts, and it had my data back again.