fresh install, can't get past "Loading initial ramdisk"

I bought a new UltraNUC Pro 7 Fanless (i7-8650U, NUC7i7DNHE) and am booting from USB stick; but am not making it past “Loading initial ramdisk”.
I tried with the latest Tumbleweed. Same. I am not familiar with grub and EFI; but I found somewhere to use “E” and enter into the parameter editing where I removed the “splash=silent” option on the linuxefi command to get more info; but it stays silent nevertheless.

Any help or ideas would be really appreciated

What is the storage, hdd, ssd, m2 (NVME?)?

Is the stick booting in UEFI mode? If yes, there will be none of F1 F2 F3 F4 F5 F6 at the bottom of the screen.

Do you have anything else you can use to try to boot your stick, to make sure it’s correctly created?

Can you try a different display; or a different video cable?

Try appending plymouth=0 to the kernel cmdline. If it doesn’t help, possibly appending nomodeset will get you going. If it does, you’ll need to remove it soon after you’ve booted to a completed installation (delete from /etc/default/grub from within YaST Bootloader). It’s main purpose is for troubleshooting.

Thanks to both of you for your quick responses. I am a bit embarrassed to say, that it now works without any of your fixes. I went into the BIOS, poked and looked around hit F10 and it worked. I didn’t change any settings, same stick and I tried about half a dozen times yesterday. The only thing I changed, that I used another (older) monitor. I am now running through the install and see whether this occurs again.