Fresh install: Can not log in either in SDDM or in a console.

This is my second attempt to clear up this thing as proposed by Henk van Velden, so admins please bear with me (re double posts):

I ran the install as I always do, so this comes as surprise. I created one user with password, no automatic log in and no administrator rights. I then set a different password for root in the next menu. The installation finished with no Errors. Upon reboot I was stuck in the SDDM login screen with an error message like wrong password or user and password don’t match (I am doing this from memory). So I switched to console via <Alt><Ctrl><Fn2>. I could not log in either as normal user nor as root. I’m blocked at the normal login Screen and in console. Neither a “standard” user (me) nor root can log in into a normal KDE/Plasma session.

From the earlier thread:

So I booted in maintenance mode, looked at /etc/shadow which had no user except root and root had no password. Okay, so I used “passwd” and set one – no luck. So I re-set it to “xxx” so as to avoid language-layout specific problems with the keyboard – no luck. so I "chroot"ed from another installation mounted the new installation, set the password, synced the disk – no luck. So I re-installed with only root as user – no luck.

I learned that maintenance-root is different from normal root, small wonder that my first tries didn’t work. I do not know why the “chroot” attempt failed. Can maintenance-root perhaps run YAST so as to work on the real root or the fresh install? (I’m sitting in front of a Windows box right now and can’t try:().

Any advice about how to analyze, debug and eventually repair it would be highly appreciated :).

From your description, it looks as if something went wrong in your install.

However, I have never tried it that way. When installing, I make the initial user “support”, intended as a user administrator account, and I do allow that to also be the root password. I always turn off automatic login. I have never run into the problem that you describe.

Can you login as an ordinary user at the command line (say, after CTRL-ALT-F1)?

I assume that you are using a password for root that is not going to be confused by keyboard mappings when you try to log in on the tty (Alt-Ctrl-F2 I think you try?) So you can type the correct password as the login name - just to confirm that the password you type is what you get - rather than root just to see that the keyboard is doing what you think it is?

As I said on your earlier post, I found the same problem - could not login on the GUI login screen, but in my case I could log in as both root ans my new user on tty1 on a new Tumbleweed install.

And what I did then was install xfce4 and lightdm, set lightdm as the DisplayManager, and then after a reboot I could login via the gui screen. But the default GUI login screen / chooser did NOT work.

I can’t duplicate this at the moment - as I haven’t got a blank HDD with me to do a test install on - but it happened twice as I was not happy with the ways that the installer partitioner was partitioning my disk, so I re-installed a couple of times (and manually created the partitioning scheme I wanted)

…and then spent an hour or so getting my keyboard layout changed from US English, something that should have taken 30 seconds - or zero time at all as I had chosen UK British English at Install time.

No, I can’t (though I tried with <Fn2>, see post #1).

Yes, as I wrote I used “xxx” as root-password just to make sure of this.

Not possible here :(.

When I can’t log in I can’t install things either…

That’s the way I did it, too.

Short info: I’ll be out of town this entire week, will report back then.

Re-installing without mounting the pre-existing home didn’t work either.

So I downloaded the latest tumbleweed and lo and behold – problem vanished. Ergo, distro-malfunction.

Fun-fact: Although gpg of sha256sum file and sha256sum check ran without error, install halted due to a corrupt checksum of networkmanager-something or other. So I re-wrote the stick this time on an USB 2 socket instead of previously using USB 3 – and got a corrupt checksum of yast2-ldap. Sigh. Since I could live with that I finished the install and loaded yast2-ldap online. Seems my USB-stick is leaving us … does this really have to happen all at once?

Yeah you have a dud USB stick, I had one of though … nightmare to figure out, wrecked my week back in the days of Mandrake/Mandriva Linux