Fresh Install 11.4 with Gnome3?

What is the best way to perform a fresh opensuse 11.4 installation and getting Gnome 3 installed without having to “update” it? My existing hard drive seems to be on its last legs and I’m hoping to replace it soon but would like to make it as clean of reinstallation as possible. I have the 11.4 standard ISO but saw that what I’m trying to do may be easier with the Gnome Live CD in the method of adding the repository then setting the CD to install the system. Would this work or is there an updated 11.4 ISO with Gnome 3 yet? Thanks!

Use the Gnome 3 CD
Index of /repositories/GNOME:/Medias/images/iso

Or use your 11.4 install DVD
and then do the One click
openSUSE:GNOME 3.0 - openSUSE

Will the results of the two (2) above options be significantly different ? From a fresh install of 11.4 from the install DVD, I experienced problems with gnome-shell. To wit, after the reboot, I received the Gnome3 failed to start (suggesting it may be a graphics problem). Since the graphics in question is the vaunted Arrandale/Ironlake platform, I upgraded Xorg (as on previous 11.4’s) and resolved that problem, only to receive the “oops” (something is wrong, log out and log in) message.

Reboot with “failsafe” worked, as did reboot with only nomodeset, allowed some success, although graphics was crippled to 1024 x 768 fbdev. In each case, Gnome3 was in fallback mode. At this point, I attempted to set the “force fallback mode” (Gnome 3 Fallback mode - Get your productivity back, without success (any idea on how to do this on oS 11.4 ?).

At this point, I uninstalled “metatheme-adwaita-common”, with no change to the “oops” message. Next, I uninstalled “gnome-shell”, and all booted up in normally, with Gnome3 in fallback mode. Please note that none of the gnome-shell-extensions (including xrandr) had been installed.

Possible next steps (now that it can be booted) include defining a new user (in case some contaminated .gnome/.gconf/.??? things are remaining on the existing user), or burning the Gnome3 .iso. Any suggestions are welcome.

Observations and Questions

  1. During the “zypper dup” (after all packages were downloaded, and install started), the network connection is reset (at the point of installing NetworkManager). No recovery was possible, and an intermediate reboot was required to zypper in gnome-shell.

  2. After much searching, I found no method to set the “force fallback mode” mentioned earlier.

  3. What logs may contain the reason(s) for the “oops” panel. This failure leaves only the option to log out, and log back in to receive the same error.

(Insanity: doing the same thing repeatedly, expecting a different result)

  1. Would the “1 Click Install” obtain something different from the text mode install ?

I used the 11.4 install DVD, and performed the One-Click for Gnome3 first before doing any system updates.
Gnome3 uses mutter(?) for compositing, so go through and uninstall all compiz entries in add/remove software, logoff - logon.
If you get a Gnome 2 looking desktop with some Gnome 3 elements, make sure your graphics drivers are up to date and then you should have a nice shiny Gnome 3 desktop!!
I can go into more detail if needed, have fun…

Thanks! The compiz removal was a good starting point, but the problem(s) still remained. In removing compiz, it was necessary to remove


At that point, I re-installed gnome-shell and metatheme-adwaita-common. A little progress, but still no cigar. I found that in YAST Software Manager, the pattern “Gnome 3” was not checked, so that was installed. A little closer, but still problems appeared.

As to the graphics idea, the PC runs kernel 3.0.rc3-3.1, and Xorg is at Index of /repositories/X11:/XOrg/openSUSE_11.4, so I knew that the support for the Intel GMA HD was as close to Factory as I ever use.

After checking the various repositories, I looked at the Gnome 3 repo (in YAST), then did a “switch system packages”. This presented a conflict with libgdata7, and I selected to de-install libgdata7, Many updates ensued. At logoff, the gdm login screen was different.

I threw in a re-boot, and voila! … Gnome 3 is alive and kicking! As with any new product, there are a number of non-fatal things that need research, and will most likely be updated soon.

One important note: the Gnome 3 install updates (replaces) Mesa (3-D graphics). If, like me, you are using a higher level of Mesa, such as from the Xorg repositories, it is critical that you not regress Mesa !

As a closing comment, I do hope some more aesthetic desktop themes are in the offing: black/blue and some grey leaves a rather droll appearance!


(Note written from the 11.4/Gnome 3 PC, with Firefox 4 and a copied Firefox profile)