Fresh Install 11.4 Blocks at Splash Screen on Reboot

I ordered a SuSE 11.4 installation DVD from an online Linux Distro distributer that I’ve used before with no problems. I did this rather than burn my own DVD from the website. I thought that I might perform a fresh install of SuSE 11.4 on this Dell 1420 Laptop that is currently running Ubuntu 11.04.

Note, this is a completely fresh install, not a side-by-side installation with Ubuntu; I followed the installation sequence that completely repartitions the entire disk for SuSE, and accepted all of the suggested options regarding logon, etc.

Everything goes well … sort of. The first install didn’t reboot correctly, i.e., the set-up that is supposed to run after the initial install never happened and I had to manually power-down the machine and restart from the “safe mode.” Needless to say, that didn’t work as expected. So, I re-install, from scratch, trying different options: for instance, instead of LVM, I decide to have an un-encrypted partition scheme and accept the “obvious” options … thinking that the LVM options interacted badly with the install. Eventually I get the installation to proceed correctly, or so it appears: it goes though the entire sequence, including the re-boot, building the default image, etc.

I test this image by removing the DVD, power-cycling the machine, and all looks good, so I begin the process of installing software updates, etc. Being paranoid, I re-boot the machine, and all restarts correctly, etc.

Now here’s the annoying thing. The next day, I power the machine on, and it locks at the splash screen. By the way, these are the exact symptoms that I experienced with the bogus/incomplete installations. The boot sequence proceeds up to the splash screen and waits forever.

So, in sum: I spent inordinate amounts of time attempting to install this software, carefully following the instructions provided by the installer. In every instance, after leaving the machine off for a day or so and rebooting, I am met with a splash screen that sits forever. Needless to say, I am extremely reluctant to repeat another day of software installation to only have to re-start with no assurances of success. Either I go back to ugly Ubuntu (which has always worked out of the box, by the way), or I look at other options. I was hoping to use SuSE, but I really don’t care which distro is on that machine as long as it works and it provides TeX, R, Emacs, Scheme, and a few other software packages that I’m sure are of no interest to your customer base.

Tom R

Did you run the media check?

What video do you have?

It appears to be an Intel 645 chipset. I tried adding the nomodeset option to the Grub boot file and that works, but results in an ugly rendering. I also tried modifying the 50-device file to use the “intel” driver … this appeared to work, once. So, I removed the nomodeset option, but things froze again … sigh.

Making matters worse, because this is a laptop, it needs to seamlessly use the wireless network connection (sometimes) and a hardwired connection (other times, such as when I have a large software update or some such thing to do). It seems to have difficulty with this. If I configure the wireless and move to the wired connection, I get the splashscreen lockup; I notice that it’s trying to disambiguate blacklisted from whitelisted networks … or some such thing.

Bottom line: I don’t think that this is worth the aggravation. In two hours, I can re-install, re-configure Ubuntu (with the ugly Unity desktop), AND (in the bargain) an able to install various software packages that are NOT supported natively in SuSE, such as Dr. Scheme, TexWorks, Dropbox, etc.

I’ll keep the open SuSE that I installed on my desktop until tomorrow, when I’ll probably install either Debian or Fedora and be done with it.

Thanks for your thoughts, but time is wasting, and summer is for article writing not distro-debugging.

Tom R

Intel redeveloped their graphics driver and broke alot of older chipsets in the process; but in long run Linux graphics will be much better for it. You either use the modern default driver which uses KMS, or you use the legacy driver & nomodeset as documented in the release notes.

It’s quite likely, once you have updates and a sound configuration that your problems will disappear. I’ve had same type of issues, trying out fresh Ubuntu releases where a lot of bugs need patching before I got a semi-solid system.

Ugly rendering may be the fonts if you chose GNOME which don’t seem to suit every system, there’s an automatic pullin of some fonts and various other fonts available, to find ones that work well for you.

In your situation I would try installing with wired network (wireless disabled) and nomodeset (perhaps even ugly VESA driver) then re-configure post-install after I have updates from the net. Once you have sorted a configuration, openSUSE is very solid and the rolling release options, mean you should not have to go through this pain again.

I think an explanation as to what I believe is happening here might help. Note there IS an explanation in the openSUSE-11.4 release notes, albeit understanding the same is not easy.

It appears that when you boot the PC without any boot codes, the kernel mode setting (KMS) is not able to handle your graphic hardware. When you specify nomodeset as a boot code, openSUSE in addition to NOT using the kernel mode setting, will for Intel hardware (and without further config file edits stating otherwise) will also fall back to using the primitive (but highly compatible) FBDEV graphic driver. As you noted both font and performance (and also resolution) will be poor with the FBDEV compared to the Intel driver.

By booting with nomdeset and having the intel driver specified in the /etc/modprobe.d/50-device.conf, you were on to an EXCELLENT configuration to try for your problem. If that works, you should have kept that ‘nomodeset’ boot code and ‘intel’ driver (in 50-device.conf) setting.

By removing the nomodeset boot code, you undid the good you did by specifying the intel driver. Ergo I think the graphic problem has a solution.

Reference the wireless problem, my knowledge there is too weak to give good advice. I think thou you could have obtained good advice had you asked for help on our wireless forum (as we have some knowledgeable users AND also a wireless developer who hang out there). This is significant because in general developers do NOT hang out on the forums but rather they hang out on the mailing lists. Our forum is a volunteer forum of openSUSE enthusiasts and we are not paid for this. Rather we just like to try and help users. So we are very fortunate for wireless and the quality of help on our wireless forum area is of a very high standard (IMHO).

Note a LOT is taking place in the graphic world, ESPECIALLY in the area of Intel graphic drivers. Dependant on the version of a GNU/Linux distribution, the video behaviour for Intel hardware can be substantially different, and this is almost entirely being driven by upstream updates that have made their way downstream.

I’m glad you stuck with GNU/Linux and found a distribution that works for you.

Take care, and possibly next time you try openSUSE, if you have problems, you can post on our forum asking for advice from our volunteer enthusiasts. :slight_smile: