Frequent system crashes/Hangs.

The opensuse leap leap 42.1(desktop KDE plasma5/workspace) hangs the system frequently i.e no shortcut keys or numlock works when it hangs and i have to manually power off the machine and ON again.
Once it hanged right after i login and then sometimes whenever i tried to access yast and mostly while using the system for a while.
My hardware seems not to be the problem because the other distro i am using works really good, so its not the hardware. Some suggested moving to tumbleweed, i chose leap since its stable. Help please.

Tell use about this hardware. like what video card and have you install the drivers?

My machine is Intel Core 2 duo E7500 .
I use ‘Nvidia Geforce 210’ and i am using default drivers that comes with a fresh install - the nouveau one.

Display Server: X.Org 1.17.2 drivers: nouveau (unloaded: fbdev,nv,vesa) Resolution: 1366x768@59.8hz
GLX Renderer: Gallium 0.4 on NVA8 GLX Version: 3.0 Mesa 11.0.2 Direct Rendering: Yes

**
More Hardware info**- http://susepaste.org/41958f36

my repo list - SUSE Paste

Turn off Desktop Effects:

Configure Desktop –> Display and Monitor –> Compositor

and uncheck the box “Enable Compositor on Startup”.

If you like to experiment, then you can instead try (on the same settings screen) – look for “Rendering Backend” and change that to “XRender”.

After making those changes, I suggest that you logout and login again.

If the desktop is too unstable to make those changes, then use ALT-SHIFT-F12 first, to temporarily disable Desktop Effects while you make the changes.

Also may want to try the NVIDIA driver

IME that’s the thing that will show how stable Plasma5 is.
IMHO it’s not Plasma5, it’s the nouveau driver that needs fixing.

On two AMD machines with Radeon graphics – Richland [Radeon HD 8650G] and Oland [Radeon R7 240] – since the 13.1 openSUSE I enable the compositing when the login has completed – in the .kde4/Autostart directory there’s a bash script which does the following:


if  'false' == $(/usr/bin/qdbus org.kde.KWin /KWin compositingActive) ]; then
    /usr/bin/qdbus org.kde.KWin /Compositor toggleCompositing
fi

On the Richland system I can use the OpenGL 3.1 compositing but, on the Oland system I have to use the OpenGL 2.0 compositing – both with Raster enabled.

I first turned off the Desktop Effects via compositor(unchecked the box “Enable Compositor on Startup”) but that didn’t solve the issue, it kept on hanging like before.

The problem seems to be solved after installing the nvidia driver from community repo, not a single hang/crash after that. Hoped leap would run fine without problems out of the box but its ok feeling positive now , thank you :slight_smile:
Graphics: Card: NVIDIA GT218 [GeForce 210] bus-ID: 01:00.0
Display Server: X.Org 1.17.2 drivers: nvidia (unloaded: fbdev,nv,vesa,nouveau)
Resolution: 1366x768@59.8hz
GLX Renderer: GeForce 210/PCIe/SSE2 GLX Version: 3.3.0 NVIDIA 340.93 Direct Rendering: Yes

So can i turn ON the compositor now ? and what compoistor settings should i choose for smooth running now ?

Compositing works for me with the Nvidia G02 driver. But I did have to set it to use XRender instead of OpenGL. I’m not sure what works for your card.

I’m pretty sure that OpenGL worked for me with KDE4, but Plasma 5 seems a bit more fussy.

whats your graphic card ?

how can that be done in opensuse leap with plasma5 ?

Just posting this for others to get some idea…

Sometime back i had the same issue with opensuse 13.2 and the desktop environment was kde plasma…
it gave me the same head ache/…
But when i switched back to gnome there was no problem again…
i think it is a bug in kde plasma

GeForce 6150LE.

Hello:

I have the same problem with Leap 42.1, only it is a bit more severe. Most of the time, I can’t even get past
the login screen. My notebook system has an NVidia GeForce 770M graphics display board. I went to the NVidia
site, downloaded the latest linux 64 bit driver and installed it. The tag for this driver is the Linux x64
(AMD64/EM64T) Display Driver, Version 352.63. After adding a file to /etc/modprobe.d, I was able to get
the nouveau driver to unload and the nvidia driver to load on system boot to multiuser. Now, I just get a
blank screen. sddm-greeter is exiting with the message (among others) “Cannot create platform OpenGL context,
neither GLX nor EGL are enabled”. It appears that the nvidia driver that I found does not support all of the
capabilities that the nouveau driver provides. My question is this: Can you give me the url or location of the
public repository the tag for the nvidia driver that fixed your problem, as described in the post above. This
would be most helpful to me at this point. Alternately, is it possible that there is a module parameter that
I could provide to the nouveau driver that would leave me enough functionality to be able to log in, but eliminate
the crashes (wishful thinking)?

I thank you in advance for any help that you can give me.
~

I think you mean the Geforce GTX 770 M. I guess you should uninstall the installed driver before trying out the one from repo.
You can add the Nvidia repo for leap from yast - YaST->Software->Software Repositories->Add->Community Repositories->NVIDIA Graphics Drivers URL- Index of /opensuse/leap/42.1

LOOKOUT for the special Note mentioned for Leap here - SDB:NVIDIA drivers - openSUSE Wiki
Someone mentioned this earlier - If the desktop is too unstable to make those changes, then use ALT-SHIFT-F12 first, to temporarily disable Desktop Effects while you make the changes.
Or you can also choose the IceWm Session and install the driver.

If M in number then it is mobile and probably an Optimus system if so then you can not use the regular NVIDIA driver. Uninstall it and follow instructions here

https://en.opensuse.org/SDB:NVIDIA_Bumblebee

Having issues like described at start of this thread.

Using Tumbleweed 1128 and KDE5 plasma.
I7-6700, Geforce GT730 ]

Issue also occurs on another unit using an i7-3770 with AMD radeon 75xx

Problem seems not to exist using XFCE desktop.

Login with XFCE or Icewm. Either of those should work without problems.

Then look for the file “$HOME/.config/kwinrc”.

It should contain a section that starts with “[Compositing]”

In that section, there is likely to be a line “OpenGLIsUnsafe=false”.

If you can find that line, then change “false” to “true”. And then try again with Plasma 5. It should now work, though Desktop effects probably won’t work.

You can later try setting desktop effects to use “XRender” instead of “OpenGL”. Do this in the “Display and Monitor” settings under “Compositing”.

Note that what I have described works for me with a nvidia geforce 6150LE graphics card, and using the nvidia driver. It would probably work with the nouveau driver too, but I didn’t try that.

I’ve just completed getting Leap 42.1 with Plasma 5 up and running on my laptop – the script I mentioned still runs OK but,

  • I have checked the “enable the Compositing when starting” option box.

And, amazingly, the Compositing works OK but, I’ve reduced the OpenGL to 2.0 – the same as that used on the Desktop 13.2 system with the AMD Oland [Radeon R7 240] graphic card.

I have what sounds like the same problem on a system with Intel E3-1200 Integrated Graphics. Driver is i915. openSuSE LEAP 42.1, Plasma 5.

Launching any of a wide variety of gui apps, either from the KDE application menu or from a shell prompt, can cause the crash. Just X appears to be frozen. I can ssh to the box and get a fully-functional shell session.