Frequent segfaults in host with VirtualBox

I have a windows xp 32 bit VM, I can use it for some minutes, like from 10 to maybe 50. But it will crash. This VM worked without problems some time ago, but did not use it in a while, so not sure since when it triggers the segfault.

With dmesg I see:

threaded-ml[3663]: segfault at 1b1 ip 00007f9cad795d5e sp 00007f9c42d1fab0 error 4 in[7f9cad761000+50000]

Am I the only one with that problem?

I did another ‘zypper dup’ today, but the problem is still there.

I turned off audio input and output for the VM, but still get this:

threaded-ml[4751]: segfault at 1b1 ip 00007fc8048c5d5e sp 00007fc79e330ab0 error 4 in[7fc804891000+50000]

Did update guest additions for that VM. 40 minutes without crash, but maybe just lucky. Will report back if I have time to run it for longer.

Do you have an AMD host CPU?

Might be related to the problems with the recent security fixes that cause 32bit applications to crash on (some) AMD systems.
Should be fixed in kernel 4.14.13, or the “nopti” kernel option should help on kernel 4.14.11 (but not on 4.14.12).

No, it is Intel. I got the crash again, even with updated guest additions.

You might inspect a few lines (10 lines?) before the specific error to see if any prior entries might provide more tools.
If you’re unable to do that with dmesg, you should have more flexibility reading system log entries using journalctl.

Have you installed updated VBox Extensions after you might have updated your VBox? I think you are confusing VBox Extensions which are installed in the HostOS and Guest Additions which are installed in the GuestOS (You should actually update both)
Is your VBox installed from the openSUSE repos, or from the Oracle website?


VirtualBox is from suse repo. And i regularly do ‘zypper dup’, so everything should update at once, right (except guest additions)?

I now switched the audio backend of the VM to ALSA instead of pluse audio. Did not have a crash since.

Virtualbox Extensions which are installed in the HostOS are installed from Oracle and are not automatically latest in a new VB install.


Seems related
any solution or ideas ?

IMO there isn’t much that connects your problem with that reported problem, only that your symptoms are similar.

Probably you should run the same commands described in that bug report on your machine to see if you can return same results which could tie your situations together.

You might do what the author of that other bug did which is to report the bug upstream.

If you’ve done all that is described in this Forum thread which is to install and update to latest VBox Extensions and Additions, you’ve probably done as much as an end-user can expect.