Frequent lockups/freezes

Hi all,

Running Plasma on LEAP 42.2, I’ve been experiencing frequent total freezes of the system. The mouse cursor would stop moving, and the laptop wouldn’t reply to ping anymore. That happens several times a day, and of course nothing shows up in the logs at the time of the freeze (but I’m not very proficient with journalctl yet, I may have missed something).

The laptop is a Lenovo T460 with a VGA adapter and I’m running KDE/Plasma, so my first reaction was to follow the recommendation to use “UXA” acceleration on the Intel driver, without success. Then I also tried the “modesetting” driver, but that didn’t help either.

The problems began on Monday morning, when I started using the kernel-default 4.4.36-5.1, and persisted with the upgrade to kernel-default 4.4.36-8.1.
I’ve downgraded the kernel back to 4.4.27-2.1 yesterday morning, and haven’t had any lockup since.

VGA adapter:

​00:02.0 VGA compatible controller [0300]: Intel Corporation Skylake Integrated Graphics [8086:1916] (rev 07)        Subsystem: Lenovo Device [17aa:5053]
        Kernel driver in use: i915
        Kernel modules: i915

Any help would be greatly appreciated. Let me know if there is additional info I can provide.

Still no freeze since I downgraded to kernel-default-4.4.27-2.1.x86_64. Every other package is up to date, according to the software update applet in plasma.

Considering this is my work laptop and it was consistently freezing several times a day with more recent kernels, I’m glad there’s this workaround.

Seeing the same problem here, with kernel 4.4.36-8. No VGA adapter involved - just using the laptop with no peripherals and the lock-ups still happen. Model is Lenovo Thinkpad T460s.

Will try the downgrade to kernel 4.4.27 and see if that helps.

It’s recomforting to see I’m not alone.

In my original post, I meant to say “with an Intel VGA adapter”. Then the rest of the paragraph makes more sense :slight_smile:

You most certainly have an adapter involved, else you wouldn’t see anything on the laptop’s display panel :wink:

You can find what is enabled (in a power supplied to it sense) in your system with:

/sbin/lspci -nnk|  egrep 'VGA|3D|Display' -A3


/usr/sbin/hwinfo --gfxcard

… the third party (meaning its not included and you’ll have to install it) “inxi” utility is also a nice info provider *

 inxi -Gx 

In any regard, I’d suspect that it too is another skylake adapter like alrj’s

  • (hat tip to oldcpu for first introducing that one to me).

I am experiencing the same problems on my T460s with kernel 4.4.36-8 (Leap 42.2). I am currently trying Kernel 4.9.0-3.gf4d3acd-default (see: )

I had a problem with WiFi dying occasionally. It was due to intel power management. It may or may not be related to your problem but greping the journal for this wouldn’t hurt:

The following command should do the trick.

journalctl | grep intel_