Freezing of PC

Hi all,

I have just recently changed my computer and the specs are:

Asrock AB350 Pro4 (latest BIOS)
Ryzen 2400G
Corsair LPX 3000 mhz
Samsung 860 EVO

I installed Tumbleweed and have updated to the latest packages.

Problem is, I’m getting random freezing on the computer, this is happening at any time, during web browsing, bench marking or any other task, no matter how light or heavy the load is. This happens probably 10 minutes after booting into openSUSE, leaving the PC stuck with no other solution than doing a hard reset using the power button.

I have also a double boot of Windows 10 that is working with no issues whatsoever.

Has anyone had this kind of trouble?


It is installed xf86-video-amdgpu

glxinfo | grep -i render

Gnome Plasma or …?


Read this:

Check your bios for 'power supply idle control - typical current idle". Or how Asrock name it. I have an Asus an it work it.


Yes that package is indeed installed, version 18.0.1-1.1.
I’m using KDE.

abriel@linux-ecr9:~> glxinfo | grep -i render
direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
Extended renderer info (GLX_MESA_query_renderer):
    Renderbuffer free memory - total: 991 MB, largest block: 991 MB
    Renderbuffer free aux. memory - total: 3067 MB, largest block: 3067 MB
OpenGL renderer string: AMD RAVEN (DRM 3.23.0 / 4.16.6-1-default, LLVM 6.0.0)
    GL_ARB_compute_variable_group_size, GL_ARB_conditional_render_inverted, 
    GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_packed_depth_stencil, 
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth, 
    GL_NV_blend_square, GL_NV_conditional_render, GL_NV_depth_clamp, 
    GL_OES_element_index_uint, GL_OES_fbo_render_mipmap, 


Hi there,

Unfortunately is not only happening at idle, but under load too.


Is you memory listed in Memory QVL?


It is noton the QVL, but I don’t think it is a memory issue.
I have ran memtest for almost 5 hours, have stress tested CPU, GPU and ram all at one on Windows 10 and have had 0 crashes or errors


Searching on the net, many have problems with the new Ryzen GPU
And yet there does not seem to be a solution

This is with the 2400G’s integrated graphics?

I’ve been having that same soft lockup/freezing issue for the past 7 months (since I got my Ryzen 1800x). No issues when dual booting to Windows. PC will lock up at any time for any reason, seems totally unpredictable from my point of view.

I made a thread about it a bit ago, and one user suggested modifying the kernel boot parameters, however I can’t say the difference is all that great for me. Upgrading to TW didn’t seem to do much in terms of resolving the issue either.


Indeed, it seems that is not a solution to modify the kernel boot parameters .
For me, after the last BIOS (Asus Prime X370-Pro and 4011 BIOS), no problem so far (26h and no freeze).
It seems that nobody really knows what is going on.
I hope that is not the reality (post #337, last paragraph):

Upgrade motherboard to latest bios. If problem continues, try disabling C6 state in bios settings. Btw, this is different than the apparent 2400G issue, as far as I know.

Hi xorbe,

Yes this is with the onboard Vega graphics of the 2400G.

I’m still having freezes on the latest Tumbleweed image as of June 7th 2018.



For 2400G wait for kernel 4.17 and you will have support for it.
Or install it from

You could even mount an Nvidia Geforce.
I know that one buys a gpu to use it, but if it creates problems it is not nice to forcibly turn off the computer waiting for support.

Unfortunately freezes are still occurring in OpenSuse even with latest 4.17.2 Kernel and latest Mesa packages.

I had this issue too with my Ryzen 1800X. It seems to be a known issue with the C6 deep idle power state. Turning it off in the BIOS can help, but may not be possible if your BIOS is as bad as mine (or it may also turn off additional power saving states that actually work).

I decided to fix the issue by creating a service that disables the C6 power state on boot. It has been working fine for a few weeks on my PC now. I uploaded it to OBS in case anyone else still has this problem: You can install it from the repository here

Don’t forget to enable and start the service after installation with*sudo systemctl enable amd-disable-c6.service
sudo systemctl start amd-disable-c6.service