Freezing at boot

I’m trying to use the x86_64 version of openSUSE 11.1.

During the installation reboot (or any later boot), my laptop (Acer Aspire 5100) freezes entirely with corrupt graphics. The display looks as if the first 100 or so pixels are repeated horizontally and that scanline is repeated, so I just see repeating groups of vertical lines.

At this point, the small progressbar underneath the “openSUSE” logo has moved maybe 2 pixels. When it freezes, the hang is complete (all I can do is force the laptop off by holding the power button for 5 seconds).

The odd thing is that it boots normally 99% of the time if I have any USB storage device plugged in. The installation DVD always boots normally.

I’ve searched the forums, but not found anything useful yet (probably because the terms mostly lead to booting off USB devices etc). Is there any workaround other than plugging in a USB stick every time I need to boot? It’s not that big a deal, but gets especially annoying whenever I forget it.

Have you tried the Failsafe boot option?

Yes. Makes no difference.

Please boot and press Esc. to get verbose mode. Text will display, try and see what it says, we are looking for error messages.

Was the usb storage device in anyway connected with the install?

I’ve tried this too, there are no error messages that I can see (although I may simply not see it because the same corruption occurs in text mode resulting in grey on black lines rather than light- on dark green). The last thing I can read is a line about acpi and vga. It moves by too fast to see what it is, but doesn’t look like an error (I’ve seen the same line flash by during successful boots). It doesn’t get to the normal services initialisation (no green “done” text anywhere in sight). I don’t think the root file system has been mounted in writeable mode yet, so it’s kinda tough to get a log too.

No, I’ve tried reinstalling several times, figuring it might have something to do with USB devices being connected during the installation. It made no difference. It also doesn’t matter what storage device I connect. Even an (empty) ATAPI CD-ROM drive using an IDE-to-USB converter cable will allow it to boot.

I’ve also flashed the BIOS to the latest version available from the Acer site, but that too made no discernible difference (also tried reinstalling after the BIOS update).

I haven’t tried using something like a USB webcam (there’s one built in anyway) nor have I tried the 32bit version, which I may try if I have a lot of time.

I’m not sure this will help, but it will not do any harm:

Pause the boot by moving the down arrow, then back up to the default boot. But now press backspace, it should delete any text where you can see VGA=…etc
Remove all text and now type just the number:
and hit enter

at the login type your user name and then password
now type:
then the root password

now type this:
sax2 -r -m 0=vesa
(N.B. the 0 is a zero not a letter)
now reboot: type: reboot

if you don’t get a gui login
login as user at cli and try this at the cli

It never gets to the login prompt without the USB device connected (neither in text nor graphics mode – I prefer text-only anyway). With it, it boots normally and I get my KDE desktop just fine (or Gnome, on another install attempt).

Let me correct my earlier statement: it does get to initialising some services, but not far enough to have /var/log/boot.omsg available on a successful boot.

The last line displayed is one of the following three (it varies, but these lines are very close together in the boot process):

“ACPI: Video device [VGA] (multi-head: yes rom:no post: no)”,
“rtc0: alarms up to one month” or
“registered led device: acer-wmi::mail”

It never gets past that last one on a failed boot. On a successful boot, that line is followed by

ipw220: Detected geography ZZR (14 802.11bg channels, 0 802.11a channels)

Please try adding: acpi=off
to the boot argument - do you know how to do that?

Yes. And it has no effect. It is also one of the options included in the failsafe boot.

Oh, and just to be sure: I had memtest86 running overnight and it reported no problems (for weird stuff like this, I generally suspect faulty RAM).

It is also one of the options included in the failsafe boot.
Odd, not for me it’s not.

title Failsafe – openSUSE 11.1 -
root (hd0,1)
kernel /boot/vmlinuz- root=/dev/disk/by-id/ata-ST9160827AS_5RF16D1B-part2 showopts ide=nodma apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x367
initrd /boot/initrd-
Neither is: noapic
did you try that?

Ah, you’re right, it isn’t in the default. I did try it though, both noacpi as well as acpi=off (also tried apm, just in case).

Just did, to no avail.

To get opensuse to install on my Acer laptop (different model) I had to use the boot options:

noapic nolapic

When your computer boots (with a usb key installed) can you use the webcam?

Tried that now. Made no difference.

Interesting. Adding a USB device does move the webcam to device 3 on the bus. I haven’t used a GUI install of Linux before, just 10 years of CLI up to now, so I’m not sure if I’m testing the right thing, but Kopete has no listing of the webcam. lsusb on the other hand seems to find it:

Bus 003 Device 003: ID 0402:5602 ALi Corp. Video Camera Controller
Bus 003 Device 002: ID 090c:1000 Feiya Technology Corp. Memory Bar
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Bus 3 is the USB port on the side of the laptop. There are also two ports on the back. I haven’t tried whether there is a difference when something is plugged into those.

Edit: tried the other port and it boots fine with the USB drive in there too. I’m not too familiar with the workings of USB, but the webcam seems to shift along with it, as well as USB1.1/2.0 status:

Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 090c:1000 Feiya Technology Corp. Memory Bar
Bus 001 Device 002: ID 0402:5602 ALi Corp. Video Camera Controller
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

To me, that’s a little surprising, although it may be perfectly normal for all I know.

I suspect that what’s happening is that USB camera is confusing things. When you have something plugged in that gets recognized correctly then accessing the USB works because there’s a device on the same USB bus that your system knows how to talk to.

Are there any options to control this in the bios?

Unfortunately not. The BIOS seems to have fewer options than a Mac mouse. Change the boot order, password, VRAM size and splash screen and that’s about it.

Does that mean my options are to either always have the USB key or perhaps to disable USB support entirely? I won’t ever use the webcam and would gladly physically rip it off the **** laptop, but my mother always taught me violence wouldn’t solve anything :wink:

It’s possible that if you get the correct driver loaded at the right time you could avoid that (which is why I asked if it ever worked)

You might also try booting off of live cds of different distros as this is one of the things that different ones handle… you know… a little differently.

Thanks for the help and advice.

It seems that this particular webcam isn’t very well supported under Linux at present and it stands to reason that that is indeed the problem.

I’m not at all interested in the webcam itself, but was just trying to see if it would be feasible to use a Linux desktop rather than Windows for my day-to-day work. Had this old laptop lying around for testing purposes.

This glitch is annoying (and I find the graphics corruption and freeze rather curious symptoms), but won’t really affect that.

Although I might check out some other Live CDs, I think I’ll stick with openSUSE as it’s the one I’m most familiar with (having started with SuSE 6.1 in 1999).

Thanks again!