Freeze at boot, no flash :(

im a new user of opensuse and installed 12.1 When i start the system normally the systen freezes while loading the sign in menu and start beeping continually. I discovered that i can start the system with the failsafe option, which works normally.
I have a HP pavilion With Amd athlon 64 xp 3200+ Nvidia Geforce ti4200 and 1gm memory. I tried to install a nvidia driver through their server (or how should i call it?). i dont know whether it worked but since then the flash content on the internet doesnt work.

Are these 2 problems connected and how do i fix them?

i hope u can help, thanks!

Flash has a bug
Disable the hardware acceleration for flash

Just in case](

But is this related to my unablility to boot in normal (non-failsafe) mode? I know this flash menu but all the flash stuff doesnt appear at all so im afraid i cant get to this menu either…

This sounds like a graphic card problem. What graphic card do you have? Have you installed the propritary driver for it?