freewrl installed successfuly but does not work

Hello every body :slight_smile:
I have just installed a new freewrl software to use it in specific application and tried to test it by typing freewrl command in the terminal as the following:

nobani@linux-m9c6:~> freewrl
freewrl: error while loading shared libraries: libmozjs.so: cannot open shared object file: No such file or directory
nobani@linux-m9c6:~>

Also I am trying to use it by clicking the freewrl icon in the kickof application launcher without any success.

I am using openSUSE11.2 with default KDE

thanks a lot
:slight_smile:

al-nobani wrote:
> Hello every body :slight_smile:
> I have just installed a new freewrl software

how did you install it?

that is, i visited the source website <http://freewrl.sourceforge.net/>

and do not see instructions for installing on openSUSE, nor any
rpms–so, did you download the source and compile/install…or??

if you did compile/install did you have any errors? (apparently
libmozjs.so is required but not available on your machine, a fact that
i’d expect the configure/make to complained about)


DenverD (Linux Counter 282315)
CAVEAT: http://is.gd/bpoMD
via NNTP w/TBird 2.0.0.23 | KDE 3.5.7 | openSUSE 10.3
2.6.22.19-0.4-default SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Bummer that there seems to be some silliness somewhere in the logic behind
this utility. The freewrl command is loaded directly without setting up
an LD_LIBRARY_PATH that would find the libmozjs.so file (I have the same
thing as you… x86_64 and Gnome). Easy enough to fix, though.

#x86_64 system like mine… hacked workaround:
LD_PRELOAD=/usr/lib64/xulrunner-1.9.1.10/libmozjs.so freewrl

#x86_32 system should be similar, but probably just ‘lib’ instead of ‘lib64’.

Put the stuff above in a script called ‘freewrl’ in your user’s ‘bin’
directory (~/bin/freewrl) and that should do it… at least until you get
to the next error that may be specific to my system or maybe is not:

<quote>
opengl version=2.1 Mesa 7.6
FreeType - can not use font /usr/share/fonts/VeraMono.ttf
dont know how to handle font id 0
FreeType - can not use font /usr/share/fonts
FreeWRL got a SIGSEGV - can you please mail the file(s) to
freewrl-09@rogers.com with a valid subject line. Thanks.
</quote>

The path above to the VeraMono.ttf file does not exist, but that file
exists instead at /usr/share/fonts/truetype/VeraMono.ttf. Not sure what
to make of that as that file comes with bitstream-vera-1.10-306.2.noarch
which was installed as a dependency of FreeWRL. Anyway, looks like this
needs some updating somewhere. To me this looks like a packaging problem
so perhaps try compiling from source or find an RPM elsewhere (or an older
one on the OpenSUSE Build Service (OBS)) to see if that helps.

Good luck.

On 07/04/2010 11:56 PM, al-nobani wrote:
>
> Hello every body :slight_smile:
> I have just installed a new freewrl software to use it in specific
> application and tried to test it by typing freewrl command in the
> terminal as the following:
>
> Code:
> --------------------
> nobani@linux-m9c6:~> freewrl
> freewrl: error while loading shared libraries: libmozjs.so: cannot open shared object file: No such file or directory
> nobani@linux-m9c6:~>
>
> --------------------
>
> Also I am trying to use it by clicking the freewrl icon in the kickof
> application launcher without any success.
>
> I am using openSUSE11.2 with default KDE
>
> thanks a lot
> :slight_smile:
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.12 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJMMX6SAAoJEF+XTK08PnB5EP4P/jVwHUpNUS80qQZpNjDlXtNt
Ps+gKZ2DpyXml9UDZuFsXO7GuutWtJKEiMX6uvInupMsAq8C1oNnW5IRCoSH2xJ8
xOSac5tzSY8jK19gx1mKwp44/95u5uO3gXBnF/7pumUC3sb2+08+56AT2HzONFXJ
tAPlOTzoKNKmYOuNSFnXKofm/+pD3XqA03QmX4Ec8Y6DZyuCVaDulUdmUVqs5oad
t394CHU7fTJ+yBQtgs1/splaH43bldmbkkb567pEzb3FHaQs3JmpfqhrwUWglNUj
yE6JooT+v0y1KPgJwIfDlwktBCH4zDq7tjUFZCkEE5vkYj+irWfY27eVnmODueNa
gBGtp3pvL6XcjT63mtTtPDrUkdxyhSzksjQ/7v8jt/WwtDA3de8mGqUf+RoYT8u5
pPUdy7RFeBEcIFKJKXPcl5+ld8aidZ6rsgtD05AmCCoY9zc5Q4RzXZ9DzuH/D1vN
UtA0nAu5S2e4oXOjn3BkvhDuAIT2YUTreH6q5fnnCCRDDl4wZg7t66V7o/Mr8U/+
jvrQbAIUmW/MiJoeXhDYv0VZCVchLVr9vELDlSWbIaEzOl1Vd7/oYUF/WkuE2T3L
6VQBzlS/6neYcLxYU66xGrEFiG1KUc5KGhFLKaO/6++zJxiJbiTlErCga5Jax6Jf
Es8hpFxXChDRDgOWMUcK
=9m5P
-----END PGP SIGNATURE-----

Yes I get the same error massage.
have a look:

nobani@linux-m9c6:~> freewrl
opengl version=2.1 Mesa 7.6
FreeType - can not use font /usr/share/fonts/VeraMono.ttf
dont know how to handle font id 0
FreeType - can not use font /usr/share/fonts
FreeWRL got a SIGSEGV - can you please mail the file(s) to
 [email]freewrl-09@rogers.com[/email] with a valid subject line. Thanks.
nobani@linux-m9c6:~>

then I do not know what I have to do??
Any Idea???

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

First, and I do mean first, copy/paste what you have below to the e-mail
address as requested. This will hopefully fix things in the future. Cite
this thread for fun so the author can see the entire discussion.

Second, I can get past this by giving the app what it wants as follows:

sudo cp /usr/share/fonts/truetype/VeraMono.ttf /usr/share/fonts

Dirty hack, but it works.

Seriously, though, please send the e-mail first before you forget or else
you’ll fight this forever needlessly.

Good luck.

On 07/05/2010 02:56 AM, al-nobani wrote:
>
> Yes I get the same error massage.
> have a look:
>
> Code:
> --------------------
> nobani@linux-m9c6:~> freewrl
> opengl version=2.1 Mesa 7.6
> FreeType - can not use font /usr/share/fonts/VeraMono.ttf
> dont know how to handle font id 0
> FreeType - can not use font /usr/share/fonts
> FreeWRL got a SIGSEGV - can you please mail the file(s) to
> freewrl-09@rogers.com with a valid subject line. Thanks.
> nobani@linux-m9c6:~>
> --------------------
>
>
> then I do not know what I have to do??
> Any Idea???
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.12 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJMMdVzAAoJEF+XTK08PnB5aCwQAMd8ovOd80lV0fBy2evY+6h3
EiMIugTgAwzLyLlN4/SfEuzN6uVDwd1xi4g9En6Vg03SjgZ4V74mN/wY4upTPb48
hwCGe+n2/98ZXfb8Prujn0Zn3zerxT2LfNK95s5vrBKgt5rt7b0XPl7GKl+vHmgZ
NxYl/w51DqkbW5gukQI70dhttnVg26Hef2jhxXhxpdSwqEC16lg0UEZxlCGMq+nv
oy49YbIfrodqhoTkD7aficyFFyvRnAOatk7Kc4s8qq4U1ODERPKVXOxjGZ1459kf
Luul20lvFgt6eY9otg5e0RUU9r7ACVg2yZ0Nv74S1SyehypOe7HGiUzLTh55TXrL
rqrFC4RaxmU1qweG9dahcRyKQly+n9k2EWbDwMjx90FtZtIpOSGskxc53I/0kWMM
x7OpvDVq/2sWbvMJfzOLj7C6l1XLuhqaNABwq387ZO0HA6tvsEgIpom5MTy54SFb
leZhSNQiRIyrL7epZlZDs24w77c44TdV8w+dW2CVMLf8f96GeRZNbH1RhDiF6Q0N
LhIunYzBD7pr8kho2DRKqW3zchhy1EE6j84z07OlOS5lJqcfBO3RQ35bFmlgg85C
HP49MZfI6IJDPjsoqSnnh8uD7oYbj0lnKzKXsb/s0DDyhe4WfSYX1g02bCBpqWym
Wo55u5SAkpTlPFhWLIkO
=9CPW
-----END PGP SIGNATURE-----

Thank you very much :slight_smile:
It is work correctly now
I sent the developers the error’s mail

Cheers, :wink:

Hi,
I have the similar problem. I tried to install freewrl-1.22.12_pre2 on OpenSuSE 12.1 (64bit), it compiled without error, but failed to run, I got the following error message:

jyh-shyong@linux-i7:~/Downloads/freewrl/freex3d> /usr/local/bin/freewrl
FreeWRL expected library version 1.22.12, got 1.22.13…
fwl_startFreeWRL called
opengl version=1.4 (2.1.2 NVIDIA 290.10)
xfont not initialized !!! initializing with defaults (fixed white)
Internal error: directory does not exist: /usr/local/share/freewrl/fonts
font directory=(null)
No Fonts; check the build parameter --with-fontsdir, or set FREEWRL_FONTS_DIR environment variable
Could not find System Fonts for Text nodes
FreeWRL got a SIGSEGV - can you please mail the file(s) to
freewrl-09@rogers.com with a valid subject line. Thanks.

Any suggestions? Thanks

On my laptop:


> LD_PRELOAD=/usr/lib64/xulrunner-2.0.1/libmozjs.so freewrl
freewrl: error while loading shared libraries: libmozjs.so.2d: cannot open shared object file: No such file or directory