FreeTDS, unixODBC, openSUSE, MSSQL 2008 DSN Question

Hello there,

Since I’m new to Suse Linux but have to work with it, I encounter a lot of problems. Most of these could be solved by asking Google.

If this question is in the wrong forum please move it instead of deleting, I was not sure where to put it.

Now I have a bigger problem with no solution found yet.

I have to connect to a MSSQL Database using a DSN. But creating a DSN seems more difficult then I thought.

I downloaded both freeTDS and unixODBC bye using configure, make, make install as usual.

But as odbcinst didn’t work correctly I found a tip where it said to install it in reverse order. The first time I first installed freeTDS then unixODBC, but they said it should be reverse order. Then I uninstalled both using make uninstall and installed them in the “right” order.

Now there where no files in “/usr/local/freeTDS” only folders. So the ODBC drivers are gone.

I manually changed the .odbc.ini in my home folder so when I now call “odbcinst -q -s” it shows me one datasource but when I call “odbcinst -q -d” it returns “odbcinst: SQLGetPrivateProfileString failed with .” which doesn’t help me at all.
I think it says that there is no driver installed, but how can I reinstall it?

I tried to make uninstall, configure, make, make install a few times but it won’t put any files into /usr/local/freeTDS, and the usual file “” does not exist, neither in this folder nor in any other folder.

Does anyone know how to repair this?

PS: I once had installed the Easysoft ODBC drivers and iODBC but I didn’t know how to uninstall them because they only gave me errors.

After installing freetds did you edit the config file ( default is /usr/local/etc/freetds.conf so that you have an entry for the sql server you want to connect to?
If so did you test it using tsql to ensure that freetds is working?

The first Time I installed it I could connect by using tsql but not isql, the second time none of these was possible.