FreeNX currently not working at 11.0

Good evening gentlemen! :stuck_out_tongue:

Like title says, currently FreeNX doesn’t work at all when installed from dvd/repo. I already posted about this to applications as I though it was not so important but lets try again as I managed to debug bit more as I have more time now.

Ookay… Client tried to connect to 11.0 FreeNX server, error be this:

NX> 203 NXSSH running with pid: 6405
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: 83.145.207.142 on port: 8800
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
HELLO NXSERVER - Version 1.5.0-70 OS (GPL, using backend: 2.1.0)
NX> 105 hello NXCLIENT - Version 1.5.0
NX> 134 Accepted protocol: 1.5.0
NX> 105 SET SHELL_MODE SHELL
NX> 105 SET AUTH_MODE PASSWORD
NX> 105 login
NX> 101 User: hyuga
NX> 102 Password:
NX> 103 Welcome to: Nyang user: hyuga
NX> 105 listsession --user=“hyuga” --status=“suspended,running” --geometry=“1280x800x32+render” --type=“unix-gnome”
NX> 127 Sessions list of user ‘hyuga’ for reconnect:

Display Type Session ID Options Depth Screen Status Session Name


NX> 148 Server capacity: not reached for user: hyuga
NX> 105 startsession --link=“adsl” --backingstore=“1” --encryption=“1” --cache=“16M” --images=“64M” --media=“0” --session=“Soluto NX” --type=“unix-gnome” --geometry=“1024x768+128+0” --kbtype=“query” --screeninfo=“1024x768x32+render”

NX> 1000 NXNODE - Version 1.5.0-70 OS (GPL, using backend: 2.1.0)
NX> 700 Session id: Nyang-1000-2B690AA918E9DC0D6D9AB60FD5F6C6E3
NX> 705 Session display: 1000
NX> 703 Session type: unix-gnome
NX> 701 Proxy cookie: c037a9457e64ffbc0601837eb90eb21c
NX> 702 Proxy IP: 127.0.0.1
NX> 706 Agent cookie: c037a9457e64ffbc0601837eb90eb21c
NX> 704 Session cache: unix-gnome
NX> 707 SSL tunneling: 1
NX> 105 /usr/bin/nxserver: line 1368: 4424 Terminated sleep $AGENT_STARTUP_TIMEOUT
NX> 596 Session startup failed.
NX> 1004 Error: NX Agent exited with exit status 1. To troubleshoot set SESSION_LOG_CLEAN=0 in node.conf and investigate “/home/hyuga/.nx/F-C-Nyang-1000-2B690AA918E9DC0D6D9AB60FD5F6C6E3/session”. You might also want to try: ssh -X myserver; /usr/bin/nxnode --agent to test the basic functionality. Session log follows:
Can’t open /var/lib/nxserver/db/running/sessionId{2B690AA918E9DC0D6D9AB60FD5F6C6E3}: No such file or directory.
mv: NX> 1006 Session status: closed
NX> 1001 Bye.
cannot stat `/var/lib/nxserver/db/running/sessionId{2B690AA918E9DC0D6D9AB60FD5F6C6E3}’: No such file or directory
NX> 280 Exiting on signal: 15

and if we try to debug bit further to /sessions file we can see this:

xrdb: No such file or directory
xrdb: Can’t open display ‘:1000’

(gnome-session:4702): Gtk-WARNING **: cannot open display: :1000

There is no firewall’s and new server has been installed from 11.0 DVD.

Ideas are welcome, meanwhile I continue debugging.

/var/log/nxserver is saying this.

– NX SERVER START: -c /usr/bin/nxserver - ORIG_COMMAND=
HELLO NXSERVER - Version 1.5.0-70 OS (GPL, using backend: 2.1.0)
NX> 105 hello NXCLIENT - Version 1.5.0
NX> 134 Accepted protocol: 1.5.0
NX> 105 SET SHELL_MODE SHELL
NX> 105 SET AUTH_MODE PASSWORD
NX> 105 login
NX> 101 User: hyuga
NX> 102 Password:
Info: Auth method: passdb ssh
NX> 103 Welcome to: Nyang user: hyuga
NX> 105 listsession --user=“hyuga” --status=“suspended,running” --geometry=“1280x800x32+render” --type=“unix-gnome”
NX> 127 Sessions list of user ‘hyuga’ for reconnect:

Display Type Session ID Options Depth Screen Status Session Name


NX> 148 Server capacity: not reached for user: hyuga
NX> 105 startsession --link=“adsl” --backingstore=“1” --encryption=“1” --cache=“16M” --images=“64M” --media=“0” --session=“Soluto NX” --type=“unix-gnome” --geometry=“1024x768+128+0” --kbtype=“query” --screeninfo=“1024x768x32+render”

&link=adsl&backingstore=1&encryption=1&cache=16M&images=64M&media=0&session=Soluto NX&type=unix-gnome&geometry=1024x768+128+0&kbtype=query&screeninfo=1024x768x32+render&clientproto=1.5.0&user=hyuga&userip=80.221.50.65&uniqueid=2D3EFF5779E852CE8F1B07A12D7521A7&display=1000&host=127.0.0.1
Password:
server_nxnode_echo: NX> 1000 NXNODE - Version 1.5.0-70 OS (GPL, using backend: 2.1.0)
NX> 1000 NXNODE - Version 1.5.0-70 OS (GPL, using backend: 2.1.0)
NX> 700 Session id: Nyang-1000-2D3EFF5779E852CE8F1B07A12D7521A7
NX> 705 Session display: 1000
NX> 703 Session type: unix-gnome
NX> 701 Proxy cookie: 8be206fc66a943f5616c4c89dd2de520
NX> 702 Proxy IP: 127.0.0.1
NX> 706 Agent cookie: 8be206fc66a943f5616c4c89dd2de520
NX> 704 Session cache: unix-gnome
NX> 707 SSL tunneling: 1
server_nxnode_echo: NX> 700 Session id: Nyang-1000-2D3EFF5779E852CE8F1B07A12D7521A7
server_nxnode_echo: NX> 705 Session display: 1000
server_nxnode_echo: NX> 703 Session type: unix-gnome
server_nxnode_echo: NX> 701 Proxy cookie: 8be206fc66a943f5616c4c89dd2de520
server_nxnode_echo: NX> 702 Proxy IP: 127.0.0.1
server_nxnode_echo: NX> 706 Agent cookie: 8be206fc66a943f5616c4c89dd2de520
server_nxnode_echo: NX> 704 Session cache: unix-gnome
server_nxnode_echo: NX> 707 SSL tunneling: 1
NX> 1004 Error: NX Agent exited with exit status 1. To troubleshoot set SESSION_LOG_CLEAN=0 in node.conf and investigate “/home/hyuga/.nx/F-C-Nyang-1000-2D3EFF5779E852CE8F1B07A12D7521A7/session”. You might also want to try: ssh -X myserver; /usr/bin/nxnode --agent to test the basic functionality. Session log follows:
/usr/bin/nxnode: line 540: 5965 Terminated PATH="$PATH_BIN:$PATH" $PATH_BIN/nxagent $P $R -name “NX - $user@$SERVER_NAME:$display - $session (GPL Edition)” -option “$USER_FAKE_HOME/.nx/C-$sess_id/options” $K $G $B $FP $AGENT_EXTRA_OPTIONS_X :$display 2>&3
NX> 105 xrdb: No such file or directory
xrdb: Can’t open display ‘:1000’

(gnome-session:5982): Gtk-WARNING **: cannot open display: :1000
NX> 1006 Session status: closed
server_nxnode_echo: NX> 596 Session startup failed.
NX> 596 Session startup failed.
server_nxnode_echo: NX> 1004 Error: NX Agent exited with exit status 1. To troubleshoot set SESSION_LOG_CLEAN=0 in node.conf and investigate “/home/hyuga/.nx/F-C-Nyang-1000-2D3EFF5779E852CE8F1B07A12D7521A7/session”. You might also want to try: ssh -X myserver; /usr/bin/nxnode --agent to test the basic functionality. Session log follows:
session_close 2D3EFF5779E852CE8F1B07A12D7521A7
NX> 1001 Bye.
server_nxnode_echo: NX> 1006 Session status: closed
server_nxnode_echo: NX> 1001 Bye.

same problem here, qtnx says:

Process started
stderr> Warning: Identity file id.key not accessible: No such file or directory.
Pseudo-terminal will not be allocated because stdin is not a terminal.

This seem to be a bug in qtnx.
I got that error too and tried to copy that file
from host machine to different directories.
Also tried different versions of qtnx from various repositories.
Nevertheless it wouldn’t start.

The solution was simple - installing NoMachine’s client-application:
NoMachine NX - Download: NX Client for Linux
I tried i386 (32-bit) rpm, it worked connected straight after configuration
and I didn’t have to copy anything from host machine.

Hi

Does anybody know if this error has come up in 11.2 ?

I have used NX-client (both Windows and Linux) together with FreeNX from BuildService on 11.1 without problem. Okay - sometimes I have to connect 2-3 times before success.

But now I run 64bit versions both on client and server, and I am not able to connect anymore.

Logs says:
NX> 707 SSL tunneling: 1
NX> 1009 Session status: starting
/usr/bin/nxserver: line 1371: 16291 Terminated sleep $AGENT_STARTUP_TIMEOUT
NX> 105 NX> 596 Session startup failed.
NX> 1004 Error: NX Agent exited with exit status 1. To troubleshoot set SESSION_LOG_CLEAN=0 in node.conf and investigate “/home/jhj/.nx/F-C-hp-1000-EA450C2092419CBFF4FA5F0D9E7EF4CF/session”. You might also want to try: ssh -X myserver; /usr/bin/nxnode --agent to test the basic functionality. Session log follows:
NX> 1009 Session status: starting
Can’t open /var/lib/nxserver/db/running/sessionId{EA450C2092419CBFF4FA5F0D9E7EF4CF}: No such file or directory.
mv: cannot stat `/var/lib/nxserver/db/running/sessionId{EA450C2092419CBFF4FA5F0D9E7EF4CF}’: No such file or directory
NX> 1006 Session status: closed
NX> 280 Exiting on signal: 15

Firewall and tunnel should be okay, as ssh to server is possible

FreeNX version: FreeNX-0.7.2-26.1.x86_64
NX Client for Linux: 3.4.0-5, 64 bit-version

Jan

We have a similar Problem here with openSUSE 11.2.
When connecting the !M-Symbol appears shortly
than the monitor just flickers and the connection
is closed / terminated.

/var/log/nxserver.log:

-- NX SERVER START: -c /usr/bin/nxserver - ORIG_COMMAND=
HELLO NXSERVER - Version 2.1.0-72 OS (GPL, using backend: 3.2.0)
NX> 105 hello NXCLIENT - Version 2.1.0
NX> 134 Accepted protocol: 2.1.0
NX> 105 SET SHELL_MODE SHELL
NX> 105 SET AUTH_MODE PASSWORD
NX> 105 login
NX> 101 User: sthielen
NX> 102 Password:
Info: Auth method: passdb ssh
NX> 103 Welcome to: nx6 user: sthielen
NX> 105 listsession --user="sthielen" --status="suspended,running" --geometry="1280x1024x24+render+fullscreen" --
type="unix-kde"
NX> 127 Sessions list of user 'sthielen' for reconnect:

Display Type             Session ID                       Options  Depth Screen         Status      Session Name
------- ---------------- -------------------------------- -------- ----- -------------- ----------- -------------
-----------------


NX> 148 Server capacity: not reached for user: sthielen
NX> 105 startsession  --link="wan" --backingstore="1" --encryption="1" --cache="128M" --images="512M" --shmem="1"
 --shpix="1" --strict="0" --composite="1" --media="0" --session="sthielen" --type="unix-kde" --geometry="1280x102
4" --fullscreen="1" --client="linux" --keyboard="pc102/de" --screeninfo="1280x1024x24+render+fullscreen"

&link=wan&backingstore=1&encryption=1&cache=128M&images=512M&shmem=1&shpix=1&strict=0&composite=1&media=0&session                          =sthielen&type=unix-kde&geometry=1280x1024&fullscreen=1&client=linux&keyboard=pc102/de&screeninfo=1280x1024x24+re                          nder+fullscreen&clientproto=2.1.0&user=sthielen&userip=172.16.9.108&uniqueid=395EEB7665BECA8703FEC31E096455E7&dis                          play=1004&host=127.0.0.1
Password:
NX> 1000 NXNODE - Version 2.1.0-72 OS (GPL, using backend: 3.2.0)
server_nxnode_echo: NX> 1000 NXNODE - Version 2.1.0-72 OS (GPL, using backend: 3.2.0)
NX> 700 Session id: nx6-1004-395EEB7665BECA8703FEC31E096455E7
NX> 705 Session display: 1004
NX> 703 Session type: unix-kde
NX> 701 Proxy cookie: d19b62e0f0d00d76ed98be2fde21b49f
NX> 702 Proxy IP: 127.0.0.1
NX> 706 Agent cookie: d19b62e0f0d00d76ed98be2fde21b49f
NX> 704 Session cache: unix-kde
NX> 707 SSL tunneling: 1
server_nxnode_echo: NX> 700 Session id: nx6-1004-395EEB7665BECA8703FEC31E096455E7
server_nxnode_echo: NX> 705 Session display: 1004
server_nxnode_echo: NX> 703 Session type: unix-kde
server_nxnode_echo: NX> 701 Proxy cookie: d19b62e0f0d00d76ed98be2fde21b49f
server_nxnode_echo: NX> 702 Proxy IP: 127.0.0.1
server_nxnode_echo: NX> 706 Agent cookie: d19b62e0f0d00d76ed98be2fde21b49f
server_nxnode_echo: NX> 704 Session cache: unix-kde
server_nxnode_echo: NX> 707 SSL tunneling: 1
NX> 1009 Session status: starting
server_nxnode_echo: NX> 1009 Session status: starting
NX> 710 Session status: running
NX> 1002 Commit
NX> 1006 Session status: running
server_nxnode_echo: NX> 710 Session status: running
server_nxnode_echo: NX> 1002 Commit
session_status 395EEB7665BECA8703FEC31E096455E7 Running
NX> 105 server_nxnode_echo: NX> 1006 Session status: running
bye
Bye
NX> 999 Bye
NX> 1009 Session status: terminating
session_status 395EEB7665BECA8703FEC31E096455E7 Terminating
server_nxnode_echo: NX> 1009 Session status: terminating
NX> 1006 Session status: closed
session_close 395EEB7665BECA8703FEC31E096455E7
server_nxnode_echo: NX> 1006 Session status: closed
rm: Entfernen von Verzeichnis „/home/sthielen/.nx/C-nx6-1004-395EEB7665BECA8703FEC31E096455E7“ nicht möglich: Das                           Verzeichnis ist nicht leer
NX> 1001 Bye.
server_nxnode_echo: NX> 1001 Bye.

In openSUSE 11.0 and openSUSE 11.1 everything worked well.
SSH is working and we use the same configuration as in 11.1.
So how can we solute this problem?

Thanks in advance

Just a comment regarding Nx NoMachine. It worked fine for me and I was very happy with it. As soon as i upgraded to 11.1 I was not able to use it. So be aware! Not sure about 11.2 as I didn’t install it yet.

After many attempts I can login from a Windows Nomachine client /32 bit and into a 64 bit FreeNX server.
I tried 6-7 times switching between different linux users incl. root.

Jan

I have nx working fine on 11.2 (It was critical for me to put the servers name into the server /etc/hosts file)

However gnome-settings-daemon is having trouble and I cannot remap keys which for me is critical.
Unable to start the settings manager ‘gnome-settings-daemon’.
Without the GNOME settings manager running, some preferences may not take effect. This could indicate a problem with DBus, or a non-GNOME (e.g. KDE) settings manager may already be active and conflicting with the GNOME settings manager

I’m connecting to nx to localhost (so I can resume the session remotely)

Anyone else seen this behaviour?

Linux am-rjs 2.6.31.8-0.1-desktop #1 SMP PREEMPT 2009-12-15 23:55:40 +0100 x86_64 x86_64 x86_64 GNU/Linux

NXSERVER - Version 3.4.0-8

**Resolution for me: **delete file .ICEauthority on users profile.