Framebuffer "stty -a" results - differences for Tumbleweed and Leap 15.2

I’m trying to alter the virtual console size on a Leap 15.2 system to where it has the same size as a Tumbleweed system. When issuing “stty -a” on each system, I get: Tumbleweed: 240x67 (This is the tty size I’d like to see on Leap) Leap 15.2: 100x37 (Spending any time on the Leap system’s virtual console is almost like going back in time to an ITT AsciiScope.) The font setting in vconsole.conf is the same on both systems but on the Leap system, the displayed fonts are much larger. Both systems are up-to-date with their respective patches. In case this has anything to due with graphics drivers, the system running Tumbleweed is on a Ryzen CPU with the Vega GPU. The Leap system is running on Intel + Nvidia. I notice that the “nvidiafb” module is blacklisted on both systems. Should that be disabled on the Leap system with the Nvidia card/driver? Is there any other information that would help resolve this? TIA… (I hope the formatting of this is OK. When previewed, it was all smashed into a single paragraph.)

Likely the vconsole.conf font is not installed on the system(s)… eg I use ter-132n (terminus-bitmap-fonts).

Both systems are using “eurlatgr.psfu”. That’s installed on both systems. I tried the “ter-132n” font. Nice looking. However, it changed the virtual console screen size to “50x18” and the typeface is so large that I can almost read it from across the room without my glasses.

Any other ideas?

It can’t find it then, both files in same location? Similar issue here:

Is /etc/default/grub the same on both?


“diff -y grub.leap-system-with-100x37 grub.tumbleweed-system-with-240x67” shows a few (IMHO) trivial differences:

GRUB_TIMEOUT=8                  |GRUB_TIMEOUT=20

The “GRUB_CMDLINE_LINUX_DEFAULT=” parameters are the same except the Leap system has a “RESUME=” option that I’ll be removing—it’s a desktop so I couldn’t care less about resuming from hibernation.

Both have:


which are, I believe, the only parameters related to the console.

I recently got the console resolution a little higher using “FONT=ter-c12n” in /etc/vconsole.conf which increased the cols/rows to 133x50. Which isn’t bad. Trying to increase either of those results in the ever-so-helpful “‘standard input’ : Invalid argument” error message.

Somewhere there must be a setting for the amount of memory defined for consoles and lmiting the available dimensions of the virtual consoles. The frustrating thing is that so many manpages, the material in /usr/src/linux/Documentation, and web sites keep referring to tools that aren’t available any more. Not on the system and seemingly not available in the repositories… “cnf” is unable to locate an RPM containing them. A major cleanup of the Linux documentation is needed as so much of it refers to, apparently, deprecated tools and methods. I’m keen to read up on what needs to be done. But, shees, it’s like you’re a Windows user trying to get a better understanding of Win10 and going to the library only to find that the only books in the stacks are for Windows ME.

I ignore Grub for purposes of vttys. I use the default console font, and use video= to get the resolution I like best for producing best size fonts from default console font with whatever display I happen to have connected. Most often I’m using video=1440x900 on 1680x1050 or 1920x1200 native display (both 16:10), sometimes 1600x900 on a 2560x1440 native display when I’m not too lazy to hit the E key and change my personally configured via kernel cmdline default. When I’m connected to a Full HD TV, a larger but more distant screen, I’m usually using 1280x720 (720p), also with default console font. These non-native modes make vtty fonts comfortably sized for my antique eyes, and large enough that the actual resolution used is totally immaterial.

I take it that you’ve set up different Grub entries for the different resolutions you need (monitor vs. TV vs. whatever)?

I haven’t tinkered with “video=” or “vga=ask” since the Lilo days. I did try “vga=ask” on the Leap system but it seemed to ignore it and booted without asking for any input. I could give “video=” a try later today but both systems currently correctly report 1920x1080 (the monitor’s native resolution) for the root window when I run “xwininfo”. Seems like lacking “video=” results a autodetection.


Aside: What 1900x1200 monitor do you have? I had an LG with that resolution (keyword “had”)—I liked it a lot more than the Asus that replaced it.

Not exactly. Except for stanzas for starting OS installations, I have 2-3 video= entries per stanza, with the most commonly used last taking precedence. When I want another, I hit the E key and backspace back to the one I want, or edit the last to something else, or get rid of all.

Seems like lacking “video=” results a autodetection.
X autodetects. Except with the xf86-video-intel driver, X ignores video=. IOW, video= for most drivers applies only to the vttys.

Aside: What 1900x1200 monitor do you have?
One is Samsung made in 2012, the other NEC made in 2011. The 2560x1440 and 2560x1080 are considerably newer, the 1680x1050 also 2011.

“vga=ask” is interpreted by kernel real mode code, not by bootloader, and by default grub loads kernel in protected mode (also known as 16 bit vs. 32 bit). So code that would have asked is never called.

The Linux docs under /usr/src/linux still refer to vga=ask. They still refer to Lilo, too, [sigh]

I’ve managed to get the console screen size to 133x50. Not quite what I was looking for but big enough that I’ll consider this thread “kinda solved” and closed.

Odd. The following are what I’ve observed by screen resolution using the default 16x9 font:

Resolution	Columns X Rows
2560x1440	320x90
2560x1080	320x67
2048x1152	256x72
1920x1200	240x75
1920x1080	240x67
1680x1050	210x65
1600x1200	200x75
1600x900	200x56
1440x900	180x56
1400x1050	175x65
1366x768	170x48
1280x1024	160x64
1280x960	160x60
1280x800	160x50
1280x720	160x45
1024x768	128x48
800x600		100x37
640x480		80x30
640x400		80x25