Frame tearing on KDE Desktop -- NVidia Pascal

Hi, I’ve just installed OpenSuSE and am really enjoying learning about Linux, KDE, SuSE, etc. However, in all things except 3D video applications (games) I have rampant screen tearing. Some of the things I’ve tried to fix it with are compositor settings, X Server settings, display settings in the desktop, re-installing NVidia drivers, looking for (and not finding) xorg.conf settings in X11, switching window managers (plasma 5, plasma workspace, iceWM), etc. Nothing has fixed it, though I believe that things like VSync settings in the compositor have made (very) small differences. I’m just a bit stuck and in need of help from you fine folks. I I’m fairly new to Linux, but have a good deal of knowledge about computers in general. Thank you!

if you use the nvidia propitiatory driver check and see if compositing and v-sync are enabled, plasma 5 disables them if kwin5 crashes, what driver do you have G04 or G03, some new nvidia cards have an energy saving feature which causes tearing, I do belive you can change this with the nvidia-settings app
ftp://download.nvidia.com/XFree86/Linux-x86/370.28/README/nvidiasettings.html

Hello, and thank you! I am running G04 drivers, Nvidia proprietary. I believe that I’ve found the power setting in the application you mentioned, titled “PowerMizer.” However, I have no idea how to save it. I can save the configurations for the nvidia-settings application, but not the settings themselves. When you say to “Check to see if compositing and Vsync are enabled,” is that in the nvidia-settings application, or somewhere else? I have found settings for “Sync to v-blank” and “Video mixing” which sound quite similar. I was running the nvidia-settings application as root.

Thanks again, I_A! I appreciate the help.

Run as user the settings are saved in the user home and if root it will be in the root home /root . Unless you are moding xorg.conf in which case you do need to be root.Confusing??? yep welcome to NVIDIA on Linux

Thank you, Gogalthorp, I absolutely needed that! I believe that changing those settings has helped. I’ll keep looking around for a full solution. Much appreciated!

Alright folks, I found a workaround that works with my setup at this site: http://www.thelinuxrain.com/articles/got-tearing-with-proprietary-nvidia-try-this
The gist of it is that the command nvidia-settings --assign CurrentMetaMode=“nvidia-auto-select +0+0 { ForceCompositionPipeline = On }” works. I believe it forces the desktop composition into a frame-by-frame pipeline rather than the (for some reason default??) no-latency drawing. The article details how to commit these changes to permanence.

Thanks for your help folks, I really appreciate it! This was one of the last things really annoying me, and now I can truly begin to settle in to SuSE.

-Henry Wilson