forum: how do get rid of all formatting while pasting?

See for instance: https://forums.opensuse.org/showthread.php/509750-yast2-not-starting-any-more-loader-error-similar-to-already-closed-bug

The forum software formats text while pasting, even from for instance the Mac terminal.

How can I clear all pasted formatting in a post at once?

(ideally, I’d write something in markdown or reStructuredText, if the forum software can accept that, please indicate as well).

–jeroen

I have had that happen when using the “midori” browser or the “epiphany” browser.

I’m not sure, but I think it used to happen with “konqueror” before I told it to pretend that was “firefox” (the “user agent” setting).

Near the top left of the edit window, there’s a “A” icon. Try clicking that before you paste. I think that turns of automatic formatting.

Thanks a lot for your info.

I use primarily use Chrome on Mac OS X but have seen this on other Browser/OS combinations too.

The buttons https://www.dropbox.com/s/qz3xitapkcnda24/Screenshot%202015-09-17%2009.00.42.png?raw=1 have confused me big time as to me they look to create/remove hyperlinks as they have looked the text on the buttons for over two decades: blue underlined text.
Thanks to your info, I found out the first is to switch between the (default) WYSIWIG mode and text source mode https://www.dropbox.com/s/2r3i92luhuiadqi/Screenshot%202015-09-17%2009.08.56.png?raw=1. The second is to remove all formatting.

Does anyone know how to change the default?

As unlike for instance WordPress, the editor does not remember the last setting of the toggle.

–jeroen

Yes, I’ve probably seen it happen on chromium. The one where it doesn’t happen is firefox.

Does anyone know how to change the default?

I tried the “settings” link near the top right of the page.

From there, I clicked “general settings”.

Toward the bottom of the page, there’s a choice between:

  • Full WYSIWYG
  • A simple text box
  • Standard editor with extra controls

I have not tried those. The normal default is full WYSIWYG, which I am using. I would guess making a change there will do what you want.

May I suggest that the problem is in the copy/paste function one uses in the first place?

I have seen more and more of these “fancy” font specifications coming to posts the last time. They seem to come from excotic devices that want to show off to the outside world that they are there and know what text should look like.

Isn’t it realy not possible to configure their copy/past functionality in a way that it does it’s basics only: copying text.

It works properly with firefox.

It is broken with konqueror.

It works properly with konqueror when the user agent is set to say firefox.

This leads one to suspect that there’s a bug in the forum software, perhaps bad javascript for browsers other than firefox.

Ok, I see the facts.

But I still do not quite understand the mechanism. But this is maybe too theoretical to bring us any nearer to a solution.

  • The first thing is of course that there must be some font definition at the source of the text. Does my Konsole realy have such a thing in the text shown? And how? I doubt.
  • Then the copy/paste functionality (I use what I am offered by my KDE desktop and that is the same (or comptable with) X functionality I know for already 25 years or more), must be able to copy these font definitions also. And please take not, I know of no standard ruling here (there are of course standards in e.g. HTML, but are these HTML tags used in the different text sources (like Konsole) so the copy/paste can use them?
  • On the destination translation to the destionation way of using tags (the forums way) must be done. Java is mentioned above. But again from what format to the forums tags?

It is full of uncertain steps to me. But, as said, this may be to far going a theoretical path.

I’m not sure either.

I don’t have a problem with konsole. If I am doing copy/paste between two web sites, I often first paste into konsole, then recopy to paste into a web editor so as to avoid font problems.

From memory, if konqueror is not set to pretend to be firefox, then paste into the forum gives nothing and recopies. Or, sometimes it strips line breaks.

If I copy from konsole, then select that copied text in klipper, then use CTRL-V in the forum edit box, it usually pastes in correctly. The paste with middle-click is broken. However, if konqueror identifies itself as firefox, then middle-click works fine for pasting.

I have come across other sites with similar problems, though I don’t remember which ones.

Thanks for all those combinations. IMHO the short remark is: it is a mess :wink:

Indeed, the web-application that pastes content should allow to specify which of the clipboard formats to use. In this case, it lacks a “paste as (Unicode) text” option.

On 2015-09-19 09:56, hcvv wrote:

> - Then the copy/paste functionality (I use what I am offered by my KDE
> desktop and that is the same (or comptable with) X functionality I
> know for already 25 years or more), must be able to copy these font
> definitions also. And please take not, I know of no standard ruling
> here (there are of course standards in e.g. HTML, but are these HTML
> tags used in the different text sources (like Konsole) so the
> copy/paste can use them?

The current Linux desktop has (at least) two distinct copy-paste mechanisms.

One is accessed via the mouse, and is the traditional method. It pastes
plain text only. No formatting, no images.

Another is done via menu (edit-copy, edit-paste), or keys (ctr-C,
ctrl-V). It is desktop and application dependent, and can paste complete
format information (depends on the application). The menu can offer
“paste as” with a selection list with the possible format conversions
available.

To further complicate matters, desktops now have clipboard managers.
Some have reported weird issues in KDE when also the Gnome clipboard was
running.

It is this second method which could pose problems with the forum paste
(because it can paste format information). Possibly the browser requests
the wrong format from those available.

All this is theory, you know I will not experiment with all that :wink:

HTH.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

To remove formatting, before pasting I usually click the third button from left (mouse over gives “Paste as plain text”), paste inside the box and click OK. This may not do enough for you i.e. not a long post, but can be repeated. Sorry if missed a similar suggestion earlier on.

Cool, that works. Thanks!