Formate External Hardrive to ext3

I have a Westel 1 TB external hard drive and when attempting to partition it, the partitioner never finishes refreshing the device. I’ve tried gparted live, opensuse, & ubuntu; and none of them finish refreshing the device.

Another issue is, I have 200 gig of music & movies that can’t be wiped out because I got no room elsewhere to move them to. I would like to set a partition of 750 gig for the ext 3 and leave the rest for ntfs.

I’m confused - What is the correlation between the 1TB Drive and the 200GB of Movies?

Please explain more clearly.

I use Parted Magic, did you try this?

Sorry, there is 200 GB of music & movies on the 1 TB external drive. So there is 800 GB of free space. If I can get a solution, I can’t just wipe the drive clean and formate it to ext3. I have to shrink the external hard drive to 250 GB of NTFS, so I don’t lose my media. Then format the unallocated space to 750 GB of ext3. The issue is getting the partitioner to refresh the device. I will check Partition Magic out.

You should not attempt to shrink so tight. If you have 200GB I would leave the same free. So if it’s all one partition ATM.
Eg: sdc1 = 1TB

shrink sdc1 to 400GB (maybe 300GB)

Also - Has this been de-fragmented first?

I have de-fragmented it. I got Parted Magic yesterday, which didn’t hang up reading my device. It processed everything very efficiently. Although when I get to my 1 TB drive I can’t re-size it, all I can do is formate the whole drive.

The best I can figure is, find a spare drive to transfer my files to. Formate my 1TB drive to ext3. Finally transfer my files from the spare drive onto my 1TB drive. Too much loop-around?

You can’t resize it?..Ummm - That’s Odd.
If what you have is just 2 straight side by side Primary partitions, I can’t see why not!?

No, I don’t have two side by side primary partitions on the external hard drive. The whole drive is NTFS 931.3 GB. I want to change it to ext3, without losing my data on the drive. Keep part of it as NTFS and the other part ext3.

When I go into parted magic. Open gparted. It recognizes my external hard drive. I click on resize, but I can’t decrease the size. Not sure why. But, if I choose I can formate it to whatever I wish.

Unless I’m so confused and I’m missing something so simple, it seems like the loop around method (find a spare drive to transfer my files to. Formate my 1TB drive to ext3. Then, finally transfer my files from the spare drive back onto my 1TB drive) is my only route.

I’m just going in to Parted M now with a NTFS drive to see… I will report back

Like this:

caf4926, I’m sorry for the misinformation, I have a fat32 drive not NTFS. I kept over looking that detail and focused on the issue.

I have screen shots, but I’m not sure where or how to upload the them.

In parted magic my external hard drives information is
/dev/sbc1 (a yield sign) fat32 /media/sbc1/mybook 931.51gb boot,iba

When I try to resize:
free space preceding 0
new size 953867
free space following 0
minumum size 953867
maximum size 953867

I can’t resize either by text or dragging the graphical icon.

If I right click on drive I can formate to anything as expected ext2, ext3, etc.

Thank you for your patience

Screens can be uploaded to a place like ImageBam, but you need to create an account there first.

If you have a windows computer, doesn’t the disk management there let you do it?

I’ve been 99% windows free since 07" with the exception of running one program with Virtual box. Next time I’m around a windows machine I’ll give your suggestion a try. If that doesn’t work then I’ll go back to my original plan.

I didn’t mean for you to go out of your way to find a windows machine!

If you don’t have windows and are using FAT, I wonder how long it is since this drive was either formatted or defraged? They soon get messy.

What exactly happens when you try the re-size? Can you move the slider?
Re-size on a drive like this could take ages you know. I’d be inclined to move the files from it and format it.

The drive was given to me and I didn’t think to format it to ext 3 until I put nearly 200 GB on it. I was just happy to receive a 1TB hard drive for free.

When I try to move the slider in Gparted it doesn’t move. If I try to type a number in to resize it, no numbers change. To recap, the drive is 931.58GB. Gparted says the minimum size the drive can be is 953867 and the maximum size the drive can be is 953867. So I can’t change anything since the the minimum and maximum are the same number.

As you agree: move the files to another drive: formating the Fat 32 drive to ext 3: then move the files back onto the new ext 3 drive: and be happily transfering large files onto the newly formatted drive.

I think the Mybook products are intensionally made a little off to prevent people from formating etc. If you Google it there seems to be lots of problem with changing them. I have a 512gig my self but have never tried to format it I just use it to backup. From googling it looks like the best you can do is zap it and then you can format it like you want.