Forgot the magic "bootloader command"

I have a laptop with a crappy new SiS 672 Mirage 3 video card that, as I was soon to find out, doesn’t have any support on Linux and unfortunately it runs just at 1024x786 resolution in openSUSE. But that’s not the problem I am looking for help here.
I opened openSUSE several times and everything went fine, but I when decided to edit the bootloader and add my windows partition there, unfortunately it removed several arguments that I think were there for openSUSE. I’m not sure if this is the problem but without those arguments the X doesn’t start and I’m stuck with just command line. Anyone knows if I can add some arguments to my linux bootloader option so I can make it work again or is it something else.

Thank you.

If you get a grub boot screen, have you tried failsafe?

You can login as root and edit :

which the file you need to edit to add boot arguments

Browsing to /boot/grub with root privileges, you should find at least one backup file named something like menu.lst~ or menu.lst.old or menu.lst.old~ and similar. Hopefully there will be more than one. Without directly editing them, rename your current menu.lst to something else (like menu.lst.backup) and then make a copy of the newest of those files, making sure to name the copy menu.lst. Then try rebooting. If that doesn’t work, try with the second-newest file, and reboot. And so on, until you find one that works. Then back it up before you go messing with menu.lsts again. (Just a friendly advice). If you wish to add a windows stanza later on, come back here, you’ll find plenty of experts willing to lead you by the hand.
Good luck!

Thanks mates, you helped me solve this problem.

I found the menu.lst.old and it had

option there that was no longer in the new menu.lst. (I don’t know what exactly that does, it was added when I installed openSUSE, it could be helpful for other fellows that have problems with X and crappy SiS Mirage 3 video cards).

Cheers and thank you for the good directions (and openSUSE for backing up the menu.lst).

Cheerz to you and kudos to OpenSuSE for being such a great OS!rotfl!

Getting a bit sick of the wierd resolution 1024x786 on a laptop, I searched around and found out that you can use the

command in the bootloader to get all available resolutions.
I found out that 1280x786 works if I replace
. It’s quite strange that I wasn’t allowed to change the resolution to 1280x786 in YaST and I gave up hope that my crappy video card can work at higher resolution then 1024x786.

Anyway, it now works, and I just wanted to share it. Maybe future searches from users with SiS ( Silicon Integrated Systems ) 672 Mirage 3+ crappy video cards with no support on Linux might find useful.

thanks man, i just made an account to thank you.
i have the same chipset in my new laptop.
and had the same problem,
1024x768@16b and didn’t want to change.
i’ve add the vga line in groob and now it works at higher res and in 24b,
tough the refresh is really slow… :frowning:

i’ve found in a brazilian ubuntu forum about this (i can’t read portugues)

use driver vesa
and horizsync 30-63
and vertrefresh 50-75

is slightly faster

My laptop also has SiS 671/672 graphics. I’m using VESA at the moment, but the maximum possible screen size is 1024x768. Could I use 1024x576 instead (still small, but at least it’s 16:9, not 4:3 - the 1024x768 size stretches everything here) or VESA driver really doesn’t support widescreen?

P.S.: My distro: openSUSE 11.3 64-bit

Where did you found that topic? I’m Brazilian and Portuguese is my main language, so I think I could help you on it :wink:

To determine if 1024x56 is available, you could try typing:


and that might tell you if that resolution is available.

From what I can see, most users with the SiS671/672 graphics are using the ‘vesa’ graphic driver, although there may be work going on to provide a Linux compatible driver specific to this hardware. There is a massive Ubuntu thread here on this subject: [ubuntu] SiS 771/671 Mirage 3 Video Drivers!?!? - Page 57 - Ubuntu Forums]( and arch linux have packaged a driver specific for this hardware: AUR (en) - xf86-video-sis671

That packaged arch linux driver came from an effort of a Ubuntu user who ‘patched’ ( ?? ) the sis driver for the sis671 and uploaded the patched version to rapid share as a tarball: … one could try to download that and build it against openSUSE. The archlinux user’s post is here:

If anyone gets the ‘patched’ version to work for openSUSE, then IMHO we need to ask one of our openSUSE packagers to package it to make it easier for all our sis671 users to utilize.

Good luck and let us know if you succeed. … and also perhaps write a bug report on openSUSE-11.3 on this subject of drivers for sis671.

Note there is some basic openSUSE practical graphic card theory here (although it does NOT cover the sis671) : openSUSE Graphic Card Practical Theory Guide for Users

By typing


i got 1024x768, 800x600 and 640x480.
About the aforementioned SiS671 package, I already tried it, but during compilation it says it’s missing some libraries: xorg-server, xproto, fontsproto and x86dgaproto.

Thats not great, as the resolution you want is not immediately available, and so you will need to custom add the modeline that you need. I’m no expert on this (and only recently started researching this to teach myself about it - starting in post#49 in this thread openSUSE Graphic Card Practical Theory Guide for Users :slight_smile:

Maybe the command

cvt 1024 578 

‘might’ give you the information you need on how to set up a modeline for that resolution. Although once you get that information, you need to figure out how to add that to the appropriate /etc/X11/xorg.conf.d/ configuration file, and at this point my knowledge is lacking to give precise guidance.

Reference the packages you mention, they are likely there in openSUSE, but possibly with slightly different names. For example, maybe xproto is called: xorg-x11-proto-devel and that can be found in the OBS for openSUSE. Its possible libpixman-1-0-devel (also on OBS) has some of the other packages you need. Possibly the xorg-server is xorg-x11-server (or some permutation of it).

You could ask a packager to help you.

or you could raise a bug report on openSUSE-11.3, point out this package in the bug report, and advise a developer (in the bug report) that if they complile it for you, then you will test it :slight_smile:

There are often ways around these problems which at first appear insurmountable, but hopefully if we share the knowledge/problems on our forum that together we can find away to solve them for openSUSE ! :slight_smile:

Thankyou for taking the time to investigate this.