Forgot root password: cannot upgrade from 15.2 to 15.3

Hi,

I wanted to upgrade my desktop from 15.2 to 15.3. However i seem to have forgotten my password. I don’t have a 15.2 or 15.3 dvd. The tips here: https://en.opensuse.org/SDB:Recover_root_password aren’t working for me. My 15.2 boots into insecure mode.

Do i need to download 15.3 and try something?

I don’t want to do a fresh install. I had upgraded my laptop from 15.2 to 15.2 and its working fine.

What exactly “aren’t working” means? Describe what you did and what results you received. The best is full script of all commands and their output; failing that detailed description, may be with screenshots. Upload screenshots to https://susepaste.org/.

Hi, thanks for the reply. I tried booting into single user mode, but i was unsuccessful. I tried these instructions:

If text mode GRUB, hit 'e", then select the "kernel" line, hit "e"  again, and add " single" (or just " 1") to the end of the line. Press  ENTER, and then "b" to boot. (Newer version of grub uses "a" to append  to the boot line). If using graphical Grub, just append 1 or single on  the edit line.

After typing e in the grub menu and appending 1 at the end of the linuxefi line i pressed ENTER. But this just created new blank lines. I could not find any suitable links to troubleshoot this. I hope i’ve been lucid enough.

Single user requires root password.

After typing e in the grub menu and appending 1 at the end of the linuxefi line i pressed ENTER. But this just created new blank lines.

That’s correct, you are editing commands that grub will execute, you are in editor window. Do you actually read what computer tries to tell you? On the bottom it says "press Ctrl-X or F10 to boot ".

I didn’t know that.

Very kind of you, thank you. I did press F10 and it led to “Give root password for system maintenance”. So i went to the “init or /bin/bash” version. I added “init=/bin/bash” to the the Grub “kernel” line and then pressed F10. I ended up with a blank screen. So i thought that i must be doing something wrong but i couldn’t rectify it.

Ctrl-X never worked since i couldn’t get Caps Lock to work.

Additionally, add “plymouth.enable=0” to kernel command line.

@samrat_rao:

You seem to not have tried the “CD/DVD/USB recovery mode” – the 1st method mentioned in the SDB …

  • AFAIK, that’s the only reliable method of recovering the password of the user “root” …

This thread also speaks volumes for having separate Administrator users, with at least one who can reset the password of the user “root” …

And how exactly is this user supposed to do it? What exactly is “Administrator user” on Unix/Linux? Is it user with the name “Administrator”?

Thank you very much. I managed to reset the password. I’ll try to upgrade from 15.2 to 15.3 now.

Hi, i do not have the iso image. So i was trying other methods. I didn’t understand your last line. I am the sole user of the desktop. I login as a user with a different password. But to update / upgrade/ add packages etc i need the root password which i had forgotten.

Try the on-line way to do it. When in doubt ask here first before you go.

Forget about this, it wasn’t for you and might confuse you. :wink: