foobilliard

I just installed this game from Yast but it won’t start.
It is version 3.0a-2.5.2 and I got it from here: build.opensuse.org/games (as set in my Yast repositories)

Anyway, I wanted a great 3D billiard game like I used to have on SuSE 10.0. It was called, Foo Billiards.

Hello gymnart,

There’s some information missing in your post.
So could you tell us which version of openSUSE you have?

What happens when you run it from terminal?
Does it give an error message?

Best of luck!:wink:

Sorry, I forgot about that.
I’m running OpenSuSE 11.2 and I have the NVidia driver from the NVidia company installed - not Novell’s.

This is the result of running it in a terminal:
foobillard
usage: foobillard --option <arg>]]
options:
–player1 <arg>
arg=ai|human set player1 ai/human
–player2 <arg>
arg=ai|human set player2 ai/human
–p1 <arg>
arg=ai|human set player1 ai/human
–p2 <arg>
arg=ai|human set player2 ai/human
–name1 <arg>
set name of player1
–name2 <arg>
set name of player2
–8ball
8ball pool game
–9ball
9ball pool game
–carambol
carambol billard game
–snooker
snooker billard game
–tablecolor <arg>
table color in C-style hex notation <0xrrggbb>
–edgecolor <arg>
edge color in C-style hex notation <0xrrggbb>
–framecolor <arg>
frame color in C-style hex notation <0xrrggbb>
–chromeblue
blue table with chrome edges
–goldgreen
green table with gold edges
–goldred
red table with gold edges
–blackwhite
balck table with white frame
–blackbeige
beige table with balck metal
–tablesize <arg>
table size (length) in foot (default=7.0)
–lensflare
turn on lensfare
–nolensflare
turn off lensfare
–poslight
use positional light
–dirlight
use directional light
–ai1err <arg>
to err is artificial (player1 error 0…1)
–ai2err <arg>
to err is artificial (player2 error 0…1)
–balldetail <arg>
set ball detail l[ow] m[edium] h[igh] or v[eryhigh]
–rgstereo
start in stereo mode (red-green(cyan))
–rgaim <arg>
arg=left|right|middle for aiming eye position
–hostaddr <arg>
arg=IP-address for TCP/IP connection
–portnum <arg>
arg=port# for TCP/IP connection
–geometry <arg>
<width>x<height> window geometry
–fullscreen
play in fullscreen mode
–freemove <arg>
arg=on|off free move in external view mode
–cuberef <arg>
arg=on|off rendered cubemep reflections
–cuberes <arg>
arg=<texture size for cuberef> (must be power of 2)
–bumpref <arg>
arg=on|off bumpmap reflections of edges
–bumpwood <arg>
arg=on|off bumpmap of wood covers
–balltraces <arg>
arg=on|off trace lines of balls
–gamemode <arg>
arg=match|training|tournament
–fresnel <arg>
arg=on|off fresnel ball reflections
–avatar <arg>
arg=on|off enable/disable avatar
–tourfast <arg>
arg=1.0…10.0 AI fast motion ratio for tournament
–clothtex <arg>
arg=on|off for table detail map
–help
this help
the color <0xrrggbb> means one byte for each red, green, blue

Video mode set failed: Could not create GL context

Hello gymnart,

This error could be caused be several things.
First of all the graphics card driver.
You said you’ve installed the nVidia drivers from nVidia.
This should be ok, but just to make sure, could you post the output of this command:

glxinfo | grep "direct rendering"

Another reason could be that a specific color depth is not supported or set.
Could you post your /etc/X11/xorg.conf?
And I recommend that you try foobillard fullscreen and windowed.

A last reason could be that you’re not running an Xsever.
But I assume you know that you can’t start this game from an text session.

Good luck!:wink:

Here it is:


glxinfo | grep "direct rendering"
Error: glXCreateContext failed

I now strongly suspect that Foobilliard’s problems are related to this: xorg update/opengl update - ruined app
I was told to reinstall the driver so I will try that out.

Here is the /etc/X11/xorg.conf contents:


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder75)  Wed Jun  2 00:20:35 PDT 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection


Hello gymnart,

That explains a lot.

You could also try adding your user to the video group.
Just start YaST->Security and Users->User and Group management.
Select your user and press “edit”.
Then select the “Details” tab and on your right you’ll see a list of groups.
Select video and press ok.

Good luck!:wink: