Fonts unreadable

Following my update to 42.3, fonts in Chrome and Chromium are completely unreadable; just little squares.
No idea what caused this. I’ve installed various font packages, rebooted, to no avail.
Any pointers would be appreciated.

This would be my knee-jerk response: I would uninstall chrome and chromium and also excise the settings for chrome and chromium. The latter are stored in hidden files at these locations (depending what you actually installed):

  • /home/username/.cache/chromium
  • /home/username/.cache/google-chrome
  • /home/username/.cache/google-chrome-beta

Then I would reinstall the one I want.

But I don’t really know what’s wrong, this is just my knee-jerk. Good luck.

OOPs I just spotted these also:

  • /home/username/.config/chromium
  • /home/username/.config/google-chrome
  • /home/username/.config/google-chrome-beta

In addition, you may need to forcibly refresh the font caches:

  1. With the user “root”: ’ fonts-config -f -v’ and then ‘fc-cache -f -v’;
  2. And, then, from the affected user: ‘fc-cache -f -v’.

You should take note of the warnings issued by “fc-cache” regarding missing hidden font cache directories – create the missing directories and then re-run ‘fc-cache -f -v’.

I tried the first suggestion, removing the chrome profiles, but it didn’t help. I was about to try the font cache thing but I can no longer log in unfortunately.
Thanks for your help but I’m walking away. No reason to put myself through the grief I’ve had with Leap just to use desktop Linux.
Rant appearing shortly in the rant section if you’re interested.

Most likely this:

Exit, make sure all browser processes are terminated, and try running chromium or google chrome as follows

FREETYPE_PROPERTIES=“truetype:interpreter-version=35 /usr/bin/google-chrome”

Why “walk away” and also express dissatisfaction when, the solution is possibly the entry at the bottom of the Google Bug Report “Issue 726631” in Comment #83?

You were right bunge…, after setting the “GPU rasterization” back to default (from enabled) all the font rendering issues are gone. It might be something connected to my how my system is setup - nvidia optimus.

I don’t remember anymore what was the initial reason for enabling GPU rendering so I think I can live without it.

[HR][/HR]It seems that AT&T - Bell Labs language is also being used by Google:

We don’t have any errors or failures but, there are possibly some unresolved issues with the product.