Fonts, subpixel hinting etc in 12.2

Hi all,

I’ve just upgraded from 11.4 to 12.2 and (almost) everything went well. I’m surprised by the looks of Gnome 3, I must say. It doesn’t look so bad, in fact, I do like it.

Anyway, I can’t figure how to configure subpixel hinting. I see that there is no repository for 12.2 (it exist for 12s.1 and tumbleweed). Is it really needed?

Thanks a lot and keep up with the good work, opensuse!


I’m looking for it as well. On previous openSUSE, there are Muzlocker repo, but there are nothing for 12.2.

Am 08.09.2012 14:26, schrieb m goku:
> I’m looking for it as well. On previous openSUSE, there are Muzlocker
> repo, but there are nothing for 12.2.
I downloaded the muzlocker rpm’s which are for factory and use them in
12.2 without problem, just make sure you don’t keep the muzlocker
factory repo active to avoid breaking it later.

PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.4 | HD 3000
eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

I used
Index of /subpixel/Factory/

Work nicely, thank you

Oh. I tried Tumbleweed repo, but I didn’t notice any change. If you use Factory repo, can you configure subpixel hinting in Advanced Configuration then?
Thanks a lot.

I think Tumbleweed is a better approach, since Tumbleweed is rebased to 12.2.
So far, font rendering is as good as 12.1 with Muzlocker repo, exept for Chromium, where font still look ugly.

Thanks for the link, guys, I had been looking and couldn’t find a repo either.

For the record as well as the off-chance that somebody who knows is reading this: What is the reason that this still hasn’t made it into the official packages? The patents have expired. I’m honestly a little disappointed that subpixel hinting isn’t a higher priority for the devs - as it might be just a detail, albeight one that, I’m sure, many people would be happy to see improvements to.

No hard feelings at all here though. I love openSUSE and am deeply thankful for all the work that goes into it.

Muzlocker’s repo has not yet been updated for 12.2, at least as of today, however, I know that he is working on it. There is another subpixel font repo that you can implement for OpenSUSE 12.2 based on Infinality here:

Index of /repositories/home:/namtrac:/subpixel/openSUSE_12.2

You can read more about the Infinality project here:

Freetype Patches |

I am currently running OpenSUSE 12.2 as a test bed under Virtual Box prior to upgrading my everyday workhorse system from OpensSUSE 12.1 to 12.2. I have installed the Infinality subpixel repo on my 12.2 VM installation and it appears to significantly improve the font rendering very similarly to Muzlocker’s repo.

FYI… Gordon

I submitted a bug to include Muzlocker’s subpixel rendering into the official OpenSUSE distro several months ago and I also pointed out that many of the patents have expired, however, my suggestion was rejected. Here is the bug along with explanations from the developers:

I used the repo mentioned ( Index of /subpixel/Factory/ ) and it seemed to work. I switched to, installed, then disabled the repo. Not sure if I have to enable anything else I just enabled subpixel and slight in KDE settings. It does look a bit nicer.

@gldickens3, thanks for the link and explanations.

These are mine

Thanks for the info. :slight_smile:

Muzlocker’s 12.2 repo has been posted at:

Index of /repositories/home:/muzlocker/openSUSE_12.2



I’m using subpixel repo from namtrac. I also have a Windows installation and took some of the TrueType fonts from there to my liking, then configured everything and it works quite fine for me.

Just my finding. Switch to Muzlocker repo produce great font on KDE app but ugly on GTK app. So I install fonconfig from community subpixel repo and got the best result.

Make sure that you have configured your Personal Settings to use your KDE fonts in GTK applications with:

Personal Settings > Application Appearance > GTK Styles and Fonts > Check “Use my KDE fonts in GTK applications.”

Wow, thanks for that! Never noticed it, was always mildly annoyed with gtk fonts in kde…

Aargh I checked out all post/repositories. I just can’ t get it right!
My fonts in GTK applications really really suck.

There used to be an application “gnome-appearance-properties” in OpenSuse 10.3 that would do everything for me. A few clicks and everything was settled.
But I cannot find it, nor can I find the package to install it ???

I really makes me crazy.
Currently I have installed the packages from Index of /subpixel/openSUSE_Tumbleweed/x86_64/ .

My configuration panels of firefox look like the ones in kde. Chrome / chromium fonts suck. Firefox content of websites suck. Eclipse takes on font configured in “GTK Styles and Fonts” but rendering sucks. File-roller has huge fonts, I cannot change the way that program looks. Man, I totally lost it. I don’t know what to do anymore … . Just looks at how this page looks like : Ubuntu Forums - View Single Post - [SOLVED] 12.04 LTS / Precise Classic (No effects) Tweaks and tricks

Oke, yaaaay. I found it. You have to UNCHECK “Exclude range”.