Fonts not found in gtk application

Since some days I try to install ScicosLab under openSuSE 11.1. Because there
is no .rpm available for SuSE at all, I tried that one from Fedora and I tried to
recompile the sources. Both attempts now fail on the same point:
Starting “scilab + scicos” lead to a bundle of:

Unknown font : -adobe-courier-medium-r-normal–-80---m--iso8859-1
I’ll use font: fixed
Unknown font : fixed
Please call an X Wizard !

followed by:

(scilex:28164): Gdk-CRITICAL **: gdk_string_width: assertion `font !=
NULL’ failed

And all graphical Blocks and Palettes are without letters, so it’s unusable.

So because I’m not a X-Wizard, I try my best to call one her in this forum :wink:
All mentioned fonts are visible in KDEs
Configure Desktop -> Computer Administration -> Font Installer
no problem there, all mentioned ones are installed.

Here is my environment:
ScicosLab 4.3 by sources from .tar.gz compiled fine and by Fedora .RPM
openSuse 11.1 (which already have an Scicos
4.2 within there repositories,
but I want to use the 4.3)
KDE 4.2
IBM ThinkPad T40p (only for ad of this really
good old workhorse, should
not be important for my
problem :slight_smile:

Why not post your question in the opensuse-education sub forum. They
will probably be able to look at upgrading the version in the

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 23:24, 2 users, load average: 1.35, 1.52, 0.77
GPU GeForce 8600 GTS Silent - Driver Version: 185.18.14

Hi all,
some X-wizard helped me a lot in fixing this problem.
What we did:
Ignored the gtk version of Scicos and only use the X11 one:
“./configure --without-gtk2”
Patch the file accessing the fonts:
by replace all “iso8859” by “iso10646”

Now it works like a charm (even if the X11 user-interface looks very old-fashioned, it is quite ergonomic)