Font problems after today's font update

I use a java app, MoneyDance, which uses JRE 1.8.0-25. After today’s font update that java app is almost impossible to use due to the font.

The app uses:

initialised fonts:
base=java.awt.Font[family=Dialog,name=Helvetica Neue,style=plain,size=12]; 
numeric=java.awt.Font[family=Dialog,name=Gill Sans,style=plain,size=12]; 
register=java.awt.Font[family=Dialog,name=Helvetica Regular,style=plain,size=11]; 
header=java.awt.Font[family=Dialog,name=Helvetica Neue,style=plain,size=14]
multires images available: true
initialised mono font: java.awt.Fontfamily=Dialog,name=Gill Sans,style=plain,size=13

In the long list of available fonts in the font manager I don’t see Helvetica or Gill and I don’t know if there is a repo that has them for download nor do I know if adding them to my system would be helpful.

Is there any thing I can do with the system fonts to make it work better? I don’t understand how the fonts & font config work with my system. Everything else is working fine. In system config I tried changing tried changing general & also mono fonts and that did not have any effect on my problem.

Solved my problem.
First changed my system fonts from Oxygen to Liberation Sans. That had no impact on my java app but I liked the look and kept it.

I deleted the recently installed fonts noto-sans, google-noto-fonts, & google-roboto-fonts and then marked them taboo. This returned my java app to it’s prior condition. I don’t know why those fonts would interfere with my java app and I’d like more info if anyone has an idea.

I have a similar problem though not with a Java app but with browsers.

After this last update some fonts were updated here too and now many websites (e.g. Gmail, Google, this forum etc) display hair-thin the sans fonts which is a torture for my eyes and I almost always have to hit CTRL+"+" to zoom. I am using Chromium and Firefox. Any idea how to restore that to as it was?

Example of how it looks now in Chromium:

Interesting. I’ll think about trying that.

I don’t like what that font update did. Using “akregator”, bold and normal text are now almost indistinguishable on the list of feeds, making it hard to tell which feeds have unread items.

that’s how the openSUSE website has always looked for me - before and after updates.
If you don’t like the fonts displayed on webpages just go into chromium > advanced settings and change your preferred fonts there.
But I’m sure the openSUSE forums specify the font to be used so it shouldn’t have changed after the font update???

Using your repo for font hinting - thanks
It’s fantastic

That doesn’t help.

But I’m sure the openSUSE forums specify the font to be used so it shouldn’t have changed after the font update???

I am not so sure. For example li html elements have this computed CSS font property:

font-family: ‘Lucida Grande’, ‘Trebuchet MS’, Arial, Verdana, sans-serif;

Considering the first 4 Windows fonts will not be found, obviously the fallback is on the sans-serif which means some local system font is being used. So it is not a specific web font which the browser downloads and uses for the site itself.

BTW I partially fixed my problem by removing the --force-device-scale-factor=1 option which I was using to start chromium. However that made the fonts on some sites again a bit fuzzy/blurry which was the main reason for using that option. It gave me sharp but at the same time not hair-thin fonts before the update. Now I have to choose between good sized but blurry and hair thin.

I individually installed each of these 3 fonts that I previously marked taboo. The only one of these that gives me a problem with a “hair-thin” display that effects readability is when I have the “google-roboto-fonts” installed. So now I have the 2 noto fonts installed but the google-roboto font remains taboo’d. And I am not using any of these fonts AFAIK.

I have no more hair thin font problems at this time.