F'n Grub

well, in the last two and a half years, I have had a dual boot system consisting of Win XP and Suse 10.1…then 10.2…then 10.3 but since the geniuses at Novell decided to take down the repository’s for 10.3 because of 11.X now i’m forced to upgrade. I successfully installed 11.2 and it looks like a quality distro. However now I cannot set up grub. When I first started out with the problem, it said error 2. This is now fixed after 2 days of reading and tinkering. Now, I cannot even boot into either XP or 11.2 as all I get after post is “Disk boot failure, insert system disk and press enter”. When I load my disk and reload grub, it says success…etc… and then I reboot and I get the same error. Any help would be appreciated. I have read multiple hours on this subject and haven’t had any luck. Some of the articles I have found are Help! Grub didn’t install! - openSUSE ForumsGRUB Boot Multiboot openSUSE Windows (2000, XP, Vista) using the Grub bootloader.Grub Command For Loading Windows On Sda1 - openSUSE ForumsI can access yahoo messenger as itlbtu2 if someone would be so helpful in this issue.

Thank You

Dusty

I would just do a manual grub reinstall.

If you only have one hard drive, and one linux system installed, this is simple. It is less simple (slightly) if this isn’t the case, so post back for clarification.

Load your live CD / DVD. Get to a root prompt.

Type;


grub
find /boot/grub/menu.lst

Grub will tell you where the boot files are in grub notation. It will look something like (hd0,2). Put what it tells you in the next instruction (stop and post back if it says several things, or indeed nothing);


root (hd0,2)

Then put the first digit of what it told you in the next;


setup (hd0)
quit

Reboot, see how far that gets you. If it doesn’t work, get back to your root prompt on your disc, and again substituting what it told you, give us the output of


fdisk -l
grub
cat (hd0,2)/boot/grub/menu.lst
quit

First of all thanks for the reply. I rebooted the computer and I got “DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER”. I then inserted the openSUSE Installer disk and navigated to the rescue prompt. After using fdisk -l, I see

Device_____BOOT_____Start__End___Blocks___ID___System
/dev/sda1_1____262-2104483+_82 linuxSwap/Solaris
/dev/sda2
__263-9726___76019580____83__Linux
/dev/sdb1
____1___7296___58605088+___7_HPFS/NTFS

sorry it’s compacted but I think you get the point…I had to manually type that.

after “cat (hd0,1)/boot/grub/menu.lst” I get

default 0
timeout 8
##YaST - generic_mbr
gfxmenu (hd0,1)/boot/message
##YaST - active

###Don’t change this comment - YaST2 identifier: Original name: linux###
title SUSE LINUX
______root (hd0,1)
______kernel /boot/vmlinuz root=/dev/disk/by-id/ata-WDC_WD800BB-75JHC0_WD-WMAM9n201155-part2 resume=/dev/disk/by-id/ata-WDC_WD800BB-75JHCO_WD-WMAM9n201155-part1
splash=silent quiet showopts
_____Initrd /boot/initrd

###Don’t change this comment - YaST2 Identifier: Original name: failsafe###
title Failsafe – SUSE LINUX
____root(hd0,1)
____kernel /boot/vmlinuz root=/dev/disk/by-id/ata-WDC_WD800BB-75JHCO_WD-WMAM9n201155-part2 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe
initrd /boot/initrd

Sorry - to clarify - you ran


grub
root (hd0,1)
setup (hd0)

before you rebooted? Did they produce any error messages, or look like they worked?

Have you checked which disk is booting first in the BIOS?

yes, I did run

grub
root (hd0,1)
setup (hd0)

…all went well. No errors. My BIOS is set for IDE Channel 0 Master = Western Digital HDD (openSuse) and then IDE channel 0 Slave = Segate HDD (Windows XP) IDE channel 1 Master = DVDRW drive.

My Hard Disk Boot Priority is

  1. CH0 M. : WDC WD800BB - (suse)
  2. CH0 S. : ST360021A - (Win XP)

and then my boot sequence is

  1. CDROM
  2. HARD DISK
  3. Disabled
  4. Disabled

I have now corrupted the MBR using

dd if=/dev/zero of=/dev/sda bs=446 count=1

and then rebuilt it with a manual install of GRUB.

root (hd0,1)
setup (hd0)

and all I got was the same result “DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER”. It would sound believeable to think about checking the hardware for problems but less than 24 hrs ago, both drives were working and less than 4-5 hrs. ago, suse was loaded and I could see all NTFS files on the other drive…So I’m kind of ruling that out.

Thanks

Dusty

Have you got the boot priority correct.

When you do fdisk -l
what does it actually report? I mean actually.

After using fdisk -l, I see

Device_____BOOT_____Start__End___Blocks___ID___Sys tem
/dev/sda1_1____262-2104483+_82 linuxSwap/Solaris
/dev/sda2
__263-9726___76019580____83__Linux
/dev/sdb1
____1___7296___58605088+___7_HPFS/NTFS

that is very close to what I get. I could not copy & paste as I am on another laptop just to get on forums. I have however now decided to load Knoppix and try to check hard drives, install grub, etc…and I got this error.

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block (0,0)
…now not only is the Kernel panicking, I am as well…IDEAS???

You enter this ---------------- grub
Computer returns like this ---- grub>

You enter this ---------------- find /boot/grub/menu.lst
Computer returns like this ----
(hd0,1) Is this what you get?

You enter this ---------------- root (hd0,1)
Computer returns like this ---- Filesystem type is ext2fs, partition type 0x83 Do you see this?

You enter this ---------------- setup (hd0)
You see several lines like this — Checking if /boot/grub/stage1 exists … yes
Computer finally returns this-- Succeeded…Done And this?

You enter this ---------------- quit
You enter this ---------------- reboot

Yes, that is exactly what I Do/Get…I guess I didn’t understand what you were asking…But yes…grub> etc… (hd0,1) etc…

But find /boot/grub/menu.lst

It does actually say (hd0,1) nothing different
And it finally says success!

But it still doesn’t work?

Let me get this straight you did a dd to your boot sector and filled it with 0’s???

Sounds like you may have corrupted a partition table. :open_mouth:

I’ve read that that is the correct dd command to just write out the MBR, though I may be wrong…

This is way over my head. My only suggestion would be to use a ‘testdisk’ live CD to attempt to recover your data.

Sorry, and good luck. :\

yes I did dd the MBR but only with the first 446 blocks so that it will not mess with my partition tables.

On a different Issue, I loaded my 11.2 disk and got to the GUI repair side of it and it found that “BooT Loader Error Detected” - “The configuration of the boot loader contains errors. Press Repair to generate a new configuration automatically.” If you are sure your configuration contains no errors and your system is bootable, press Skip:

I clicked on repair…And then told it to repair MBR…It did. Then under the Boot Loader Installation tab, set the Boot loader location to "Boot from Master Boot Record and unchecked “Boot from Root Partition”. Clicked OK, rebuilt Grub and Rebooted…And now it still has the same Error “DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER”

Why no grub error I wonder.

This error is more like M$. Any chance you can pull the power on the M$ HD and try again - see if the same happens

I suppose you could try putting grub on SUSE’s root partition, making it bootable, and installing generic code to the MBR. Not quite sure how you’d achieve the last bit, but I’m sure you can figure it out - might be doable from your recovery console. “grub, root (hd0,1), setup (hd0,1)” would install grub there, and you can set the bootable flag with fdisk.

[edit - cross post. I’d go with caf’s suggestion first!]

I pulled the power on the M$ drive and still I got the error, “DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER”

beings I’m at my wits end with this problem, What would happen if I installed grub to every place possible, crossing my fingers and hoping for the best? Because as it sets now, having a computer with 3 operating system, (Win XP, OpenSuSE, and Knoppix) that will not boot really sucks.

I have an idea for You mate, change the boot priority to the disk on which XP is installed, after changing the priority boot from the Windows XP installadion disk and fixmbr then fixboot. After confirming that Windows boots fine change the disk boot priority in BIOS so that the Windows disk will be second and suse first. After changint that boot with openSUSE DVD and rescue it and install the bootloader again (you can even install it to mbr and use the simple repair option instead of cli). By clearing the first 446 bits you have wiped the information on which disk is the active one so we need to fix this.

HAHAH I am now writing this via my openSUSE distro!!! to make a long long story short…I did not have my M$ hard drive grounded good enough to the case. I had took it out to change from cable select to slave etc…and it did not get screwed in tight enough…WIERD…

Thank you all for help.

Dusty