FN buttom problem

Hi, I use OpenSuse 13.1 my machine is Acer Aspire 5750G, I have problem - my FN buttons don`t work for brightness, but for sound is working perfect and show me to desktop level of sound when I use it, but for brightness is now working, and Nums or capslock work but not show me :frowning:

Add this line to /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="acpi_backlight=vendor"

After saving file changes, run as “su -” grub2-mkconfig -o /boot/grub2/grub.cfg

Restart your laptop and check the brightness keys.

You can also try:

xbacklight +10% and xbacklight -10%

Follow Up

If that doesn’t work try replacing the previous entry with the following:

acpi_osi=Linux

Alternate Option

Another option is to add the entries to /etc/default/grub in between the quotes:

GRUB_CMDLINE_LINUX=""

Instead of:

GRUB_CMDLINE_LINUX_DEFAULT=""

but I have double boot system ( Windows 7 and openSUSE)
is this a problem ? And after this will be lost my Windows 7 boot ???

I add this:

GRUB_CMDLINE_LINUX_DEFAULT="acpi_backlight=vendor"

but no effect

Try adding adding this line:

acpi_osi=Linux

So it looks like:

GRUB_CMDLINE_LINUX_DEFAULT="acpi_backlight=vendor acpi_osi=Linux"

Always remember whenever you alter a file with grub2. You must run the following command:

grub2-mkconfig -o /boot/grub2/grub.cfg

Restart your laptop. Then install the “xbacklight” package using the command:

sudo zypper in xbacklight

xbacklight allows you to control your backlight. Start with the commands:

This command should increase the brightness:

xbacklight +10%

This should decrease the brightness:

xbacklight -10%

BTW Are you running KDE4 or GNOME?

Good Luck!

Thank you very much my friend, its work now :), but now when PC start show me Windows 7 and GNU/Linux ( before was OpenSUSE now name is GNU/Linux) and when i chose GNU/Linux start show many lines of codes, and then start the OpenSuse. And when I use xbacklight +10% or -10% on desctop show me level of brightness, but when use FN buttom dont show me. (This is not a big problem :slight_smile: )
And BTW I use KDE4.

Thank you very much my friend, it`s work now :), but now when PC start show me Windows 7 and GNU/Linux ( before was OpenSUSE now name is GNU/Linux)
and when i chose GNU/Linux start show many lines of codes, and then start the OpenSUSE.

  • Start up Yast2 Boot Loader -->Click on Boot_loader Options
    button - Change the name In the Distributor
    field - Click on the OK buttons to confirm the changes

Note: The Yast2 Boot Loader will run grub2-mkconfig automatically after clicking on the OK buttons. So it’s not necessary to run the command again in “konsole” or “xterm”.

And when I use xbacklight +10% or -10% on desktop show me level of brightness, but when use FN button don`t show me. (This is not a big problem :slight_smile: )
And BTW I use KDE4.

  1. Navigate to Configure Desktop–>System Settings–>Shortcuts and Gestures–>Custom Shortcuts
  2. Select Edit–>New–>Global Shortcut–>Command/URL
  3. Assign a name i.e. Increase brightness
  4. Select the Comment tab
    and type in Increase Brightness 1. Select the Trigger tab **
    and assign your keyboard shortcut 1. Select the
    Action tab**
    and copy the command from konsole to Command/URL section 1. Click on the Apply button
    to confirm the changes.

That’s it. You may have to restart your laptop. Please work on it.
**

FYI If you have and are using your graphics card with Bumblebee nVidia Optimus support:**

Navigate to and edit /etc/X11/xorg.conf.d/50-device.conf and add the following:

Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection

Save your changes and shutdown and restart your laptop.

After I make this

**FYI If you have and are using your graphics card with Bumblebee nVidia Optimus support:**

Navigate to and edit /etc/X11/xorg.conf.d/50-device.conf and add the following:

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
Option “RegistryDwords” “EnableBrightnessControl=1”
EndSection


Save your changes and shutdown and restart your laptop.

my OpenSUSE now start in “terminal mode” have not desctop :frowning: have not KDE how can reapir this ?

My OpenSUSE now starts in “terminal mode” have no desktop :frowning: I have no KDE4. How can I repair this ?

Looks like there is a syntax error somewhere or perhaps it’s competing with the bumblebee.conf file. Most likely it’s the latter.**

Problem when getting stuck in console**

When you boot, boot to runlevel 3 or init 3 first, and then runlevel 5, and before completing runlevel 5 login screen,
go back to a console screen as root or “su -” (without the quotes) and issue the commands:

rcxdm stop

then type:

rcxdm start

Complete your login screen and you should be able to use the desktop.

If it switches back to “console or terminal mode” again, try editing the file again **/etc/X11/xorg.d/50-device.conf **and change it to the following:

#Section "Device"
#   Identifier "Device[0]"
#   Driver "nvidia"
#   VendorName "NVIDIA Corporation"
#   Option "RegistryDwords" "EnableBrightnessControl=1"
#EndSection

The pound sign comments out the entry.

How To Edit the File with The VIM Editor

Restart your laptop. From the Grub2 menu and select the **Advanced **entry. Press the key once to view and select Recovery Mode with the arrow key.
Press the “e” key (for edit). Use the up and the left arrow key to navigate to the line that includes “nomodeset x11failsafe”.

At the end of the line (after the last word) add a space with the bar and type press the number **" 3 " **key once and then press the " F10 " key (without the quotes).
This will boot to runlevel 3 or “init3” in console mode. Now, you can use the “vim editor” with command **“vim” **(without the quotes) to uncomment.

Below is an example of what you may see while in edit mode in Grub2:

menuentry 'openSUSE 13.1, with Linux 3.11.6-4-desktop (recovery mode)' --class 'opensuse-13-1' --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.11.6-4-desktop-recovery-4da26394-58bd-454b-b8f2-f12da3dfe983' {
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_msdos
        insmod ext2
        set root='hd0,msdos1'
        if  x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1 --hint='hd0,msdos1'  4da26394-58bd-454b-b8f2-f12da3dfe983
        else
          search --no-floppy --fs-uuid --set=root 4da26394-58bd-454b-b8f2-f12da3dfe983
        fi
        echo    'Loading Linux 3.11.6-4-desktop ...'
        linux    /boot/vmlinuz-3.11.6-4-desktop root=UUID=4da26394-58bd-454b-b8f2-f12da3dfe983  showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 
        nomodeset  x11failsafe **3**
        echo    'Loading initial ramdisk ...'
        initrd    /boot/initrd-3.11.6-4-desktop

While in the vim editor use the arrow key to navigate. Press the **" i " **key for inserting the # key. Once you’ve finished., press the key once. It will add a colon " : ".
Then type **“wq” **and will appear as :wq. Which stands for write and quit.

Finally, type:

shutdown -r now

This will reboot your system and the problem will be resolved.

Check out this translation from a German website about editing a **" dedicated " **Nvidia card setting for the /etc/X11/xorg.conf.d/*.conf files for openSUSE 12.1.
This when you install the Nvidia driver instead of the Bumblebee driver setup.

http://translate.googleusercontent.com/translate_c?depth=1&hl=en&rurl=translate.google.com&tl=en&u=http://www.unixboard.de/vb3/showthread.php%3F48739-OpenSuse-12-1-Xorg-Konfiguration-xorg-conf&usg=ALkJrhheVFJ1HBv_ZPwgVnYbsYdOXT61jw

What do you mean by “Nums or capslock work but not show me”?

I found an alternate setting for Grub Default for you to try:

**acpi_osi=Linux acpi_backlight**

Thanks for this, with 13.1 on my XPS 13 I used the xbacklight global shortcut solution, works beautifully.

now all is ok thank you very much my friend, after I make this changes my laptop is perfectly and very beatiful :slight_smile:

Thank you :slight_smile:

You are welcome. It’s good to hear that you are up and running.

Please. When you get a chance, navigate to our Hardware section and add your laptop to the section and add your comments.
Just use the previous comments as your reference on formatting.

Used the “preview” button to see your entry. It’s not difficult to create an entry for your brand of laptop.

On 2014-01-13 04:46, Romanator wrote:

> HOW TO EDIT THE FILE WITH THE VIM EDITOR

Suggestion: joe is available by default on openSUSE, it has a menu and
it is easier to grasp. And it has several flavours, so you have several
choices of interfaces:

joe, jstar, jmacs, rjoe, jpico…


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)