Fluxbox help openSUSE 11.0

Hello openSUSE family,
I am trying to install fluxbox 1.0.0, currently running openSUSE 11.0. I have read the documentation, wiki, and googled my problem but to no avail. I am pretty sure fluxbox is installed, (from YaST), but it’s impossible to run. Perhaps I am to new to Linux and need to get more familiar with it but here’s my problem. According to FB’s documentation, I need to do this…

There are two generally different ways to start X11 (and thus Fluxbox). The traditional way is using the command startx. The other way is using a graphical login manager (also called “display manager”). The most common display manager is xdm which is part of the XFree86 distribution. The display manager provided by Gnome is called gdm, the one from KDE is kdm.

If X11 is started the former way (via startx), the file that is important is called .xinitrc and resides in your home directory. In the case of starting via a display manager, the file is .xsession which resides at the same location.

The next step is to find the executable for Fluxbox. For most people, this is /usr/local/bin/fluxbox. Now you need to edit (or create) the file I just mentioned. Just put the following line at the bottom of the file:

exec /usr/local/bin/fluxbox

Change the /usr/local/bin/fluxbox to where ever your Fluxbox executable is, the above is the default location when compiling from source. Once that is done, save it and close whatever editor you used to edit it. Now you need to run the following command if you use startx:

$ chmod 700 .xinitrc

In the case of .xsession that is not needed. In both cases, you should create the directory in which Fluxbox stores its configuration:

$ mkdir .fluxbox

Okay, I want to run fluxbox from the gdm, but there is no file called .xsession in my home directory, only .xsession-errors. I am unsure how to make this file if need be. Also the directory usr/local/bin does not contain a fluxbox folder, which makes me think it isn’t installed. I have tried installing a few times but haave gotten nowhere, anyone know what I am doing wrong or will at least point me in the right direction?

If Yast says it’s installed, you should be ok. Log out of your current session by clicking on the launch bar, then on “logout.” When you go to log in again, select Fluxbox in the “session type” menu. It should start up fluxbox.

You might also be interested in “fluxbox-generate_menu,” which will automatically generate a fluxbox menu containing all your programs for you.

Thanks, turns out I didn’t install it correctly or it didn’t compile completely. Problem solved.