Fluendo Codecs and OpenSuse 11.2 (playing wma files)

I have a question regarding the ability (or lack thereof) to play certain .wma files in openSUSE 11.2

I have already downloaded and installed the “codec-kde.ymp” package from the community website, which provided me with 99% of the media functionality that I wanted - except for the ability to play certain audio files with a .wma extension (I am assuming this has to do with digital copyright issues etc).

My question is this:

Do I need to purchase a codec pack from Fluendo in order to get full media functionality for openSUSE 11.2?

I don’t mind spending the extra money if it means that I can play any and every file natively on my system.:wink:

I suppose it’s not possible you could give an example or are they all local to you rather than web based?

They are local to me (music .wma files).

Depending on the program I am using, I am either getting an error message, or the file just doesn’t play.

In VLC, I get this message:

No suitable decoder module:
VLC does not support the audio or video format “wmal”. Unfortunately there is no way for you to fix this.

In Amarok, the file “goes through the motions” of playing on the slider bar, but no sound comes out & the file is instantly finished playing. The same thing happens in KMplayer.

I am able to play .wma files that people have recorded using windows sound recorder - just no commercial music files (the files play fine in windows).

I know you have installed the codecs, but can you have a look at this, carefully please
Multi-media and Restricted Format Installation Guide - openSUSE Forums

Hi
I run the fluendo codecs here (SLED11), do you have a link to a file to
play? I can install on a vm and test if required. On my netbook, I run
11.2 and smplayer which pulls in most of them, else you might want to
look at the gecko-mediaplayer plugins and the gnome-media player from
RedDwarfs repository on OBS.


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
up 3 days 4:29, 2 users, load average: 0.25, 0.29, 0.26
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

I note on my 64-bit openSUSE-11.2 that .wma files play ok.

On the other hand, on all 3 of my 32-bit openSUSE-11.2 PCs, .wma files only give static and do not play.

I don’t use gstreamer, but rather I use the alsa-API (or as applicable use the xine sound engine) in various applications.

_64 and 32 bit both play .wma fine here (For the few that I have of that rubbish)

Just tried in amarok and kaffeine

I note the packman packagers have not been able to reproduce the problem where I can not get .wma to play on 3 different openSUSE-11.2 32-bit PCs. I also note .wma does play on my 64-bit openSUSE-11.2 PC.

Clearly (IMHO) there is something systemic that I have done in the 32-bit PC’s 11.2 install, that has resulted in .wma not functioning. But when I compare the 32-bit to 64-bit, I see no difference. I applied the same method for installing applications on my 64-bit PC as I did on my32-bit PCs, so that is puzzling to me. Why did my systemic approach ONLY break .wma on a 32-bit PC and not on a 64-bit. In all 4 cases both / and /home were complete reformats.

I’m thinking there is a specific application needed to provide .wma that I do not have installed on the 32-bit PCs, but for the life of me I can not figure it out. Needless to say, I have done all the standard codec checks (RedDwarf’s 10 easy steps guide, … all libffmpeg codecs, no videolan codecs, w32codec-all … etc … ).

Microsoft, in its infinite wisdom, decided to use the same name (WMA) for different formats.

“wmal” is Windows Media Audio Lossless. It’s format “0x163”, and you can see at Codec Status Table - MPlayer - The Movie Player that it isn’t supported by libavcodec. You need the Windows codec (w32codec-all Packman package) to play it… and it’s only available for x86 (32 bits).

I’m bad. I’m going by memory, and not being at a linux pc, my memory is fuzzy now.

I’m now thinking its only mplayer on my 32-bit PC that does not play .wma. … Mplayer on my 64-bit PC does play .wma.

I’m thinking now that xine on my 32-bit PCs does play .wma.

I need to check again when I get home.

So basically, for these “.wmal” files (I have about ten of them) to work, I need to be using the 32-bit system?

All other .wma files work just fine on my x64 system with the KDE codecs installed.

If you have a link to a sample file (I couldn’t find any googling) I’d be happy to try it on my system which is 32-bit.

An easier fix though might be to use a Windows box to just convert the files into FLAC:
Convert WMA Lossless to FLAC - Head-Fi: Covering Headphones, Earphones and Portable Audio

Foobar will convert WMA-L to FLAC, and preserve metadata where feasible (no current support in FLAC for embedded album art tags, yet).

You can use, even on a 64-bit system

  • 32-bit mplayer
  • 32-bit vlc (but I’m not sure if Packman enables support for Windows codecs in VLC)
  • 32-bit gstreamer with a 32-bit gstreamer-based app (but you need the pitfdll gstreamer plugin, not available in Packman I think)
  • 32-bit libxine with a 32-bit xine-based app

Thanks for that link. I note MS-PowerPoint Viewer when running under wine does not play audio for some presentations, and I’ve been wondering if it was because the power point presentations were using a .wma variant for their audio. This link has given me some ideas as to what I could do with wine.

Unfortunately, the file is one that is copyright protected (I can’t share it online)…

I like your idea about converting the file. I’ll give that a try and report back this afternoon with the results :slight_smile:

I installed the newest version of Audio Konverter but could not convert the .wma file to any other format.

When I right click on the file and select “Convert to xxx” (I tried this for mp3, mp4, ogg, and FLAC), the program window pops up for one second and then the program shuts down.

It looks to me like the .wma lossless format might be a lost cause until new codecs are released… :frowning:

OK, I checked.

The .wma file I have been trying to play, is a “wmav2” or “Windows Movie Maker 2.1.4026”.

On my 32-bit PCs I can play it with vlc and xine, but NOT with mplayer. On my 64-bit PC I can play it with vlc, xine AND mplayer.

I can not figure out why my 64-bit PC mplayer can play it and my 32-bit PC mplayer can not. I am suspicious of the 32-bit mplayer package, but the Packman packagers think their 32-bit mplayer is packaged ok.

tk83 said: “An easier fix though might be to use a Windows box to just convert the files into FLAC”

Linux support mostly depends of ffmpeg/libavcodec (for everything: xine, vlc, mplayer, gstreamer, Audio Konverter… everything), and I already show it doesn’t supports WMA Lossless.

Since you said you just have a few of them the idea is to use a Windows box (or virtual machine, or wine) once to convert them to FLAC (a lot more used than WMA for lossless audio compression) and never again touch a WMA Lossless file.

Since it’s little used (little motivation) and the format needs to be reverse engineered (hard work) don’t expect support soon.

Hi
Fluendo supports WMA lossless…

  • Windows Media Audio Decoder (Windows Media 7, 8, 9, 10, Pro,
    Lossless and Speech)
  • Windows Media Video Decoder (Windows Media 7, 8, 9 and VC1)
  • Windows Media ASF Demuxer
  • Windows Media MMS Networking
  • MPEG2 Video Decoder
  • MPEG4 Part 2 Video Decoder
  • DivX 3.11 Alpha :wink: Video Decoder
  • H.264/AVC Video Decoder
  • MPEG2 Program Stream and Transport Stream demuxer
  • MPEG4 ISO Demuxer
  • MP3 Audio Decoder
  • AAC Audio Decoder
  • LPCM Audio Decoder

If it’s drm’ed though they won’t.


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.39-0.3-default
up 0:12, 2 users, load average: 0.15, 0.39, 0.26
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

In my checking out of openSUSE 11.2 in virtualbox and vmware one of the things I wanted to also experiment with were the fluendo codecs, as on previous openSUSE releases I couldn’t get satisfactory results with them.

Of course drm protected files will not work, don’t have any myself, so I can’t offer a suggestion other than to play them using Windows or wine if possible.

With some changing of the default packaging of the KDE in openSUSE the fluendo stuff, using their latest full codec rpm package, now works very nicely on openSUSE. :slight_smile:

What is needed is to install pulseaudio (or gnome, which will bring that in) as well as using the totem-mozilla plugin, installing and using (set in the kde multimedia applet in settings) the phonon-gstreamer backend.

I did not activate the packman repository and did not install gstreamer0.10-plugins bad or ugly but did make sure the base and good packages were installed along with the previously described packages, then installed the fluendo rpm using Yast.

Note that without pulseaudio totem will play the windows media content but without sound, with the volume control in totem greyed out. I think this version of totem’s audio is only set to use the pulseaudio volume and will not recognize that a mixer exists if only alsa stuff is installed.

I was happy to see that quicktime movie trailers on the apple website also were played perfectly with the totem-mozilla.

Note that by not using the packman ffmpeg/libmad/lame, etc stuff, as well as the mplayer, mencoder, transcode types of things we’ll be using a system (with the fluendo codecs) that will PLAY the microsoft (and some other non-free) codecs but will not be able to encode mp3 or other non-free stuff.

I have not tested whether the fluendo playback codecs mix well with the packman packages which enable encoding and probably a lot more codec playback. I also think that the gstreamer ugly and bad packages might mix up the system and disable some of that nice fluendo codec playback.

But for someone, in the U.S. let’s say, who only wants to play back most file formats and stay within the realm of patent law, both the fluendo codecs and their recent dvd player (removing the need to install libdvdcss and paying for their patent complying dvd player) is a nice addition. They now work a lot better than they did in the past, where I found that even on systems where their codecs worked they both left out too many codecs and the ones that played were at times buggy.

So one could install realplayer, adobe flash, the fluendo complete and their dvd player along with sun java and adobe reader, and be using a patent compliant system that would still serve their needs of listening, watching most content without booting into Windows.

No mplayer, vlc of course, or you would be wasting your time and money. Use those and you might as well be using the still more complete ffmpeg/w32 codecs packman xine and gstreamer bad, ugly methods still used by most users around the world who don’t worry about patent issues.

Since I only have 32 bit hardware I have no idea how all this works using 64 bit software.