Flock and Pulse

I downloaded Flock 2.0b and Pulse, extracted the files to a directory. Now how do I run them? When I click on the file for flock (same one that runs in Ubuntu), I’m asked what I want to open the file with. If I change the permissions, making it executable and then click on it nothing happens.

What am I doing wrong or not doing?

> What am I doing wrong or not doing?

i don’t know what you did wrong…what i did here was

  • at flock.com, LEFT side of page, near the orange button saying
    “download”, click on the Linux Penguin (TUX)

  • download flock-1.2.2.en-US.linux-i686.tar.gz

  • unpacked that to /home/temp

  • double clicked on the file named flock (5.1 kb, dated 2008-06-09)
    [NOTE: i didn’t change any file permissions…though, that file didn’t
    (and doesn’t) show up as executable in my konqueror]

  • soon a dialog popped up asking if i wanted to import data from Firefox
    (i said no!!)

  • then another dialog popped up asking if i wanted Flock to be my
    default browser (again i said NO!)

  • then Flock popped up on http://www.flock.com/getting-started/1.2.2/en-US/

NOW, what i don’t know is how one is supposed to know how to start it up
again…as the installer didn’t plop a clickable icon on my
desktop…nor did it add an icon to my KDE/SUSE menu…

so, i go to read the unpacked in directory’s README…there is NONE!!

but, if you are running KDE (you didn’t say) you can build your own
clickable icon:

  • right click on desktop, select “Create new” then “Link to
    Applications”, in the popped up dialog, select:

  • General tab: type Flock in the line next to the icon KDE gear icon

  • Application tab: type description/comment as you wish and in the
    “Command” browse to the directory where you unpacked the *.gz file to
    and select flock-bin, then hit “ok”…now when you click on Flock
    desktop icon NOTHING happens…

browse again and select gm, then ok, then try the icon–NOTHING happens

what a bunch of JUNK…nothing in that directory SEEMS to launch Flock…

so, now i wanna get rid of it, completely…but the missing README does
NOT tell me how to completely remove all code it installed, nor undo
anything it did…

CAUTION, this is just like the junk that comes out of Redmond…

what it DID do was add /home/me/.flock for its settings…

so, now i’m a little afraid of it and what it MIGHT do, so i’m gonna delete:

  • the downloaded *.gz

  • all the stuff that unpacked out of it

  • the /home/me/.flock directory

  • the desktop icon i made and named Flock

whew!! i did all of that and Firefox still works!!

my best advice is to STEER CLEAR of Flock or contact the good folks at
Flock and ask’em what the Flock is going on…that is:

  • how come the menu wasn’t updated (that is, where is the button to
    click to start Flock again)

  • where is the uninstall routine

  • why don’t they package in an *.rpm file??? (then you could install and
    UNinstall in YaST)

ymmv, DenverD

I’m using KDE and now I have the same problem with Eclipse. I downloaded and extracted the new version, click on “eclipse” (66.3kb) and I get the “Open with…” box. This is getting annoying.

read this thread and decided to give it a shot myself…

i d/l-ed the file “flock-12.2.en-US.linux-i686.tar.gz” from here:

Flock Browser - The Social Web Browser

placed it in a folder called “flock” that i had created in my home directory. right clicked on it and extracted it into the same directory. this created another folder in the directory called “flock-12.2.en-US.linux-i686”. inside that folder was yet another folder called just “flock”. finally, inside that folder is the executable “flock”. so in my case the path to the file is /home/<user name>/flock/flock-1.2.2.en-US.linux-i686/flock/flock

next i right clicked on the start button (or whatever you call it) and chose menu editor. from the menu editor i clicked on “internet” in the list on the left, and chose “new item” from the toolbar. gave the new item the name “flock”. in the command line i entered the very long path that i showed previously:

/home/<user name>/flock/flock-1.2.2.en-US.linux-i686/flock/flock

then click save from the toolbar and close the editor. that makes an entry for flock in the main menu under > applications > internet

you can right click on that and add it to the desktop. once created it will still not have an icon…so right click the unknown icon on the desktop and choose “icon settings”. then click the unknown icon in that box > other icons > browse and lead it to that same long path again (minus the last “flock” in the path), where you will find a folder called icons. click on one of them and you be all set to.

there should now be a flock icon on your desktop which you can click on to open.

hope that helps.

Test Pilot Flock 2.0 Beta(one) | Flock

Flock 2.0 beta based on Firefox 3.0 is bursting with fruit flavor!

Sadly, an RPM search didn’t pop up any good openSUSE RPM’s for a proper installable RPM.