flickering Screen on Start up

Hello everyone,

I’m running openSUSE 11 (Gnome) with ATI fglrx closed source (Version 8.5.22) installed. Whenever I either switch on or reboot my machine, the screen starts flickering for a minute, then after I log in, it continues to flicker for another minute or two. It’s really annoying and I don’t know what cause it. I still can play video files and DVD without any problem. The flickering only occurs when I start the operating system. I’m assuming the problem could be related to either Xorg or fglrx driver. This problem started after I installed and configured the fglrx from the ATI repository! Please help me to rectify this problem. Thanks


# /.../
# SaX generated X11 config file
# Created on: 2009-01-05T08:20:25+0300.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "ServerLayout"
	Identifier     "Layout[all]"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
	InputDevice    "Keyboard[0]" "CoreKeyboard"
	InputDevice    "Mouse[1]" "CorePointer"
	InputDevice    "Mouse[3]" "SendCoreEvents"
	Option	    "Clone" "off"
	Option	    "Xinerama" "off"
EndSection

Section "Files"
	InputDevices   "/dev/gpmdata"
	InputDevices   "/dev/input/mice"
	FontPath     "/usr/share/fonts/misc:unscaled"
	FontPath     "/usr/share/fonts/local"
	FontPath     "/usr/share/fonts/75dpi:unscaled"
	FontPath     "/usr/share/fonts/100dpi:unscaled"
	FontPath     "/usr/share/fonts/Type1"
	FontPath     "/usr/share/fonts/URW"
	FontPath     "/usr/share/fonts/Speedo"
	FontPath     "/usr/share/fonts/PEX"
	FontPath     "/usr/share/fonts/cyrillic"
	FontPath     "/usr/share/fonts/latin2/misc:unscaled"
	FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
	FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
	FontPath     "/usr/share/fonts/latin2/Type1"
	FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
	FontPath     "/usr/share/fonts/baekmuk:unscaled"
	FontPath     "/usr/share/fonts/japanese:unscaled"
	FontPath     "/usr/share/fonts/kwintv"
	FontPath     "/usr/share/fonts/truetype"
	FontPath     "/usr/share/fonts/uni:unscaled"
	FontPath     "/usr/share/fonts/CID"
	FontPath     "/usr/share/fonts/ucs/misc:unscaled"
	FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
	FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
	FontPath     "/usr/share/fonts/hellas/misc:unscaled"
	FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
	FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
	FontPath     "/usr/share/fonts/hellas/Type1"
	FontPath     "/usr/share/fonts/misc/sgi:unscaled"
	FontPath     "/usr/share/fonts/xtest"
	FontPath     "/opt/kde3/share/fonts"
EndSection

Section "Module"
	Load  "dbe"
	Load  "type1"
	Load  "freetype"
	Load  "extmod"
	Load  "glx"
EndSection

Section "ServerFlags"
	Option	    "AllowMouseOpenFail" "on"
	Option	    "ZapWarning" "on"
EndSection

Section "InputDevice"
	Identifier  "Keyboard[0]"
	Driver      "kbd"
	Option	    "Protocol" "Standard"
	Option	    "XkbLayout" "us"
	Option	    "XkbModel" "microsoftpro"
	Option	    "XkbRules" "xfree86"
EndSection

Section "InputDevice"
	Identifier  "Mouse[1]"
	Driver      "synaptics"
	Option	    "Buttons" "5"
	Option	    "Device" "/dev/input/mice"
	Option	    "Emulate3Buttons" "on"
	Option	    "HorizScrollDelta" "0"
	Option	    "InputFashion" "Mouse"
	Option	    "Name" "Synaptics;Touchpad"
	Option	    "Protocol" "explorerps/2"
	Option	    "SHMConfig" "on"
	Option	    "Vendor" "Sysp"
	Option	    "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
	Identifier  "Mouse[3]"
	Driver      "mouse"
	Option	    "Buttons" "5"
	Option	    "Device" "/dev/input/mice"
	Option	    "Name" "ImPS/2 Generic Wheel Mouse"
	Option	    "Protocol" "explorerps/2"
	Option	    "Vendor" "Sysp"
	Option	    "ZAxisMapping" "4 5"
EndSection

Section "Modes"
	Identifier     "Modes[0]"
	ModeLine     "1280x800" 83.5 1280 1344 1480 1680 800 801 804 828
	ModeLine     "1280x800" 69.8 1280 1328 1360 1440 800 803 809 823 +hsync -vsync
EndSection

Section "Monitor"
	Identifier   "Monitor[0]"
	VendorName   "AUO"
	ModelName    "AUO LCD MONITOR"
	UseModes     "Modes[0]"
	DisplaySize  331	207
	HorizSync    30.0 - 62.0
	VertRefresh  43.0 - 60.0
	Option	    "DPMS"
	Option	    "PreferredMode" "1280x800"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Device"

  #BusID        "1:5:0"
	Identifier  "Device[0]"
	Driver      "radeon"
	VendorName  "ATI"
	BoardName   "Radeon XPRESS 200M 5A62 (PCIE)"
	Option	    "GARTSize" "32"
	Option	    "CRT2HSync" "31-48"
	Option	    "SaXDualMode" "Clone"
	Option	    "SaXDualMonitorModel" "1024X768@60HZ"
	Option	    "SaXDualMonitorVendor" "--> VESA"
	Option	    "SaXDualOrientation" "LeftOf"
	Option	    "SaXDualResolution" "1024x768"
	Option	    "SaXDualVSync" "50-60"
	Option	    "CRT2Position" "Clone"
	Option	    "CRT2VRefresh" "50-60"
	Option	    "IgnoreEDID" "yes"
	Option	    "MergedFB" "yes"
	Option	    "MetaModes" "1280x800,1024x768;1024x768,1024x768"
	Option	    "SaXDualHSync" "31-48"
	Option	    "MonitorLayout" "AUTOCRT,AUTO"
	Option	    "SaXDualHead" ""
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	Option	    "EnableMonitor" "crt1,lvds,tv,tmds1,crt2,tmds2,cv,tmds2i"
	BusID       "PCI:1:5:0"
EndSection

Section "Screen"
	Identifier "Screen[0]"
	Device     "Device[0]"
	Monitor    "Monitor[0]"
	DefaultDepth     24
	SubSection "Display"
		Depth     15
		Modes    "1280x800"
	EndSubSection
	SubSection "Display"
		Depth     16
		Modes    "1280x800"
	EndSubSection
	SubSection "Display"
		Depth     24
		Modes    "1280x800"
	EndSubSection
	SubSection "Display"
		Depth     8
		Modes    "1280x800"
	EndSubSection
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "DRI"
	Group        "video"
	Mode         0660
EndSection

I have this same problem also with Opensuse 11.1 (KDE) and ATI fglrx. The screen flickers for about 30 seconds after logging in. It is annoying.

I have the same problem. Even after soft reinstalling SuSe (I kept some directories in /home partition) it keeps doing this.
I got this flickering issue even when starting wine. I got this flickering when I was starting native quake4 under “non-native” resolition, but when I fixed it it was ok.

My specs are:

OS: OpennSuse 11.1 64bit
Xorg version: xorg 7.4-8.19.1
Kernel: 2.6.27.23
Graphics Drivers: ATI fglrx 8.582_2.6.27.19
Graphic card: ATI HD4870

I got over 10Kfps in glxgears and over 3Kfps in fgl_glxgears

It seems that none has an answer :confused:

This might help someone to localize our problem https://www.youtube.com/watch?v=wblls1Vocxg)

Additional notes
Resolution: 1680 x 1050
GRUB param = vga=0x345 (which is not 1680 x 1050 but I dunno the correct vga value, this is default)

The same flickering also appears when starting app through wine.

Seems to be a problem all around Linux and is related to the ATI drivers. As I do not have a ATI card I cannot try any of these suggestions but there is a huge thread in the Ubuntu forums and one of the posts suggests disabling Compiz. I do not know if any of you run compiz but if so have a look in this post and try the suggestion.

Flickering graphics with ATI in Ubuntu 8.04 Post 27

Hope it helps.

Hi, I have not read the thread (but I surely will give it a shot), but I got the compiz disabled. Thank you for the effort anyway, at least someone care:)

It definatly has something to do with the drivers so update them to the most recent ones. Judging by your information you have version 8.5 of the drivers from the repo.

The ATI website has newer ones so use those. They have version 9.8 This might fix the issue straight away.

Found some other people saying they fixed it by doing the following. It’s worth a try if the driver update doesn’t work.

Edit your /etc/X11/xorg.conf (make a backup first please) and look for the following in the Device section that discibes the fglrx:

Option "TexturedVideo"

If it’s not there put it there. If it is make sure it is set to off. So the finished line should look like this:

Option "TexturedVideo" "off"

save the file and restart X11 by pressing ctrl-alt-backspace twice.
Log back in and see if it is fixed. If this does not work just restore you backup or remove/change the above line to undo what you’ve done.

Hope it helps.

Ok, I will try updating… hope it wont mess it even more :slight_smile:

Well… the fglrx version in the 9.8 catalyst paccage is 8.64… I gave it a shot, it was still flickering on startup + I was unable to run glxgears (and any other accelerated app) with this error

X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 143 (GLX)
Minor opcode of failed request: 19 (X_GLXQueryServerString)
Serial number of failed request: 12
Current serial number in output stream: 12

So I put back the old driver

Seems again it’s a error other people also have -> OpenGL doesn’t work
Here someone tried the same fix and it worked for them too -> ATI repo ready for 11.1

Give that a try if you haven’t given up already :stuck_out_tongue: :wink:

I am really glad I have a Nvidia card which has no problems with drivers rotfl!

Though an NVIDIA user myself, I must correct this. Lately I’ve helped out dozens of people, at home and here. that bought laptops with recent NVIDIA GPU’s ( 10xM series). Officially these are not supported, if stable driver installs. it crashes on X startup. The latest beta drivers do support these cards, and they install fine on 11.1 and Milestones. And still nothing about this on the NVIDIA site. Cards all give ‘Not supported’. Driver from repos will not work.

The key word here is recent. Found it’s very dangerous to have recent hard ware when it comes to Linux support. But a Radeon HD 4870 is not recent and should be supported by now. It was first lauched in june - july 2008. Just saying Nvidia’s usually quicker with Linux support. My 2 year old Nvidia 8800GT is fully and flawlessly supported by Nvidia. I first used it for Linux in march 2008 and had no problems with it from day 1.

Anyway, this is about getting a ATI card working that is causing problems. Not a ATI vs Nvidia debate. :slight_smile:

Hello Dexter,
I tried what they proposed on the link you provided me with with no result :slight_smile: So I’m back to 8.5

The flickering on the startup is not bothering me the most (because it’s really short), it’s the flickering with wine and some native 3d linux apps (i.e. HoN) (which is really long and lags my computer). But I really think those problems are connected, because the flickering is exactly the same (apart from length).

Here is my xorg.conf

# /.../
# SaX generated X11 config file
# Created on: 2009-07-17T13:32:11+0200.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [SaX2] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/Speedo"
  FontPath     "/usr/share/fonts/PEX"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/share/fonts/baekmuk:unscaled"
  FontPath     "/usr/share/fonts/japanese:unscaled"
  FontPath     "/usr/share/fonts/kwintv"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/usr/share/fonts/CID"
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
  FontPath     "/usr/share/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/input/mice"
EndSection

Section "Module"
  Load         "dbe"
  Load         "freetype"
  Load         "extmod"
  Load         "glx"
  Load         "dri"
EndSection

Section "ServerFlags"
  Option       "AIGLX" "on"
  Option       "AllowMouseOpenFail" "on"
  Option       "IgnoreABI" "on"
  Option       "ZapWarning" "on"
EndSection

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "cz,us"
  Option       "XkbModel" "microsoftpro"
  Option       "XkbOptions" "grp:shift_toggle"
  Option       "XkbRules" "xfree86"
EndSection

Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "10"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "Razer DeathAdder"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
  Option       "CalcAlgorithm" "XServerPool"
  DisplaySize  474 296
  HorizSync    30-83
  Identifier   "Monitor[0]"
  ModelName    "LG ELECTRONICS L226W"
  Option       "DPMS"
  Option       "PreferredMode" "1680x1050"
  VendorName   "GSM"
  VertRefresh  43-75
  UseModes     "Modes[0]"
EndSection


Section "Modes"
  Identifier   "Modes[0]"
EndSection


Section "Device"
  BoardName    "RV770 (RV770 9440)"
  Driver       "fglrx"
  Identifier   "Device[0]"
  Option       "Capabilities" "0x00000000"
  Option       "VideoOverlay" "on"
  Option       "OpenGLOverlay" "off"
  Option       "FSAAEnable" "off"
  Option       "FSAAScale" "0"
  Option       "XAANoOffscreenPixmaps" "true"
  VendorName   "ATI"
EndSection


Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      15
    Modes      "1680x1050" "1280x1024" "1280x960" "1024x768" "800x600" "768x576" 
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1680x1050" "1280x1024" "1280x960" "1024x768" "800x600" "768x576" 
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1680x1050" "1280x1024" "1280x960" "1024x768" "800x600" "768x576" 
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1680x1050" "1280x1024" "1280x960" "1024x768" "800x600" "768x576" 
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection


Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Screen       "Screen[0]"
EndSection


Section "DRI"
    Group      "video"
    Mode       0660
EndSection


Edit: I also think, that is’s possible the problem being related to kernel, because the 8.5 kernel module is for 2.6.27.19 but I have 2.6.27.29

Maybe but if this was the case it should have been fine when you had 2.6.27.19 installed and from what I can gather it wasn’t. And downgrading your kernel to test this theory is not the way to go.

I am going to bow out of this problem since I cannot test any of the suggested fixes myself. Hopefully someone else will have an answer. It still sounds to me like it is a driver issue and it’s something that is not unique to you. Not that this makes it any less annoying :wink:

Good luck with it and please post the fix if you find one so it may benifit other people with the same problem.

Long long time ago there was no flickering… then suddenly it appeared. Since then I tried several things (like format everything besides some documents on my /home partition, etc.), none of it helped.
But I’m not giving up yet, I still believe I will find the solution… one day, and I surely will share it with this community because I know how annoying the flickering is.

Hi, the problem was caused by xrandr, if you disable it, it works fine.