FlashPlayer no sound 64bit Opensuse 12.1

Hi all,

I have big problem with Opensuse 12.1 64bit default kernel.
If I play any MP3 trough AMAROK, sound is OK.
1st problem:**
When I switch soud source with “Kmix”, then it not work. Only I can switch audio
directly in Yast2 using - “Prefered hardware”

2nd problem:**
But I install flashplayer directly for 64bit Linux (rpm) from adobe.com and trough
Mozilla or default browser I can not hear any sound.

I tried lot of things (reinstall flash player, isntall alsa, plugins, …)

Thak all for help

Try installing the application pulse audio volume control (pavucontrol) and use that to tune your firefox sound. I provided a top level guide on using pavucontrol in a recent blog entry here: Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums

That quote scares me. You could have broken ALL SORTS of things when you attempted that.

I have the same problem, Stock opensuse 12.1 but no sound in my flash based mp3 player.
I removed pulseaudio, but it did not help. I like rather prefer pure Alsa, since it has better support in KDE.
All other programs work fine with audio.

I’ve installed opensuse 12.1 on 3 other machines without any flash audio problem.

I’m missing the /dev/audio, /dev/snd/* and /dev/mixer device

I’ve tried running:
modprobe snd-mixer-oss as root but it do not create those devices

Once one removes pulse audio in openSUSE-12.1 they are into a non-nominal configuration and a not tested configuration and a not supported configuration.

I for one can not help there due to a lack of knowledge/experience in doing such a removal (as I noted - its not official nor supported for such an approach).

A user who has removed pulse and has this working would need help here.

Sorry, wrong thread! LOL