flashplayer crashed

Hello

I am trying to open my flashplayer by command:

install/flashplayer_11_sa.i386> ./flashplayer

but it failed with messages:

(flashplayer:2628): GLib-GObject-WARNING **: instance with invalid (NULL) class pointer

(flashplayer:2628): GLib-GObject-CRITICAL **: g_signal_handlers_disconnect_matched: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

I am just wondering how to fix this problem?

thx a lot

to be clear you are trying to install flash-player from a gziped tar-ball from adobe?
Do not do that get an rpm, you can get an opensuse rpm from packman

if you have packman configured you can install it with

zypper in flash-player

I’ve never used adobe’s install script but I’m thinking maybe you’re missing root privileges.

it still failed:

flashplayer: Symbol `SSL_ImplementedCiphers' has different size in shared object, consider re-linking

(flashplayer:3591): GLib-GObject-WARNING **: instance with invalid (NULL) class pointer

(flashplayer:3591): GLib-GObject-CRITICAL **: g_signal_handlers_disconnect_matched: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed


I’m not quite sure what you did with the tar ball, consider cleaning then reinstalling
https://en.opensuse.org/Adobe_Flash_Player#Cleanup_of_older_versions

Problem solved.

I try to compile gnuash by myself and I noticed that many libraries including Mozillar xunllerun are missing. After install necessary libraries, flash-player goes well.

if you used zypper for install it would have downloaded all the missing dependencies.

After installing flash from packman repo, just install libcurl4-32bit.

This worked for me