Flashing screen when trying to login after hardware upgrade

Have recently upgraded hardware - from an i5 generic to an i5 Dell (both with generic intel onboard video) and have run the Upgrade option off the x64 install dvd but when logging in, get to the actual login screen, but then - sometimes without even logging in, others after logging in - the whole screen starts flashing different colours.
Believe what I need is to do a full ‘reconfig’ on the video config - but how do you get this to happen??

Other than i5 CPU and Intel video on both, it’s unclear what you did. Did you move or clone the HD from the old to the new, then do an upgrade installation? How old was the old i5. Can you provide the old CPU’s model number, and/or the model number of the old motherboard? What models are the new? Software/driver compatibility from one to the next and so on with Intel graphics pretty well stay good due to the work the driver devs put in as new hardware is announced, so by the time we get it, it will usually work automagically.

When the screen is discombobulated, can you Ctrl-Alt-F2 and get a good login prompt?

The place to start is testing boot changes by editing at the Grub menu. The sledgehammer approach is to use the e key when the menu appears, navigate to the end of the line that starts with linux, and append the string nomodeset. That usually gets startup into what amounts to emergency rescue mode. Less drastic action starts the same way, but instead of appending nomodeset, try deleting quiet & splash=silent. This likely won’t help except to show boot messages that might provide clues. A little more likely to help is after removing quiet & splash=silent to append plymouth.enable=0.

However you can manage to get booted into a usable mode what we want to see is which X driver was in use when the screen was blinking. That can be done by examining /var/log/Xorg.0.log.old if currently booted with nomodeset, or if booted into X without using nomodeset, /var/log/Xorg.0.log. The driver in use is known by bunches of lines in sequence that include one of the following after the timestamp: modeset(0), intel(0) or fbdev(0). fbdev is what you’ll most likely get booted using nomodeset. What may solve the problem is getting switched from whichever is in use to the other. If you find it’s intel(0), which I’m guessing it will be, then the simplest way to switch is to remove the package providing it:

zypper rm xf86-video-intel

and reboot. If I’m wrong, and xf86-video-intel is not installed, and modeset was/is already in use, then the problem to solve will likely require us getting more information.

If plymouth.enable=0 solved the problem, the simplest possible fix is probably:

zypper rm plymouth

IMO Plymouth is purely eye candy, but there are claims of valid other uses for it besides avoiding flicker.

If the above results in inadequate resolution, giving us output of

inxi -bGxx

should help us help you. Uploading of lengthy information such as screenshots and Xorg.0.log can be done from a shell prompt using the command susepaste. These two commands may need to be installed first.

That sounds like a bad cable, a poor connection, or even a bent pin the video cable.

Login on the console with your username and password when not logged in on the plasma desktop and do

rm -rf ~/.local/share/kscreen*

then login on the plasma desktop and see if the issue still exists.

Believe I have chased down what the issue is:
recently purchased an AC Wireless USB dongle, labelled AC1200M, which uses a Realtek 88x2 chipset.
Chased down a driver (https://codeload.github.com/MeissnerEffect/rtl8822bu/zip/master) which seemed to work on my running install, at the time.
Then had the issues with my PC (hardware, memory/power supply), and transferred drives (3xhdd - 1xssd boot + 2xhdd data) to another (very underspecced - core2duo+2GB RAM) machine, did an upgrade off the install DVD, which was when I first noticed the screen issue. Received a replacement PC, and again transferred the 3hdds to this, and did an ‘upgrade’ off the Leap15 install DVD. Now, pretty much as soon as I install and activate the USB dongle, the machine locks up, with a flashing screen… Have tried reinstalling the driver, with no change.
If I unplug the dongle, all is generally OK.
Wondered if perhaps the dongle was damaged, but don’t believe so. It does seem to work (detects wifi ssids) at times before it craps out…

Probably need to reinstall the proprietary driver since you did an upgrade

Done that…

So everything is fine until/unless you connect the dongle?

Yep, sometimes there seems to be a bit of a delay (30/60 seconds), but guaranteed to start flashing after a while. Not plugged in, all is fine.

Does the problem occur after attaching the dongle even with its driver not installed?

Sorry, got distracted… :slight_smile:
Uninstalled driver, and thought it was not going to occur, but ended up just taking longer (5+ mins)…