Linux x86_64

SUSE 11.1

many sites keep calling for the latest version of flash to be installed?

There are no updates?

i have flash-player installed but for i586 must have been via update

flash plugin for player 10 10.42.34-release

I am asked in Konqueror and firefox.

Any ideas what flash players should be installed and from what repositories
packman is first with 20 priority.


Where are you having this trouble? I have the same flash. Give us a url.

is the flash player for
i have flash-player installed but for i586 must have been via update when I have a 64 bit installation.

the bbc iplayer
the itv player


Dude those all work flawlessly.
I have both 32bit and 64bit but both are 11.2 systems.

This is what I have:

rpm -qi flash-player
Name        : flash-player                 Relocations: (not relocatable)
Version     :                        Vendor: openSUSE
Release     : 0.1.1                         Build Date: Fri 11 Dec 2009 00:52:04 GMT
Install Date: Mon 21 Dec 2009 16:30:49 GMT      Build Host: build34
Group       : Productivity/Networking/Web/Browsers   Source RPM: flash-player-
Size        : 19917311                         License: NON-OSI-COMPLIANT(royalties)
Signature   : RSA/8, Fri 11 Dec 2009 00:52:19 GMT, Key ID b88b2fd43dbdc284
Packager    : http://bugs.opensuse.org
Summary     : Adobe Flash PlugIn and standalone Player
Description :
This package contains Adobe's Flash Plugin for the supported Web
browsers in addition to a standalone flash player application.

Make sure you have nspluginwrapper on _64 bit

It works for me with the same version of flash, but only the BBC Radio iplayer. If i want to watch BBC TV it tries to tell me that i am outside of the UK.

****, i remember the time i have lived in Aberdeen. It was a great time. Ok, i have to stick now with ARD & ZDF, RTL & Co.


yes I have the 64 bit mspluinwrapper1.2.2-2.1.1 498k

but when i copied your text above

brian@linux-z3dx:~> su
linux-z3dx:/home/brian # rpm -qi flash-player
package flash-player is not installed
linux-z3dx:/home/brian #


su terminal

zypper in flash-player

If problem, post result of

zypper lr -d

many times (here with Firefox and the latest flash) i have seen a
javascript problem reported as a flash player needing to be updated…

as far as i can tell 100% of the times that happened it was because of
a javascript problem…

make SURE you have javascript enabled (and if you use an addon like
NoScript, make SURE you allow javascript for those sites which
‘report’ a need to upgrade your flash)…

btw, if it is a javascript problem, then there is NO way to upgrade
flash to fix it…see?

HOWEVER, if you are certain your javascript is turned on, then follow
this advice closely:

it works! use locate or find to clean out all old libflashplayer.so
files…AND, come back and let us know if it was a simple javascript
off, or what…ok??



Before your posting. I used YAST and ticked the Flashplayer.

It downloaded about 6 meg of Flashplayer.

So sorted both BBC iplayer and ITV player both work fine.

They were working fine last time I tried them.

Thanks for your help


I restarted the computer and the BBCiplyer does not work and ITV only has sound.

I will work through the above - thanks

Hmmm … interesting. The Beeb’s iplayer hasn’t worked on my machines (32bit and 64bit, various SuSE releases up to 11.2 except 11.1) for years. I have a clean install of 11.2 (unfortunately with KDE4) on a 64bit machine with up to date flash-player and nspluginwrapper. Maybe the iplayer shouldn’t work after the recent lockdown by the Beeb, but I just tried the ITV version (never tried it before – nothing on ITV worth watching) and had sound but no picture. Needless to say the iplayer works fine when I boot Vista; but then I rarely do.

But then with nspluginwrapper grabbing 100% CPU (of one of the CPUs anyway) and driving my machine’s fan crazy, maybe I want to avoid any site which uses flash anyway.

iplayer works fine on both 32 and 64 bit in 11.2 for me.
ITV is functional but it’s rubbish quality.

OK, I tried something different: I used Konqueror. But the iplayer still didn’t work. So I used Konqueror and selected to play the programme in a pop-out window. And it worked! So I guess it’s just the embedded player that doesn’t work. I’ll see if the popped-out player works in Opera and SeaMonkey another day.

I haven’t tried the ITV player (does it even have the pop-out window option?) but as you say, ITV is rubbish so I’m not fussed.