hi…im new here, so im sorry if this has been asked before…
i have a new install of OpenSUSE 11.1.
some sites i go to ask me to install flash player. i cant get this done. is there another program that handles flash files?
thanks very much in advance.

How do you mean you can’t.

Open a terminal and type: su
then your root password


zypper in flash-player

what i meant is that i havent figured out how to do it yet.
anyway, i did what you said and followed the instructions, but i still get the no flash player error from youtube.

In a terminal type:

rpm -qi flash-player

post the result:

Also in a terminal do:

zypper lr

post result:

Pardon my interruption,

But doesn’t openSUSE pull in flash during the first online update? From what I remember it always has. The user has a fresh install of openSUSE 11.1 and seeing as du66y doesn’t know how to install software, it might be reasonable to suggest he/she hasn’t run an online update yet.

I guess that wouldn’t account for it not being installed with zypper in flash-player but it could be a viable scenario.

du66y, have you run an online update yet?

My thoughts exactly. You just make a better job of working to a solution Ian.

actually, ijbreakey has it correct. i just ran said update not 10 minutes ago and youtube works great! thanks everybody for the help :slight_smile:

Glad to see you got it working :slight_smile:

Hope the rest of the ride is smooth :wink:



I am having a similar issue with YouTube, running openSUSE 11.1 ppc64.

I have been able to get to the point where some warbled sound plays for each YouTube video, but no visuals…just a black square.

I have tried the command “zypper in flash-player” but receive the “‘flash-player’ not found” message.

Here is the result of “zypper lr”:

#  | Alias                           | Name                          | Enabled | Refresh
1  | 11.1                            | 11.1                          | Yes     | Yes
2  | ATI Repository                  | ATI Repository                | Yes     | Yes
3  | Main Update Repository          | Main Update Repository        | Yes     | Yes
4  | openSUSE 11.1-0                 | openSUSE 11.1-0               | Yes     | No
5  | openSUSE-NonOSS-Add-on_11.1-0   | openSUSE-NonOSS-Add-on 11.1-0 | Yes     | Yes
6  | openSUSE-NonOSS-Add-on_11.1-0_1 | openSUSE-NonOSS-Add-on 11.1-0 | Yes     | Yes
7  | openSUSE_11.1                   | openSUSE_11.1                 | Yes     | Yes
8  | openSUSE_11.1-0                 | openSUSE 11.1-0               | Yes     | Yes
9  | openSUSE_11.1-0_1               | openSUSE 11.1-0               | Yes     | Yes
10 | openSUSE_11.1-0_2               | openSUSE 11.1-0               | Yes     | Yes
11 | repo-debug                      | openSUSE-11.1-Debug           | Yes     | Yes
12 | repo-non-oss                    | openSUSE-11.1-Non-Oss         | Yes     | Yes
13 | repo-oss                        | openSUSE-11.1-Oss             | Yes     | Yes
14 | repo-source                     | openSUSE-11.1-Source          | Yes     | Yes
15 | repo-update                     | openSUSE-11.1-Update          | Yes     | Yes

Any help would be greatly appreciated.

There isn’t a flash for ppc. The binary files don’t work for ppc.

Follow this guide here PowerPC Flash Player - openSUSE

Good Luck,


The instructions on the page that you linked are really vague about what to do after installing qemu, but thanks for the lead!

Researching qemu…