Flash videos not playing

I got a copy of mmcheck and ran it. After I installed the totem items everything is there. Except the one where it says to use mplayer2 in place of mplayer1.

I still can’t see videos. On youtube there is just a black screen where the video should be. At the Adobe test page, it has A plugin is needed to play this content.

I can’t even view .avi files. This one is a total riot if you can see it https://www.youtube.com/watch?v=zzabmVIU6EQ

What next? I’d really like to see videos again.

Check your Plugins in Firefox and see if they match with this.


Thank You,

I don’t have Adobe Reader 9.5. I tried to find it and it’s not in the list at firefox > tools > add-ons > plugins. How to I get it?

Others I DO NOT have
Gnome Shell Integration
iTunes Application Detector
NPAPI Plugin Wrapper 1.4.4

Others I DO have that are not in your list
DivX Browser Plug-in [also has DivX Web Plug-in]
mplayerplug-in is now gecko-mediaplayer1.0.7
Quicktime plugin 7.6.9 [also has 7.6.6 of the same]
Realplayer 9
VLC Web plugin [also has VLC Multimedia Plugin]
Windows Media Player Plug-in [also has 10 of the same]

Make sure you don’t have gnash installed

To get Adobe Reader, you can serach for and load acroread I think it is called, but its not related to this issue. However, the main thing to see is that all pertinent media players are being done by Totem. Disable any that use anything other than as I show above.

Thank You,

You don’t need Adobe Reader.

Mozilla is integrating the https://addons.mozilla.org/en-us/firefox/addon/pdfjs/ extension into Firefox as a feature in a future version.

I can’t recall the last time I used Adobe Reader.

On 2012-12-28 16:16, rafter22 wrote:
> I can’t recall the last time I used Adobe Reader.

That’s because you do not use things like cryptographic signatures, or
fill forms.

Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))

Ok, I’ll worry about Adobe Reader later if it becomes a problem.

I searched and there are no gnash programs that are installed.

I disabled these in firefox. They had something to do with gecko.

DivX Browser Plug-in
mplayerplug-in is now gecko-mediaplayer1.0.7
Quicktime plugin 7.6.9
Realplayer 9
VLC Web plugin
Windows Media Player Plug-in

The totem items are still active. I still can’t see videos, same as before. Got out of firefox and got back in. Still can’t view.

I ran mmcheck again. Everything is still there. The only exceptions are mplayer2-as-mplayer and something about libxine1 not there but the libxine2 items are there.

Have I asked you what type of video system you are using? It could be nVIDIA, AMD or Intel for anything recent. What desktop do you use? It could be Gnome or KDE. I am using the same KDE version that came with openSUSE 12.2. Its my understanding that the very latest version of the GNOME desktop has a version of Totem that does not work properly. I am not sure what using Tumbleweed might do either. In one case a user with a 6000 series nVIDIA card could never get Flash to work properly. Also, I am still using the original mplayer and not mplayer2. I am using a very recent nVIDIA video card (new GTX 660 Ti for Xmas), but I am not loading the nVIDIA proprietary video driver on my main PC and just using the default open source one.

Thank You,

Can we just see:

rpm -qa | grep flash
rpm -qi flash-player
uname -a
cat /etc/SuSE-release
zypper lr -d

Please post each in it’s own code block

My Computer

OS Information
OS:  Linux 3.4.6-2.10-default i686
  System:  openSUSE 12.2 (i586)
  KDE:  4.8.5 (4.8.5) "release 2"

Display Info
Vendor:  Silicon Integrated Systems Corp.
  Model:  SiS630 GUI Accelerator+3D
  2D driver:  sis
  3D driver:  Unknown Gallium (8.0.4)

CPU Information
Processor (CPU):   AMD Athlon(tm) Processor
  Speed:  1,244.48 MHz

When you get everything thing configured properly in software and it still does not work, one must suspect the video hardware as being the problem. I show that “Model: SiS630 GUI Accelerator+3D” is very old and not main stream anymore as nVIDIA, Intel and AMD own the video market these days and I would not use AMD either in my opinion. What options do you have to replace this video chipset, if any?

Thank You,

# rpm -qa | grep flash

# rpm -qi flash-player
Name        : flash-player
Version     :
Release     : 1.14.1
Architecture: i586
Install Date: Sun 23 Dec 2012 06:26:53 PM EST
Group       : Productivity/Networking/Web/Browsers
Size        : 32888812
License     : NON-OSI-COMPLIANT(royalties)
Signature   : RSA/SHA256, Fri 14 Dec 2012 08:24:44 AM EST, Key ID b88b2fd43dbdc284
Source RPM  : flash-player-
Build Date  : Wed 12 Dec 2012 11:45:00 AM EST
Build Host  : build22
Relocations : (not relocatable)
Packager    : http://bugs.opensuse.org
Vendor      : openSUSE
URL         : http://get.adobe.com/flashplayer/
Summary     : Adobe Flash Plugin and Standalone Player
Description :
This package contains Adobe's Flash Plugin for the supported Web
browsers in addition to a standalone flash player application.
Distribution: openSUSE 12.2

# uname -a
Linux linux-jh9f 3.4.6-2.10-default #1 SMP Thu Jul 26 09:36:26 UTC 2012 (641c197) i686 athlon i386 GNU/Linux

# cat /etc/SuSE-release
openSUSE 12.2 (i586)
VERSION = 12.2

# zypper lr -d
#  | Alias                     | Name                               | Enabled | Refresh | Priority | Type   | URI                                                                  | Service
 1 | Packman Repository        | Packman Repository                 | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/12.2/                                   |        
 2 | libdvdcss                 | libdvdcss                          | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/12.2/                                 |        
 3 | libdvdcss repository      | libdvdcss repository               | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/12.2/                                 |        
 4 | mozilla                   | mozilla                            | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_12.2/     |        
 5 | openSUSE-12.2-1.6         | openSUSE-12.2-1.6                  | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-Memorex_DVD+-RAM_525G_v1,/dev/sr0 |        
 6 | packman                   | packman                            | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_12.2/                          |        
 7 | repo-debug                | openSUSE-12.2-Debug                | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/12.2/repo/oss/       |        
 8 | repo-debug-update         | openSUSE-12.2-Update-Debug         | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/12.2/                      |        
 9 | repo-debug-update-non-oss | openSUSE-12.2-Update-Debug-Non-Oss | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/12.2-non-oss/              |        
10 | repo-non-oss              | openSUSE-12.2-Non-Oss              | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/12.2/repo/non-oss/         |        
11 | repo-oss                  | openSUSE-12.2-Oss                  | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/12.2/repo/oss/             |        
12 | repo-source               | openSUSE-12.2-Source               | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/12.2/repo/oss/      |        
13 | repo-update               | openSUSE-12.2-Update               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/12.2/                            |        
14 | repo-update-non-oss       | openSUSE-12.2-Update-Non-Oss       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/12.2-non-oss/                    |        

Can you please run this:

zypper patch

Then try the same again…

Now do this:
(it’s an old image, it’s the principle that matters)

I ran the zypper patch. Had to do it twice. Looks like it updated the whole os. Rebooted. Still can’t view in firefox or chrome. Chrome says no plug-in available to display this content.

However, kaffiene shows .mp4 videos on my local drive with no problem. This doesn’t seem like a card problem. But when I try firefox on the local .mp4 file, it just sits there with the wait icon going in a circle, after I push the go arrow at the bottom. At least that’s more than I got from youtube sites. Chrome has the arrow on the local file, but doesn’t do anything when pushed.

For the packman switch, you mean to turn it off? I’ve already turned it on.

I just had you run patch which may have switched some stuff back
You should see the option to switch is still there, though I don’t think this will make flash work.

Let me think on that again

Please post the following:

ls /usr/lib64/browser-plugins

Here is what I see:

javaplugin.so            libtotem-gmp-plugin.so          npwrapper.solibflashplayer.so        libtotem-mully-plugin.so        packagekit-plugin.so
libtotem-cone-plugin.so  libtotem-narrowspace-plugin.so  skypebuttons.so


Chrome has the arrow on the local file, but doesn’t do anything when pushed.
This is worrying, since it uses a built in flash. Hence I’m inclined to think there is something technically wrong with your machine or install.

I can add that SiS are absolutely useless. I don’t recall them ever working properly. I’ve had folk hand me SiS laptops that they want Linux on, I just say forget it. And give them windows instead.

I don’t have a lib64, just lib. Mine has some others. Should I just delete the gecko files? Use Yast to remove them? Some other way?

# ls /usr/lib/browser-plugins
gecko-mediaplayer-dvx.so  gecko-mediaplayer-wmp.so  libtotem-gmp-plugin.so          packagekit-plugin.so
gecko-mediaplayer-qt.so   javaplugin.so             libtotem-mully-plugin.so        skypebuttons.so
gecko-mediaplayer-rm.so   libflashplayer.so         libtotem-narrowspace-plugin.so
gecko-mediaplayer.so      libtotem-cone-plugin.so   libvlcplugin.so

gecko-mediaplayer isn’t required in Gnome - remove it
You should use the mozilla plugin for totem, ‘totem-browser-plugin’

I guess you are not 64 bit then