Flash videos no audio

I’ve been playing around with the latest RC of 11.4. Overall, it works great, but just have 1 issue. no flash videos have audio. Video works just fine. I’ve tried installing both the flash-player package so that it loads the official 32-bit plugin through ndiswrapper, and tried downloading the Adobe Square 64-bit plugin and installing it. Doesn’t make a difference, either way I have working video but not audio. Audio itself on the laptop works with no issues, I listen to Amarok all the time on it.

Laptop in question is a Dell Latitude E5500. Any ideas?

I’ve also had Debian Wheezy and Kubuntu 10.10 on here, both had no issues.

First, WELCOME to openSUSE Linux and WELCOME to openSUSE forums. We are all volunteers on this forum, and NOT official Novell nor SuSE-GmbH employees. We are just volunteer enthusiasts.

First, some moderator admin stuff that I have to get out of the way. Sorry, … but … I know 11.4 is going to be released in 4 days, but its the GM of 11.4 that will be released, not the RC. You are using one of the two RC versions …

This IS the wrong forum area for such a post on an RC (release candidate) version. That is in essence beta software. If you are not going to use a released version of an application (and I am confident you have good reasons for using a non-released RC version) then PLEASE post in the correct area … ie : the pre-release/beta area: Pre-Release/Beta

… anyway, its difficult to know what the problem might be without more detail. Most of us do NOT have a Dell Latitude E5500 laptop.

Now back to your problem, since you posted IN multimedia area, did you read the stickie ? Welcome to multimedia sub-area where it notes the information that is useful to provide ? I will quote this for you:

please post … providing in your post the following information:


and select the SHARE/UPLOAD option and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL/website-address that gives. Just the URL/website-address. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
Note if for some reason that gives you no website/url/address then run it with the no-upload option:

/usr/sbin/alsa-info.sh --no-upload

and post the file /etc/alsa-info.txt it creates to Pastebin.com and press SUBMIT on that site and again post here the URL/website-address it provides.

… some clarification on running the script “alsa-info.sh” … when you run:


you should get something like this (if it asks for an update, select NO):

followed by this (select the SHARE/UPLOAD option):

followed by this (its quickest if you simply select ‘NO’ to seeing the output - you will see it on the web page) :

followed by this (where in RED is the URL).

Just post the URL you get (similar to the RED URL in my example, but yours will be different).

Again, if you can not get that, then run this with the no upload option:

/usr/sbin/alsa-info.sh --no-upload

which will create the file /tmp/alsa-info.txt.  Copy that file and paste it on [Pastebin.com](http://pastebin.com) and press submit. That will give you a URL address. Please post that URL here.

Also provide the following:

  • in a terminal, or xterm, or konsole, type: rpm -qa ‘alsa#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
  • in a terminal, or xterm, or konsole, type: uname -a #and post output here
  • for openSUSE-11.2 or newer, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

Are you a Gnome user? or a KDE user? That makes a massive difference as to what the problem may be and what solutions should be recommended.

Good luck, and I am reasonably confident that with the appropriate information we will be able to solve the problem.

On 03/06/2011 05:36 PM, tmiller76 wrote:
> Laptop in question is a Dell Latitude E5500. Any ideas?

you don’t say, but i assume you are using KDE4.4.4 on openSUSE 11.3
fully updated…if so open kmix (probably using an icon near the
clock in the panel which looks kinda like a speaker) by left clicking
on the icon, and then on the “Mixer” button, and make sure the “PCM”
slider it not sitting on zero…

on my machine (with my sound card and driver) the “Master” does
nothing at all, and the volume is controlled only by “PCM” (whatever
that is)…

CAVEAT: http://is.gd/bpoMD
[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11

Yes, the reason I’m using 11.4 instead of 11.3 is that the live KDE usb of 11.3 wouldn’t install at all. Every time I tried (2 different downloads to make sure that it wasn’t the image) it would throw up errors with grub and so I couldn’t get it installed. 11.4 installed, so I’m using that. KDE only, personal opinion is that Gnome is uglier than Windows 3.1. :smiley:

Sorry didn’t see the subforum for non-released. Most forums don’t have that, so didn’t think to look (I’m a distro hopper, currently have installs of Debian, Kubuntu, OpenSuse, Fedora, and Arch on real hardware…ummm, well maybe not Arch, it irritated me and I think I removed it).

I’ll post the info from that diagnostic as soon as I can get back on that pc. Thanks!

lol ! Actually, I really like the look of Gnome, but I prefer the flexibility of KDE, so I’m a KDE user.

Now, in KDE, check that the order of sound devices under Kmenu > Configure desktop > multimedia matches the order of devices in YaST > Hardware > Sound.

Also, in Kmenu > Configure desktop > multimedia check the audio back end. You should have a choice of gstreamer or xine.

I recommend you replace all your packman gstreamer apps with packman packaged versions, and replace all your xine apps with packman packaged versions. There are two good stickies here you should read:

Also, try the command with root permissions:

rcalsasound restart

and say yes to get rid of the audio apps it warns you about (or is it no to get rid of them ? - but in any case, when asked get rid of them).
and then type ‘kmix’ (as a regular user) to get your mixer back (if it has not come back already) and then test your sound in firefox again.

I followed the links you gave. I actually had followed the Multi-media and Restricted Format Installation Guide to try to get it working already. The other link, I’d like to point out that it can’t find mmcheck, so that might need to be udpated.

Anyway, replacing the default audio packages with the packman packaged versions fixed it. Works perfectly using the 64-bit flash plugin now. For future installs (I install os’s like some people change pants), is there a simple way to do this? I did zipper install xxx and then just copy/pasted the part where it tells you “use zipper install xxx-xxx” one at a time, which took a rather long time, although it definitely did work. Just wondering if there’s a quicker way to do it.

Thanks greatly.

Well, mmcheck is there, but one needs a small amount of openSUSE experience to find it easily (or be willing to explore the ‘options’ a bit).

Look at this image of the software.opensuse.org: Search Results link:
Look at the red arrows … and instead of “all distributions” select “openSUSE factory” which will correspond to openSUSE-11.4 for your openSUSE-11.4 RC.

I confess I don’t follow what you explained , … but it is simple.

Still, right now the Packman packagers are restructuring their web site, so IMHO best to wait until later this week, when the re-structuring settings down, before I make any recommendations - as there is always the risk that what I recommend today will be out of date tomorrow.