Flash problem on 11.2

Hi,

I’ve got issues with flash on 11.2, youtube and some other sites work fine when playing videos. However other sites with embedded flash movies don’t always work

For example this one
BBC News - Octopus snatches coconut and runs

I click on play and nothing happens. I’ve removed flash and reinstalled but still same issue - this is what I currently have installed.

S | Name | Summary | Type
–±-------------±-----------------------------------------±-------
i | flash-player | Adobe Flash PlugIn and standalone Player | package
i | flash-player | flash-player: Fix compatibility issues | patch

I have read elsewhere that it maybe down to java

And these are the java components I have installed

S | Name | Summary | Type
–±----------------------±-------------------------------------------±-------
i | java-1_6_0-sun | Java™ 6 Runtime Environment | package
i | java-1_6_0-sun | java-1_6_0-sun: Update to security updat-> | patch
i | java-1_6_0-sun-plugin | Browser plugin files for java-1_6_0-sun | package
i | timezone-java | Timezone Descriptions | package

Does anyone have any ideas please?

Thank you

For what its worth BBC Iplayer doesn’t work either.

Thanks

I could see the octopus.

Here are my Java packages:

rpm -qa | grep java

gcc44-java-4.4.1_20090817-2.3.4.x86_64
timezone-java-2009p-1.1.1.noarch
java3d-1.5.2-0.pm.3.1.x86_64
java-1_5_0-gcj-compat-1.5.0.0-107.109.2.x86_64
java-1_6_0-openjdk-plugin-1.6.0.0_b16-5.10.1.x86_64
patterns-openSUSE-devel_java-11.2-20.22.1.x86_64
gcc-java-4.4-4.2.x86_64
ant-javadoc-1.7.1-7.5.noarch
java-1_5_0-gcj-compat-devel-1.5.0.0-107.109.2.x86_64
java-1_6_0-sun-alsa-1.6.0.u17-1.1.1.x86_64
java-1_6_0-openjdk-devel-1.6.0.0_b16-5.10.1.x86_64
ant-javamail-1.7.1-7.5.noarch
java-1_6_0-sun-1.6.0.u17-1.1.1.x86_64
java-1_6_0-openjdk-1.6.0.0_b16-5.10.1.x86_64

Hmm - ok thanks. I’m running 32bit Opensuse. Is it worth me trying to find 32bit versions of those missing packages?

Thanks

Istalling more packages will not hurt: install from repositories all relevant packages.

I am running 64 bit.

I’ve got the same problem running 64bit openSUSE 11.2 Given that everything had been working fine in the weeks since 11.2 was installed right up until about two days ago (Dec 13th or so), I wonder if some sort of update caused the problem? Interestingly, other controls in Flash still work. For example, I can make Flash full screen, change the volume, move the slider as if changing where in movie I was.

Hmm It plays for me. 64bit 11.2 no special installs

For the record: the coconut loses.

OK, this is odd. When I log in as root, Flash works fine. Is there any security setup with Flash?

either uninstall nspluginwrapper or
edit /usr/lib/nspluginwrapper/i386/linux/npviewer (for 32bit system)
add
export GDK_NATIVE_WINDOWS=1

Quit all firefoxes. Rename or remove ~/.mozilla/ Reboot. Start firefox.

Alternatively, you can create a new user. Don’t copy . files from your home to new user. Most othe files can be copied.

Spot on! That worked great - thank you. What does that do anyway?

In case this helps anyone, (as mentioned) I have the problem with my main user and not with root. I then found that the problem persisted when I booted over to Windows. I tried uninstalling and reinstalling in Windows without success, and even ran CCleaner (again, in Windows). Finally I disabled the Firefox add-on Adblock Plus and that solved the problem.